Fix build on NetBSD.

This commit is contained in:
joerg 2015-02-05 17:34:09 +00:00
parent 2d6e8329c0
commit 951901fef9
2 changed files with 24 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2015/01/31 21:46:48 adam Exp $
$NetBSD: distinfo,v 1.5 2015/02/05 17:34:09 joerg Exp $
SHA1 (libaacs-0.8.0.tar.bz2) = 667fd744ddd73c8a3e51192dd3822f7e5002883c
RMD160 (libaacs-0.8.0.tar.bz2) = fb27b9a65b3902ce66671a9d3578acba4f50604b
Size (libaacs-0.8.0.tar.bz2) = 311904 bytes
SHA1 (patch-src_file_file__posix.c) = 0e4b7849f2b3c9c13f71132bbb13216c758a6b14
SHA1 (patch-src_file_mmc__device__linux.c) = 7e88ad3c842443f36feb970ddf2f6f4f01b83803

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_file_mmc__device__linux.c,v 1.1 2015/02/05 17:34:09 joerg Exp $
--- src/file/mmc_device_linux.c.orig 2015-02-04 13:50:55.000000000 +0000
+++ src/file/mmc_device_linux.c
@@ -32,6 +32,7 @@
#include "util/strutl.h"
#include <stdlib.h>
+#include <stdio.h>
#include <string.h>
#include <unistd.h>
#include <fcntl.h>
@@ -180,8 +181,8 @@ MMCDEV *device_open(const char *path)
} else {
BD_DEBUG(DBG_MMC | DBG_CRIT, "Error opening /proc/mounts\n");
}
-#endif
}
+#endif
if (fd >= 0) {
dev = calloc(1, sizeof(MMCDEV));