p11-kit: Fix build on FreeBSD
The build step failed on FreeBSD due to undeclared SIZE_MAX. This error has been fixed upstream (https://github.com/p11-glue/p11-kit/commit/507c394) and the patch could be removed at the next update.
This commit is contained in:
parent
0004da290d
commit
951eda4d02
3 changed files with 20 additions and 3 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.18 2021/01/04 11:43:47 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2021/01/08 21:09:08 triaxx Exp $
|
||||
|
||||
DISTNAME= p11-kit-0.23.22
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= security
|
||||
#MASTER_SITES= http://p11-glue.freedesktop.org/releases/
|
||||
MASTER_SITES+= ${MASTER_SITE_GITHUB:=p11-glue/}
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.13 2021/01/04 11:43:47 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.14 2021/01/08 21:09:08 triaxx Exp $
|
||||
|
||||
SHA1 (p11-kit-0.23.22.tar.xz) = 339e5163ed50a9984a74739b9207ea8cd77fa7e2
|
||||
RMD160 (p11-kit-0.23.22.tar.xz) = 35bc18cde9610ceb1a4c1c167360b7ef4a81288d
|
||||
SHA512 (p11-kit-0.23.22.tar.xz) = 098819e6ca4ad9cc2a0bc2e478aea67354d051a4f03e6c7d75d13d2469b6dc7654f26b15530052f6ed51acb35531c2539e0f971b31e29e6673e857c903afb080
|
||||
Size (p11-kit-0.23.22.tar.xz) = 830016 bytes
|
||||
SHA1 (patch-Makefile.in) = 1393b1c8892e90362575d5d325a583921f629b3c
|
||||
SHA1 (patch-common_compat.c) = bdcb10cebe5e7755c81f88ef033b9dfecd7a1aad
|
||||
SHA1 (patch-Makefile.in) = 1393b1c8892e90362575d5d325a583921f629b3c
|
||||
SHA1 (patch-p11-kit_lists.c) = 5834dd7cb09de7776205dac0a21a31a5ad5f3dae
|
||||
|
|
15
security/p11-kit/patches/patch-p11-kit_lists.c
Normal file
15
security/p11-kit/patches/patch-p11-kit_lists.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-p11-kit_lists.c,v 1.1 2021/01/08 21:09:08 triaxx Exp $
|
||||
|
||||
Add missing header for SIZE_MAX on FreeBSD.
|
||||
https://github.com/p11-glue/p11-kit/commit/507c394
|
||||
|
||||
--- p11-kit/lists.c.orig 2021-01-08 21:05:52.577818000 +0100
|
||||
+++ p11-kit/lists.c
|
||||
@@ -39,6 +39,7 @@
|
||||
|
||||
#include <assert.h>
|
||||
#include <ctype.h>
|
||||
+#include <stdint.h>
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
Loading…
Reference in a new issue