Remove "libXvMCW" package. The "libXvMCW" library is provided by the
"libXvMC" package which now has proper builtin detection.
This commit is contained in:
parent
a813865530
commit
952e7b21e4
8 changed files with 1 additions and 129 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.626 2011/01/19 00:42:55 jmcneill Exp $
|
||||
# $NetBSD: Makefile,v 1.627 2011/01/19 17:52:06 tron Exp $
|
||||
#
|
||||
|
||||
COMMENT= Packages to support the X window system
|
||||
|
@ -224,7 +224,6 @@ SUBDIR+= libXt
|
|||
SUBDIR+= libXtst
|
||||
SUBDIR+= libXv
|
||||
SUBDIR+= libXvMC
|
||||
SUBDIR+= libXvMCW
|
||||
SUBDIR+= libXxf86dga
|
||||
SUBDIR+= libXxf86misc
|
||||
SUBDIR+= libXxf86vm
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
libXvMC is a wrapper for XvMC libraries that allows the X server or user to
|
||||
specify the hardware dependent XvMC library at run-time.
|
|
@ -1,31 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libXvMCW-0.9.3
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=unichrome/}XvMC%20Wrapper/release-0.9.3/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://unichrome.sourceforge.net/
|
||||
COMMENT= Wrapper for run-time loading of XvMC libraries
|
||||
LICENSE= mit
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/libXvMCW
|
||||
CONF_FILES= ${EGDIR}/XvMCConfig ${PKG_SYSCONFDIR}/XvMCConfig
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
INSTALLATION_DIRS= ${EGDIR}
|
||||
CONFIGURE_ARGS+= --with-config-path=${PKG_SYSCONFDIR}
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/XvMCConfig ${DESTDIR}${EGDIR}
|
||||
|
||||
.include "../../x11/libXvMC/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,4 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
include/X11/extensions/vldXvMC.h
|
||||
lib/libXvMCW.la
|
||||
share/examples/libXvMCW/XvMCConfig
|
|
@ -1,14 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
|
||||
BUILDLINK_TREE+= libXvMCW
|
||||
|
||||
.if !defined(LIBXVMCW_BUILDLINK3_MK)
|
||||
LIBXVMCW_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libXvMCW+= libXvMCW>=0.9.3
|
||||
BUILDLINK_PKGSRCDIR.libXvMCW?= ../../x11/libXvMCW
|
||||
|
||||
.include "../../x11/libXvMC/buildlink3.mk"
|
||||
.endif # LIBXVMCW_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libXvMCW
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
|
||||
SHA1 (libXvMCW-0.9.3.tar.gz) = d7ec5243bc4fc6afe2f391c3023c3ad820f89d2f
|
||||
RMD160 (libXvMCW-0.9.3.tar.gz) = 7da779dbddbb054114b798690c0ae87abac938bf
|
||||
Size (libXvMCW-0.9.3.tar.gz) = 193316 bytes
|
||||
SHA1 (patch-aa) = 6e8d9b21ffa37dbdc38b60a0882b8b234d604212
|
||||
SHA1 (patch-ab) = 038a070bbac3191ed1bf5f88a58c18b11a1671d4
|
|
@ -1,27 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
|
||||
Install to PREFIX instead of X11BASE, and don't install the config file to
|
||||
PREFIX/etc
|
||||
|
||||
--- Makefile.in.orig 2004-11-18 15:26:09.000000000 -0500
|
||||
+++ Makefile.in 2011-01-18 19:13:57.000000000 -0500
|
||||
@@ -178,8 +178,8 @@
|
||||
target_alias = @target_alias@
|
||||
INCLUDES = @WINCLUDES@
|
||||
EXTRA_DIST = reconf libXvMCW.spec
|
||||
-xincludedir = @XEXTINCLUDE@
|
||||
-xlibdir = @XLIB@
|
||||
+xincludedir = @prefix@/include/X11/extensions
|
||||
+xlibdir = @prefix@/lib
|
||||
xconfigdir = @XCONFIG@
|
||||
xinclude_HEADERS = vldXvMC.h
|
||||
xconfig_HEADERS = XvMCConfig
|
||||
@@ -574,7 +574,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-xconfigHEADERS install-xincludeHEADERS \
|
||||
+install-data-am: install-xincludeHEADERS \
|
||||
install-xlibLTLIBRARIES
|
||||
|
||||
install-exec-am:
|
|
@ -1,42 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2011/01/19 00:42:12 jmcneill Exp $
|
||||
|
||||
Don't use == operator in configure script
|
||||
|
||||
--- configure.orig 2011-01-18 19:39:33.000000000 -0500
|
||||
+++ configure 2011-01-18 19:39:53.000000000 -0500
|
||||
@@ -8338,7 +8338,7 @@
|
||||
xv_version="no"
|
||||
fi
|
||||
|
||||
-if test x$xv_version == "xno"; then
|
||||
+if test x$xv_version = "xno"; then
|
||||
as_ac_File=`echo "ac_cv_file_$x_libraries/libXv.so.1.0" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $x_libraries/libXv.so.1.0" >&5
|
||||
echo $ECHO_N "checking for $x_libraries/libXv.so.1.0... $ECHO_C" >&6
|
||||
@@ -8364,7 +8364,7 @@
|
||||
fi
|
||||
|
||||
fi
|
||||
-if test x$xv_version == "xno"; then
|
||||
+if test x$xv_version = "xno"; then
|
||||
xv_version=""
|
||||
echo "*** Warning. Could not find a dynamic libXv.so library."
|
||||
echo "*** This may cause run-time failures when the hardware-specific"
|
||||
@@ -8399,7 +8399,7 @@
|
||||
xvmc_version="no"
|
||||
fi
|
||||
|
||||
-if test x$xvmc_version == "xno"; then
|
||||
+if test x$xvmc_version = "xno"; then
|
||||
as_ac_File=`echo "ac_cv_file_$x_libraries/libXvMC.so.1.0" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $x_libraries/libXvMC.so.1.0" >&5
|
||||
echo $ECHO_N "checking for $x_libraries/libXvMC.so.1.0... $ECHO_C" >&6
|
||||
@@ -8425,7 +8425,7 @@
|
||||
fi
|
||||
|
||||
fi
|
||||
-if test x$xvmc_version == "xno"; then
|
||||
+if test x$xvmc_version = "xno"; then
|
||||
{ { echo "$as_me:$LINENO: error: Could not find a libXvMC.so dynamic library. Aborting." >&5
|
||||
echo "$as_me: error: Could not find a libXvMC.so dynamic library. Aborting." >&2;}
|
||||
{ (exit 1); exit 1; }; }
|
Loading…
Reference in a new issue