Move gxine to the multimedia category (coming from graphics).
This is version 0.3.3nb5.
This commit is contained in:
parent
ffc4bae8e0
commit
9536979561
10 changed files with 127 additions and 0 deletions
2
multimedia/gxine/DESCR
Normal file
2
multimedia/gxine/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
Gxine is a gtk2 multimedia player that uses xine-lib to decode
|
||||
multimedia streams.
|
23
multimedia/gxine/Makefile
Normal file
23
multimedia/gxine/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/01/26 13:18:06 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gxine-0.3.3
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xine/}
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://xinehq.de/
|
||||
COMMENT= Gtk-based media player
|
||||
|
||||
USE_BUILDLINK2= YES
|
||||
USE_X11= YES
|
||||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
.include "../../devel/glib2/buildlink2.mk"
|
||||
.include "../../multimedia/xine-lib/buildlink2.mk"
|
||||
.include "../../x11/gtk2/buildlink2.mk"
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
17
multimedia/gxine/PLIST
Normal file
17
multimedia/gxine/PLIST
Normal file
|
@ -0,0 +1,17 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
bin/gxine
|
||||
bin/gxine_client
|
||||
lib/gxine/gxineplugin.a
|
||||
lib/gxine/gxineplugin.la
|
||||
lib/gxine/gxineplugin.so
|
||||
man/man1/gxine.1
|
||||
share/gnome/apps/Multimedia/gxine.desktop
|
||||
share/gxine/logo.mpv
|
||||
share/gxine/mediamarks
|
||||
share/gxine/pixmaps/gxine-icon.xpm
|
||||
share/gxine/pixmaps/gxine-logo.png
|
||||
share/gxine/pixmaps/splash.png
|
||||
share/gxine/pixmaps/wizards.png
|
||||
@dirrm share/gxine/pixmaps
|
||||
@dirrm share/gxine
|
||||
@dirrm lib/gxine
|
10
multimedia/gxine/distinfo
Normal file
10
multimedia/gxine/distinfo
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/01/26 13:18:06 jmmv Exp $
|
||||
|
||||
SHA1 (gxine-0.3.3.tar.gz) = 15408d790a3860226e5967153469bc82c886ce1e
|
||||
Size (gxine-0.3.3.tar.gz) = 1038778 bytes
|
||||
SHA1 (patch-aa) = f44ea3e755465d1b2a52f254782eb8c9e28e9ee1
|
||||
SHA1 (patch-ab) = 581122a87dd3ea1a61b434ba721866efd3455ab6
|
||||
SHA1 (patch-ac) = da2834d8d5b5f1994d000203864f9e20ee3a51e0
|
||||
SHA1 (patch-ad) = 8084ae91ef7b6bb3cf4ab1e87e6efad32eb20ade
|
||||
SHA1 (patch-ae) = 583066425c63cff4d42fa953398ae417e798eb07
|
||||
SHA1 (patch-af) = 0bf58de7d5d3a50731d30623bc76732e8d2f771f
|
12
multimedia/gxine/patches/patch-aa
Normal file
12
multimedia/gxine/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- src/globals.h.orig Fri Mar 7 02:51:04 2003
|
||||
+++ src/globals.h
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <gtk/gtk.h>
|
||||
#include <gdk/gdk.h>
|
||||
#include <glib.h>
|
||||
+#include <pthread.h>
|
||||
|
||||
#include "infobar.h"
|
||||
|
12
multimedia/gxine/patches/patch-ab
Normal file
12
multimedia/gxine/patches/patch-ab
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- src/http.c.orig Wed Mar 19 09:22:55 2003
|
||||
+++ src/http.c
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netdb.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <string.h>
|
14
multimedia/gxine/patches/patch-ac
Normal file
14
multimedia/gxine/patches/patch-ac
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- src/desktop_integration.c.orig Mon Nov 25 22:19:27 2002
|
||||
+++ src/desktop_integration.c
|
||||
@@ -30,7 +30,9 @@
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <dlfcn.h>
|
||||
+#ifndef __NetBSD__
|
||||
#include <alloca.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
|
||||
#include "globals.h"
|
12
multimedia/gxine/patches/patch-ad
Normal file
12
multimedia/gxine/patches/patch-ad
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- src/gtkxine.h.orig Sun Mar 9 09:27:27 2003
|
||||
+++ src/gtkxine.h
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <X11/X.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include <X11/extensions/XShm.h>
|
||||
+#include <pthread.h>
|
||||
#include <xine.h>
|
||||
|
||||
#ifdef __cplusplus
|
12
multimedia/gxine/patches/patch-ae
Normal file
12
multimedia/gxine/patches/patch-ae
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- browser-plugin/plugin.c.orig 2003-04-11 17:31:44.000000000 +1000
|
||||
+++ browser-plugin/plugin.c
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
+#include <signal.h>
|
||||
#include <dlfcn.h>
|
||||
#include <errno.h>
|
||||
#include <X11/X.h>
|
13
multimedia/gxine/patches/patch-af
Normal file
13
multimedia/gxine/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2004/01/26 13:18:07 jmmv Exp $
|
||||
|
||||
--- doc/man/Makefile.in.orig Sat Apr 5 18:50:43 2003
|
||||
+++ doc/man/Makefile.in
|
||||
@@ -108,7 +108,7 @@ X_PRE_LIBS = @X_PRE_LIBS@
|
||||
am__include = @am__include@
|
||||
am__quote = @am__quote@
|
||||
install_sh = @install_sh@
|
||||
-SUBDIRS = en de
|
||||
+SUBDIRS = en
|
||||
subdir = doc/man
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/include/config.h
|
Loading…
Reference in a new issue