geography/gpsd: Update to 3.24

3.24: 2022-04-22
  NTRIP 2.0 now works.  But still only plain HTML, not RTP, etc.
  Remove ntrip option and NTRIP_ENABLE.  Always build.
  Remove passthrough option and PASSTHROUGH_ENABLE.  Always build.
  Remove nmea0183 option and NMEA0183_ENABLE.  Always build.
  Remove netfeed option and NETFEED_ENABLE.  Always build.
  gpsd will retry ntrip:// and tcp:// connections
  cgps can expand to show more sats. Added --rtk option.
  maidenhead() checks for input errors.
  Better SHM logs.
  PPS and TOFF JSON now include shm used, and real precision.
  Add initial, untested, TSIPv1 support
  split debug messages into different syslog() levels.
  New ppscheck options, and can use /dev/ppsX devices.
  First try at TSIPv1 protocol decodes.
  Decode Quectel $PQVERNO for firmware version
  Decode Skytrak PX1172RH_DS messages.
This commit is contained in:
gdt 2022-04-28 11:43:14 +00:00
parent bfcf425116
commit 953e51cf79
4 changed files with 12 additions and 41 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.62 2022/01/28 12:06:04 wiz Exp $
# $NetBSD: Makefile,v 1.63 2022/04/28 11:43:14 gdt Exp $
DISTNAME= gpsd-3.23.1
PKGREVISION= 1
DISTNAME= gpsd-3.24
CATEGORIES= geography
MASTER_SITES= http://download-mirror.savannah.gnu.org/releases/gpsd/
# will probably switch to https://gitlab.com/gpsd/gpsd/releases
@ -84,16 +83,9 @@ PLIST_SUBST+= PLIST_SO=.so
PLIST_SUBST+= PLIST_DYLIB=
.endif
# \todo Consider not including this and using the pre-built man pages.
.include "../../lang/ruby/rubyversion.mk"
TOOL_DEPENDS+= ${RUBY_PKGPREFIX}-asciidoctor>=2.0.0:../../textproc/ruby-asciidoctor
SUBST_CLASSES+= ad
SUBST_STAGE.ad= pre-build
SUBST_MESSAGE.ad= Correcting the asciidoctor binary name.
SUBST_FILES.ad+= SConscript
SUBST_SED.ad+= -e "s,asciidoctor26,asciidoctor${RUBY_SUFFIX},g"
# \todo Change to TOOLS or BUILD_DEPENDS after scons support is improved.
.include "../../devel/scons/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.18 2021/08/08 23:14:46 gdt Exp $
@comment $NetBSD: PLIST,v 1.19 2022/04/28 11:43:14 gdt Exp $
bin/cgps
bin/gegps
bin/gps2udp
@ -26,10 +26,10 @@ include/gps.h
include/libgpsmm.h
lib/libgps${PLIST_SO}${PLIST_DYLIB}
lib/libgps${PLIST_SO}.29${PLIST_DYLIB}
lib/libgps${PLIST_SO}.29.0.0${PLIST_DYLIB}
lib/libgps${PLIST_SO}.29.0.1${PLIST_DYLIB}
lib/libgpsdpacket${PLIST_SO}${PLIST_DYLIB}
lib/libgpsdpacket${PLIST_SO}.29${PLIST_DYLIB}
lib/libgpsdpacket${PLIST_SO}.29.0.0${PLIST_DYLIB}
lib/libgpsdpacket${PLIST_SO}.29.0.1${PLIST_DYLIB}
lib/pkgconfig/libgps.pc
${PYSITELIB}/gps-${PKGVERSION}.egg-info
${PYSITELIB}/gps/__init__.py

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.35 2022/01/02 11:59:05 ryoon Exp $
$NetBSD: distinfo,v 1.36 2022/04/28 11:43:14 gdt Exp $
BLAKE2s (gpsd-3.23.1.tar.gz) = 1f5ecdc768d95f384055cdb564f292a289c250552911b6822ef1a09e420ffda1
SHA512 (gpsd-3.23.1.tar.gz) = fccfac363103282581e4ea8236ce40e4600a01f02489c1aaec721a13deac556bac046a3b76f8a5e21fe8c736056e872d8c7f2e4ed2d38a164323dd9738f00388
Size (gpsd-3.23.1.tar.gz) = 4904121 bytes
SHA1 (patch-SConscript) = 2b8175fdb66f6ca7efe7ec71eb5ff91af5d18e6f
BLAKE2s (gpsd-3.24.tar.gz) = daaca7f934b778990bcb35882cfcb42c62b253137324d547febed2df5ed6bdf2
SHA512 (gpsd-3.24.tar.gz) = 250bae709e19ac10421d5a537e68dcdf4c025071c152cf3c84a2f6977615bd7e445a45f3b1e5f3b64123fad3c11e1ec256bae5afc1b869f499b187116f8b028b
Size (gpsd-3.24.tar.gz) = 5152429 bytes
SHA1 (patch-SConscript) = 5d042bb9d6547c7f78ea8f37b1d12963d49584b6

View file

@ -1,32 +1,11 @@
$NetBSD: patch-SConscript,v 1.5 2022/01/02 11:59:06 ryoon Exp $
$NetBSD: patch-SConscript,v 1.6 2022/04/28 11:43:15 gdt Exp $
gpspipe requires libgpsd for serial.c cfmakeraw() compat.
\todo Fix upstream?
Support Python 3.10 or later.
--- SConscript.orig 2021-09-21 21:53:44.000000000 +0000
+++ SConscript
@@ -1516,15 +1516,13 @@ if not cleaning and not helping and conf
# announce(python_config)
# aiogps is only available on Python >= 3.6
- sysver = config.GetPythonValue('target version',
- 'import sys',
- '"%d.%d" % sys.version_info[0:2]')
+ sysver = sys.version_info
- if 3 > int(sysver[0]) or 6 > int(sysver[2]):
+ if 3 > sysver[0] or 6 > sysver[1]:
config.env['aiogps'] = False
announce("WARNING: Python%s too old (need 3.6): "
"gps/aiogps.py will not be installed" %
- (sysver), end=True)
+ (str(sysver[0]) + "." + str(sysver[1])), end=True)
else:
config.env['aiogps'] = True
@@ -1930,7 +1928,7 @@ gpsmon = env.Program('gpsmon/gpsmon', gp
@@ -1930,7 +1930,7 @@ gpsmon = env.Program('gpsmon/gpsmon', gp
LIBS=[libgpsd_static, libgps_static],
parse_flags=gpsdflags + gpsflags + ncurseslibs)
gpspipe = env.Program('clients/gpspipe', ['clients/gpspipe.c'],