Initial import of p5-Git-CPAN-Patch version 0.4.4 in the NetBSD
Packages Collection. The Perl 5 module Git::CPAN::Patch provides a suite of git commands aimed at making trivially easy the process of grabbing any distribution off CPAN, stuffing it in a local git repository and, once gleeful hacking has been perpetrated, sending back patches to its maintainer.
This commit is contained in:
parent
33d8b3289c
commit
9545b6d0e6
4 changed files with 73 additions and 0 deletions
4
devel/p5-Git-CPAN-Patch/DESCR
Normal file
4
devel/p5-Git-CPAN-Patch/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
The Perl 5 module Git::CPAN::Patch provides a suite of git commands
|
||||
aimed at making trivially easy the process of grabbing any distribution
|
||||
off CPAN, stuffing it in a local git repository and, once gleeful
|
||||
hacking has been perpetrated, sending back patches to its maintainer.
|
29
devel/p5-Git-CPAN-Patch/Makefile
Normal file
29
devel/p5-Git-CPAN-Patch/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/07/11 22:41:59 seb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Git-CPAN-Patch-0.4.4
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Git/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://search.cpan.org/dist/Git-CPAN-Patch/
|
||||
COMMENT= Patch CPAN modules using Git
|
||||
LICENSE= ${PERL5_LICENSE}
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
PERL5_MODULE_TYPE= Module::Build
|
||||
|
||||
USE_LANGUAGES= # empty
|
||||
PERL5_PACKLIST= auto/Git/CPAN/Patch/.packlist
|
||||
|
||||
DEPENDS+= scmgit-base-[0-9]*:../../devel/scmgit-base
|
||||
DEPENDS+= p5-BackPAN-Index>=0.39:../../devel/p5-BackPAN-Index
|
||||
DEPENDS+= p5-CLASS-[0-9]*:../../devel/p5-CLASS
|
||||
DEPENDS+= p5-File-Temp>=0.22:../../devel/p5-File-Temp
|
||||
DEPENDS+= p5-File-chdir-[0-9]*:../../devel/p5-File-chdir
|
||||
DEPENDS+= p5-File-chmod-[0-9]*:../../sysutils/p5-File-chmod
|
||||
DEPENDS+= p5-autodie-[0-9]*:../../devel/p5-autodie
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
devel/p5-Git-CPAN-Patch/distinfo
Normal file
6
devel/p5-Git-CPAN-Patch/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/07/11 22:41:59 seb Exp $
|
||||
|
||||
SHA1 (Git-CPAN-Patch-0.4.4.tar.gz) = 71504dd69febb23e05dcf00d9b4114e74f983f8c
|
||||
RMD160 (Git-CPAN-Patch-0.4.4.tar.gz) = 36542951a95af932ee9323c005bd910cae12f836
|
||||
Size (Git-CPAN-Patch-0.4.4.tar.gz) = 19824 bytes
|
||||
SHA1 (patch-aa) = 7c37008e8321f0d04e12d3f3efe7717a7c593d55
|
34
devel/p5-Git-CPAN-Patch/patches/patch-aa
Normal file
34
devel/p5-Git-CPAN-Patch/patches/patch-aa
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/07/11 22:41:59 seb Exp $
|
||||
|
||||
Prevent a prototype error between File::chmod::chmod() and CORE::chmod()
|
||||
|
||||
--- lib/Git/CPAN/Patch/Import.pm.orig 2010-06-08 01:03:43.000000000 +0000
|
||||
+++ lib/Git/CPAN/Patch/Import.pm
|
||||
@@ -13,7 +13,7 @@ use autodie;
|
||||
use Archive::Extract;
|
||||
$Archive::Extract::PREFER_BIN = 1;
|
||||
|
||||
-use File::chmod;
|
||||
+use File::chmod qw();
|
||||
use File::Find;
|
||||
use File::Basename;
|
||||
use File::Spec::Functions;
|
||||
@@ -47,9 +47,9 @@ sub cpanplus {
|
||||
sub _fix_permissions {
|
||||
my $dir = shift;
|
||||
|
||||
- chmod "u+rx", $dir;
|
||||
+ File::chmod::chmod "u+rx", $dir;
|
||||
find(sub {
|
||||
- -d $_ ? chmod "u+rx", $_ : chmod "u+r", $_;
|
||||
+ -d $_ ? File::chmod::chmod "u+rx", $_ : File::chmod::chmod "u+r", $_;
|
||||
}, $dir);
|
||||
}
|
||||
|
||||
@@ -584,4 +584,4 @@ as a function so git-backpan-init goes f
|
||||
|
||||
=cut
|
||||
|
||||
-1;
|
||||
\ No newline at end of file
|
||||
+1;
|
Loading…
Reference in a new issue