Fix some C++ issues that gcc 3.3 complained on.
This commit is contained in:
parent
baa897ed35
commit
95b6e0e52c
14 changed files with 287 additions and 1 deletions
|
@ -1,4 +1,17 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/12/04 10:01:44 wulf Exp $
|
||||
$NetBSD: distinfo,v 1.2 2004/06/15 17:48:35 kristerw Exp $
|
||||
|
||||
SHA1 (uml-1.0.3-1.tar.gz) = da2c249c31d0890d856e6c9578db8eec07d59032
|
||||
Size (uml-1.0.3-1.tar.gz) = 783519 bytes
|
||||
SHA1 (patch-aa) = 569fdb15462e2c99f7abc815c0908dfe65c526c4
|
||||
SHA1 (patch-ab) = 04a07a62c238841e8ca06f5a7ee0594009842581
|
||||
SHA1 (patch-ac) = f0b0320b421aaed3c669d4970a68681660db95a3
|
||||
SHA1 (patch-ad) = 7c0e79b6415482ab940169b52d2a0cd2486cfa83
|
||||
SHA1 (patch-ae) = 4603bb58c78c1628d0fc89953176d56d2fc0172d
|
||||
SHA1 (patch-af) = 8d7cb24713c981b23af375ba09882158fe6fbea6
|
||||
SHA1 (patch-ag) = 960d49bf338b05ce0d45b176301f79f7641bd2b8
|
||||
SHA1 (patch-ah) = b8ebebbacbdcba578db8985e8ecbb965fa9f4ae1
|
||||
SHA1 (patch-ai) = 4ed510a5d066c818a210a6e8ab20a6dbbfb94a69
|
||||
SHA1 (patch-aj) = c3facd7145132010a5ff83db83ed4061f1321609
|
||||
SHA1 (patch-ak) = e2127e7bc29281a581d02dcdc1a4a66f1d915b19
|
||||
SHA1 (patch-al) = c29453965b9d7ca2ffa92cd4007dc6601c77d3fb
|
||||
SHA1 (patch-am) = bdb2adfcbd1e09aa42bb4aa3ad172752f8709385
|
||||
|
|
29
devel/uml/patches/patch-aa
Normal file
29
devel/uml/patches/patch-aa
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- uml/association.cpp.orig 2004-06-15 19:35:27.000000000 +0200
|
||||
+++ uml/association.cpp 2004-06-15 19:36:19.000000000 +0200
|
||||
@@ -203,7 +203,7 @@
|
||||
wB = view -> findWidget(bID);
|
||||
if(!wA || !wB)
|
||||
{
|
||||
- cerr<<"Can't make association"<<endl;
|
||||
+ std::cerr<<"Can't make association"<<std::endl;
|
||||
return false;
|
||||
}
|
||||
if(assoc == 408)
|
||||
@@ -252,7 +252,7 @@
|
||||
wB = view -> findWidget(bID);
|
||||
if(!wA || !wB)
|
||||
{
|
||||
- cerr<<"Can't make association"<<endl;
|
||||
+ std::cerr<<"Can't make association"<<std::endl;
|
||||
return false;
|
||||
}
|
||||
|
||||
@@ -302,7 +302,7 @@
|
||||
wB = view -> findWidget(bID);
|
||||
if(!wA || !wB)
|
||||
{
|
||||
- cerr<<"Can't make association"<<endl;
|
||||
+ std::cerr<<"Can't make association"<<std::endl;
|
||||
return false;
|
||||
}
|
||||
|
11
devel/uml/patches/patch-ab
Normal file
11
devel/uml/patches/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/classattpage.cpp.orig 2004-06-15 19:34:42.000000000 +0200
|
||||
+++ uml/classattpage.cpp 2004-06-15 19:35:19.000000000 +0200
|
||||
@@ -283,7 +283,7 @@
|
||||
Attribute * a = (Attribute *)concept -> findChildObject(ATTRIBUTE, s);
|
||||
if(!a && id != NEWATT)
|
||||
{
|
||||
- cerr<<"can't find att from selection"<<endl;
|
||||
+ std::cerr<<"can't find att from selection"<<std::endl;
|
||||
return;
|
||||
}
|
||||
switch(id)
|
26
devel/uml/patches/patch-ac
Normal file
26
devel/uml/patches/patch-ac
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- uml/classopspage.cpp.orig 2004-06-15 19:33:30.000000000 +0200
|
||||
+++ uml/classopspage.cpp 2004-06-15 19:34:27.000000000 +0200
|
||||
@@ -308,12 +308,12 @@
|
||||
oldA = o -> findParm( parmsLB -> currentText());
|
||||
if(!o)
|
||||
{
|
||||
- cerr<<"can't find op from selection"<<endl;
|
||||
+ std::cerr<<"can't find op from selection"<<std::endl;
|
||||
return;
|
||||
}
|
||||
if(id == RENAME || id == PROPERTIES)
|
||||
{
|
||||
- if(!oldA){cerr<<"THE impossible has occurred for:"<<parmsLB -> currentText()<<endl;
|
||||
+ if(!oldA){std::cerr<<"THE impossible has occurred for:"<<parmsLB -> currentText()<<std::endl;
|
||||
return;}//should never occur
|
||||
ParmPropDlg d((QWidget *)doc, oldA);
|
||||
result = d.exec();
|
||||
@@ -420,7 +420,7 @@
|
||||
Operation * o = (Operation *)concept -> findChildObject(OPERATION, s);
|
||||
if(!o && id != NEWOP)
|
||||
{
|
||||
- cerr<<"can't find op from selection"<<endl;
|
||||
+ std::cerr<<"can't find op from selection"<<std::endl;
|
||||
return;
|
||||
}
|
||||
switch(id)
|
11
devel/uml/patches/patch-ad
Normal file
11
devel/uml/patches/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/classpropdlg.cpp.orig 2004-06-15 19:32:55.000000000 +0200
|
||||
+++ uml/classpropdlg.cpp 2004-06-15 19:33:20.000000000 +0200
|
||||
@@ -87,7 +87,7 @@
|
||||
UMLObject * o = ((Concept*)object) -> findChildObject(id);
|
||||
if(o)
|
||||
doc -> signalChildUMLObjectUpdate(o);
|
||||
- else cerr<<"slot dlg: can't find child"<<endl;
|
||||
+ else std::cerr<<"slot dlg: can't find child"<<std::endl;
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
void ClassPropDlg::slotApply()
|
20
devel/uml/patches/patch-ae
Normal file
20
devel/uml/patches/patch-ae
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- uml/concept.cpp.orig 2004-06-15 19:32:07.000000000 +0200
|
||||
+++ uml/concept.cpp 2004-06-15 19:32:46.000000000 +0200
|
||||
@@ -30,7 +30,7 @@
|
||||
{
|
||||
if(!attsList.remove((Attribute *)a))
|
||||
{
|
||||
- cerr<<"can't find att given in list"<<endl;
|
||||
+ std::cerr<<"can't find att given in list"<<std::endl;
|
||||
return -1;
|
||||
}
|
||||
return attsList.count();
|
||||
@@ -47,7 +47,7 @@
|
||||
{
|
||||
if(!opsList.remove((Operation *)o))
|
||||
{
|
||||
- cerr<<"can't find opp given in list"<<endl;
|
||||
+ std::cerr<<"can't find opp given in list"<<std::endl;
|
||||
return -1;
|
||||
}
|
||||
return opsList.count();
|
11
devel/uml/patches/patch-af
Normal file
11
devel/uml/patches/patch-af
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/diagramprintpage.cpp.orig 2004-06-15 19:20:34.000000000 +0200
|
||||
+++ uml/diagramprintpage.cpp 2004-06-15 19:21:13.000000000 +0200
|
||||
@@ -71,7 +71,7 @@
|
||||
disconnect(typeCB, SIGNAL(activated(const QString&)), this, SLOT(slotActivated(const QString&)));
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
-void DiagramPrintPage::getOptions( QMap<QString,QString>& opts, bool incldef = false )
|
||||
+void DiagramPrintPage::getOptions( QMap<QString,QString>& opts, bool incldef )
|
||||
{
|
||||
int listCount = selectLB -> count();
|
||||
int count = 0;
|
20
devel/uml/patches/patch-ag
Normal file
20
devel/uml/patches/patch-ag
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- uml/floatingtext.cpp.orig 2004-06-15 19:31:02.000000000 +0200
|
||||
+++ uml/floatingtext.cpp 2004-06-15 19:31:35.000000000 +0200
|
||||
@@ -19,7 +19,7 @@
|
||||
init();
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
-FloatingText::FloatingText(QWidget * parent, bool copying = false) : UMLWidget(parent, copying)
|
||||
+FloatingText::FloatingText(QWidget * parent, bool copying) : UMLWidget(parent, copying)
|
||||
{
|
||||
text = "";
|
||||
role = type = UNDEFINED;
|
||||
@@ -175,7 +175,7 @@
|
||||
{
|
||||
//here to delete assoc./message on collab diagram.
|
||||
if(!assoc)
|
||||
- {cerr<<"Error in floating text:no assoc set."<<endl;return;}
|
||||
+ {std::cerr<<"Error in floating text:no assoc set."<<std::endl;return;}
|
||||
view -> getWidgetAssocContainer() -> removeAssoc(assoc);
|
||||
return;
|
||||
}
|
11
devel/uml/patches/patch-ah
Normal file
11
devel/uml/patches/patch-ah
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/messagewidget.cpp.orig 2004-06-15 19:30:28.000000000 +0200
|
||||
+++ uml/messagewidget.cpp 2004-06-15 19:30:43.000000000 +0200
|
||||
@@ -201,7 +201,7 @@
|
||||
connect(wB, SIGNAL(sigWidgetMoved(int)), this, SLOT(slotWidgetMoved(int)));
|
||||
if(!wA || !wB)
|
||||
{
|
||||
- cerr<<"Can't make message"<<endl;
|
||||
+ std::cerr<<"Can't make message"<<std::endl;
|
||||
status = false;
|
||||
}
|
||||
|
29
devel/uml/patches/patch-ai
Normal file
29
devel/uml/patches/patch-ai
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- uml/mylistview.cpp.orig 2004-06-15 19:29:10.000000000 +0200
|
||||
+++ uml/mylistview.cpp 2004-06-15 19:30:09.000000000 +0200
|
||||
@@ -264,7 +264,7 @@
|
||||
}else if(pt == ACTOR || pt == USECASE)
|
||||
{
|
||||
item = ucv;
|
||||
- }else{ cerr<<"ERROR:listview:find"<<endl;return 0;}
|
||||
+ }else{ std::cerr<<"ERROR:listview:find"<<std::endl;return 0;}
|
||||
temp = (MyListViewItem *)item->firstChild();
|
||||
while(temp)
|
||||
{
|
||||
@@ -333,7 +333,7 @@
|
||||
}
|
||||
item =(MyListViewItem *)item -> nextSibling();
|
||||
}//end while
|
||||
- cerr<<"Error findchild"<<endl;
|
||||
+ std::cerr<<"Error findchild"<<std::endl;
|
||||
return 0;
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
@@ -379,7 +379,7 @@
|
||||
for( ; (temp = (MyListViewItem*)it.current()); ++it )
|
||||
if(temp->getID() == id)
|
||||
return temp;
|
||||
- cerr<<"Can't find list item by id"<<endl;
|
||||
+ std::cerr<<"Can't find list item by id"<<std::endl;
|
||||
return 0;
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
11
devel/uml/patches/patch-aj
Normal file
11
devel/uml/patches/patch-aj
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/operation.cpp.orig 2004-06-15 19:28:32.000000000 +0200
|
||||
+++ uml/operation.cpp 2004-06-15 19:28:43.000000000 +0200
|
||||
@@ -40,7 +40,7 @@
|
||||
{
|
||||
if(obj == a)
|
||||
if(!list.remove(obj))
|
||||
- cerr<<"Error removing parm"<<endl;
|
||||
+ std::cerr<<"Error removing parm"<<std::endl;
|
||||
}
|
||||
}
|
||||
////////////////////////////////////////////////////////////////////////////////////////////////////
|
45
devel/uml/patches/patch-ak
Normal file
45
devel/uml/patches/patch-ak
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- uml/umldoc.cpp.orig 2004-06-15 19:25:09.000000000 +0200
|
||||
+++ uml/umldoc.cpp 2004-06-15 19:27:14.000000000 +0200
|
||||
@@ -352,7 +352,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- cerr<<"CreateUMLObject(int) error"<<endl;
|
||||
+ std::cerr<<"CreateUMLObject(int) error"<<std::endl;
|
||||
return;
|
||||
}
|
||||
objectList.append(o);
|
||||
@@ -398,7 +398,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- cerr<<"ERROR _CREATEUMLOBJECT"<<endl;
|
||||
+ std::cerr<<"ERROR _CREATEUMLOBJECT"<<std::endl;
|
||||
return;
|
||||
}
|
||||
loop = false;
|
||||
@@ -514,7 +514,7 @@
|
||||
bool loop = true;
|
||||
UMLObject *p = (UMLObject *)o->parent();
|
||||
if(!p){
|
||||
- cerr<<"Can't create object, no parent found"<<endl;
|
||||
+ std::cerr<<"Can't create object, no parent found"<<std::endl;
|
||||
return;}
|
||||
QString oldName= o->name();
|
||||
while(loop)
|
||||
@@ -844,13 +844,13 @@
|
||||
{
|
||||
if(!clipboard)
|
||||
{
|
||||
- cerr <<"clipboard deleted and trying to paste. WHAT!!!"<<endl;
|
||||
+ std::cerr <<"clipboard deleted and trying to paste. WHAT!!!"<<std::endl;
|
||||
return;
|
||||
}
|
||||
currentView -> pasteSelection(clipboard);
|
||||
}
|
||||
|
||||
-void UMLDoc::setModified(bool _m=true)
|
||||
+void UMLDoc::setModified(bool _m)
|
||||
{
|
||||
modified = _m;
|
||||
((UMLApp *) parent()) -> setModified(_m);
|
38
devel/uml/patches/patch-al
Normal file
38
devel/uml/patches/patch-al
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- uml/umlview.cpp.orig 2004-06-15 19:23:17.000000000 +0200
|
||||
+++ uml/umlview.cpp 2004-06-15 19:24:59.000000000 +0200
|
||||
@@ -512,7 +512,7 @@
|
||||
ObjectWidget * ow = new ObjectWidget(viewport(), o, ++localID);
|
||||
temp = (UMLWidget *)ow;
|
||||
}
|
||||
- }else cerr <<"ERROR: trying to create an invalid widget"<<endl;
|
||||
+ }else std::cerr <<"ERROR: trying to create an invalid widget"<<std::endl;
|
||||
connect(getDocument(), SIGNAL(sigWidgetUpdated(UMLObject *)), temp, SLOT(slotChangeWidget(UMLObject *)));
|
||||
connect(this, SIGNAL(sigColorChanged(int)), temp, SLOT(slotColorChanged(int)));
|
||||
int y=pos.y();
|
||||
@@ -577,7 +577,7 @@
|
||||
if(status)
|
||||
if( !(temp = getDocument()->findUMLObject(id)) )
|
||||
{
|
||||
- cerr<<"object not found"<<endl;
|
||||
+ std::cerr<<"object not found"<<std::endl;
|
||||
status = false;
|
||||
}
|
||||
//make sure dragging item onto correct diagram
|
||||
@@ -630,7 +630,7 @@
|
||||
if(status)
|
||||
if(!(o = getDocument()->findUMLObject(id)))
|
||||
{
|
||||
- cerr<<"object not found"<<endl;
|
||||
+ std::cerr<<"object not found"<<std::endl;
|
||||
status = false;
|
||||
}
|
||||
if(status)
|
||||
@@ -913,7 +913,7 @@
|
||||
}//end object
|
||||
else
|
||||
{
|
||||
- cerr<<"ERROR LOADING VIEW"<<endl;
|
||||
+ std::cerr<<"ERROR LOADING VIEW"<<std::endl;
|
||||
return false;
|
||||
}
|
||||
status = o -> serialize(s, archive, fileVersion);
|
11
devel/uml/patches/patch-am
Normal file
11
devel/uml/patches/patch-am
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- uml/umlwidget.cpp.orig 2004-06-15 19:22:01.000000000 +0200
|
||||
+++ uml/umlwidget.cpp 2004-06-15 19:22:41.000000000 +0200
|
||||
@@ -376,7 +376,7 @@
|
||||
object = view -> getDocument() -> findUMLObject(id);
|
||||
if(!object && type >= ACTOR && type <= OBJECT)
|
||||
{
|
||||
- cerr<<"CAN'T FIND OBJECT TO USE IN VIEW id : "<<id<<endl;
|
||||
+ std::cerr<<"CAN'T FIND OBJECT TO USE IN VIEW id : "<<id<<std::endl;
|
||||
status = false;
|
||||
}
|
||||
else if(object)
|
Loading…
Reference in a new issue