Updating security/p5-Net-SSLeay from 1.35nb2 to 1.36

pkgsrc changes:
- Adjusting dependencies
- Removing compatibility patches which are all applied upstream

Upstream changes:
1.36 30.01.2010
	- Fix problems with building on GNU/kFreeBSD, to do with use of pack
	instread of sockaddr_in. Patched by Debian Perl Group. (Closes RT#40144)
	- Fixed a compile problem in t/local/ptr_cast_test.c for some gcc
	versions. Reported by "Ryan McGuigan via RT". (Closes RT#52525)
	- Improved OpenSSL detection on Win32/strawberry perl. Patch provided
	by kmx. (Closes RT#49287)
	- Fix test failures on some 64-bit platforms. (Closes RT#53585)
	- Make X509_NAME_get_text_by_NID return its result without a trailing NUL.
	Patched by Steffen Ullrich. (Closes RT#35754)
	- SSL_set_session_secret_cb required for EAP-FAST is now enabled for both
	SSL_F_SSL_SET_HELLO_EXTENSION and
	SSL_F_SSL_SET_SESSION_TICKET_EXT. The name of this #define
	changed after 0.9.8i. SSL_set_hello_extension is not available after
	0.9.8i.
	- Added SSL_CTX_get_client_CA_list sk_X509_NAME_free sk_X509_NAME_num
	sk_X509_NAME_value SSL_get_client_CA_list, from patch provided by
	Joerg Schneider
	- Added EVP_add_digest and EVP_sha256 (if available)
	- Improve documentation on callback functions.
	- Stop looping forever when writing to broken connections. Patched by
	Martin Mares. (Closes RT#44170)
	- Patches from "Martijn van Beers via RT" to add SSL_SENT_SHUTDOWN
	and SSL_RECEIVED_SHUTDOWN, remove broken URLs,
	and to fix some documentation issues.
	- Various changes to build with OpenSSL 1.0 beta1:
	SSL_SESSION_cmp has been removed
	return type of SSL_CTX_sessions changed in an ugly way
	- Fixed a build problem reported by SISYPHUS:
	On Windows Vista64, ActivePerl 5.10.0 (build 1004, x64), running 'nmake
	test', the process hangs forever when it comes to building the test
	executable (as the executable fails to build).
	- Applied patch from ecmenifee in to improve handling of errors in
	ssl_write_all. (Closes RT#48132)
	- Patch to permit compile and testing on OS/2 submitted by Ilya
	Zakharevich.
	- Fixed compile problems with openssl-1.0.0-beta3 due to MD2 now being
	optional. Reported by paul [...] city-fan.org.
	- Fixed compile problems with openssl-0.9.7 and earlier with undefined
	symbol EVP_sha256. Reported by paul [...] city-fan.org.
	- Fixed a typo reported by Dan Dascalescu.
	- added RIPEMD160 digest function.  Patch provided by dkg.
This commit is contained in:
sno 2010-02-02 20:53:46 +00:00
parent dbb406b1fb
commit 960b63a939
4 changed files with 11 additions and 71 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.46 2010/01/17 12:02:43 wiz Exp $
# $NetBSD: Makefile,v 1.47 2010/02/02 20:53:46 sno Exp $
DISTNAME= Net-SSLeay-1.35
DISTNAME= Net-SSLeay-1.36
PKGNAME= p5-${DISTNAME}
PKGREVISION= 2
#PKGREVISION= 2
SVR4_PKGNAME= p5nsl
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Net/}
@ -10,13 +10,15 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Net/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/Net-SSLeay/
COMMENT= Perl5 module for using OpenSSL
#LICENSE= same as security/openssl
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
BUILD_DEPENDS+= p5-Test-Exception-[0-9]*:../../devel/p5-Test-Exception
BUILD_DEPENDS+= p5-Test-Warn-[0-9]*:../../devel/p5-Test-Warn
DEPENDS+= p5-MIME-Base64-[0-9]*:../../converters/p5-MIME-Base64
DEPENDS+= {perl>=5.7.3,p5-MIME-Base64-[0-9]*}:../../converters/p5-MIME-Base64
# see WRKSRC/inc/Module/Install/PRIVATE/Net/SSLeay.pm
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.3
@ -26,7 +28,7 @@ USE_LANGUAGES= c
PERL5_PACKLIST= auto/Net/SSLeay/.packlist
MAKE_ENV+= OPENSSL_PREFIX=${SSLBASE}
MAKE_ENV+= PERL_MM_USE_DEFAULT=1 # avoid network question
MAKE_PARAMS= --skipdeps
PERL5_MODULE_TYPE= Module::Install::Bundled
.include "../../devel/zlib/buildlink3.mk"
.include "../../lang/perl5/module.mk"

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.21 2009/07/30 14:54:39 drochner Exp $
$NetBSD: distinfo,v 1.22 2010/02/02 20:53:47 sno Exp $
SHA1 (Net-SSLeay-1.35.tar.gz) = dc295d4a7da8ab330aca13c45e2cb5b8220aa5e4
RMD160 (Net-SSLeay-1.35.tar.gz) = b8f0afb29507624566665f3a835c3c87fd1e7996
Size (Net-SSLeay-1.35.tar.gz) = 132198 bytes
SHA1 (patch-aa) = 299303c3afabeae0b41fee55c5dcb6ce1ea38133
SHA1 (patch-ab) = 26d8af03934729ee0b152e33f51cfa3fb6b0d39d
SHA1 (Net-SSLeay-1.36.tar.gz) = e8cfb6355a596471518356a29bfe53ab2011c685
RMD160 (Net-SSLeay-1.36.tar.gz) = f9bab073ea25b7574d49b411324024ecd3750377
Size (Net-SSLeay-1.36.tar.gz) = 145651 bytes

View file

@ -1,48 +0,0 @@
$NetBSD: patch-aa,v 1.1 2009/07/30 14:54:39 drochner Exp $
--- SSLeay.xs.orig 2008-07-24 03:03:22.000000000 +0200
+++ SSLeay.xs
@@ -89,6 +89,7 @@ extern "C" {
*/
#undef _
+#define BLOCK osslBLOCK
#include <openssl/err.h>
#include <openssl/lhash.h>
#include <openssl/rand.h>
@@ -1243,6 +1244,14 @@ SSL_CTX_set_options(ctx,op)
SSL_CTX * ctx
long op
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+
+LHASH_OF(SSL_SESSION) *
+SSL_CTX_sessions(ctx)
+ SSL_CTX * ctx
+
+#else
+
LHASH *
SSL_CTX_sessions(ctx)
SSL_CTX * ctx
@@ -1253,6 +1262,8 @@ SSL_CTX_sessions(ctx)
OUTPUT:
RETVAL
+#endif
+
unsigned long
SSL_CTX_sess_number(ctx)
SSL_CTX * ctx
@@ -2124,11 +2135,6 @@ int
SSL_renegotiate(s)
SSL * s
-int
-SSL_SESSION_cmp(a,b)
- SSL_SESSION * a
- SSL_SESSION * b
-
void *
SSL_SESSION_get_ex_data(ss,idx)
SSL_SESSION * ss

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/07/30 14:54:39 drochner Exp $
--- typemap.orig 2008-07-24 03:03:22.000000000 +0200
+++ typemap
@@ -15,6 +15,7 @@ BIO_METHOD * T_IV
EVP_PKEY * T_IV
CERT * T_IV
LHASH * T_IV
+LHASH_OF(SSL_SESSION) * T_IV
struct cert_st * T_IV
X509_STORE_CTX * T_IV
ASN1_UTCTIME * T_IV