Don't use a Twisted version that no longer exist.

This commit is contained in:
joerg 2020-04-20 00:42:52 +00:00
parent 43061c9d54
commit 964e16dcf1
2 changed files with 14 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2016/04/17 10:15:21 wiz Exp $
$NetBSD: distinfo,v 1.7 2020/04/20 00:42:52 joerg Exp $
SHA1 (Coherence-0.6.6.2.tar.gz) = c8f3aedf6f393e400b012b9b79a45faf6bc3c809
RMD160 (Coherence-0.6.6.2.tar.gz) = f3cea9a846059723c846cb2254aae73ff1a6a5e9
@ -7,4 +7,4 @@ Size (Coherence-0.6.6.2.tar.gz) = 364908 bytes
SHA1 (patch-aa) = 3d0e0966a12bb6f42015dac259db085923135fae
SHA1 (patch-ab) = 54d3ab8e58a4412f4e3b5c263785468f58ac132b
SHA1 (patch-ac) = c10f363f6de78a9ae4d08956c6d2afa35d817cb4
SHA1 (patch-coherence_____init____.py) = 2f893049e59af910e9449e7ef081ec05eb1dd3e1
SHA1 (patch-coherence_____init____.py) = 6e3b8207f26bb8dedd2cd513bd1614b3c31a0c50

View file

@ -1,11 +1,21 @@
$NetBSD: patch-coherence_____init____.py,v 1.1 2016/04/17 10:15:21 wiz Exp $
$NetBSD: patch-coherence_____init____.py,v 1.2 2020/04/20 00:42:52 joerg Exp $
twisted 16.0.0 detection is broken, see
https://github.com/coherence-project/Coherence/issues/25
--- coherence/__init__.py.orig 2010-01-02 15:35:20.000000000 +0000
+++ coherence/__init__.py
@@ -24,8 +24,6 @@ try:
@@ -11,8 +11,7 @@ SERVER_ID = ','.join([platform.system(),
try:
- from twisted import version as twisted_version
- from twisted.web import version as twisted_web_version
+ from twisted import __version__ as twisted_version
from twisted.python.versions import Version
except ImportError, exc:
# log error to stderr, might be useful for debugging purpose
@@ -24,8 +23,6 @@ try:
if twisted_version < Version("twisted", 2, 5, 0):
raise ImportError("Twisted >= 2.5 is required. Please install it.")