mate-terminal: avoid NULL pointer dereference
This fixes a bug that caused significant application crashes.
This commit is contained in:
parent
bc932c9d6c
commit
9653beaf0c
3 changed files with 21 additions and 3 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.18 2019/07/21 22:26:02 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2020/01/02 18:55:57 gutteridge Exp $
|
||||
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
.include "../../meta-pkgs/mate/Makefile.common"
|
||||
|
||||
DISTNAME= mate-terminal-${VERSION:R}.1
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2019/05/08 01:40:01 gutteridge Exp $
|
||||
$NetBSD: distinfo,v 1.7 2020/01/02 18:55:57 gutteridge Exp $
|
||||
|
||||
SHA1 (mate-terminal-1.22.1.tar.xz) = 52218ea2066fb813c351b6e1b8b22787665d177a
|
||||
RMD160 (mate-terminal-1.22.1.tar.xz) = 907928524c180129af4bda7ec0e14260627e3ea9
|
||||
SHA512 (mate-terminal-1.22.1.tar.xz) = b20102c15dc140b59c93802606ca94fd108dfd5f7ac7f079b872e957794fc2c3aab40c0e6da697e8d393a67fca7b106573a4cb8014af5d6c8ad777be3a798534
|
||||
Size (mate-terminal-1.22.1.tar.xz) = 1543900 bytes
|
||||
SHA1 (patch-src_terminal-screen.c) = 2fbfe4ef4280174b6688fbc37e13bc839dd175f7
|
||||
|
|
17
x11/mate-terminal/patches/patch-src_terminal-screen.c
Normal file
17
x11/mate-terminal/patches/patch-src_terminal-screen.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-src_terminal-screen.c,v 1.1 2020/01/02 18:55:58 gutteridge Exp $
|
||||
|
||||
Avoid NULL pointer dereference in terminal_screen_child_exited.
|
||||
https://github.com/mate-desktop/mate-terminal/commit/fe73da93aa0a14ee471e7a6af7914197c41d3723
|
||||
|
||||
--- src/terminal-screen.c.orig 2019-04-23 10:25:08.000000000 +0000
|
||||
+++ src/terminal-screen.c
|
||||
@@ -1946,6 +1946,9 @@ terminal_screen_child_exited (VteTermina
|
||||
break;
|
||||
case TERMINAL_EXIT_HOLD:
|
||||
{
|
||||
+ if ((status == 9) && (priv->override_command == NULL))
|
||||
+ break;
|
||||
+
|
||||
GtkWidget *info_bar;
|
||||
|
||||
info_bar = terminal_info_bar_new (GTK_MESSAGE_INFO,
|
Loading…
Reference in a new issue