Roll back commit: this is pkgsrc freeze (sorry, I missed the message)

This commit is contained in:
manu 2010-06-29 13:42:10 +00:00
parent fa9eaef848
commit 965acbc02b
8 changed files with 2 additions and 94 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2010,v 1.2317 2010/06/29 08:16:04 tron Exp $
$NetBSD: CHANGES-2010,v 1.2318 2010/06/29 13:42:10 manu Exp $
PKGSRC IS CURRENTLY FROZEN FOR NEW FUNCTIONALITY - PLEASE DO NOT ADD
ANY NEW PACKAGES, AND PLEASE DO NOT MAKE INFRASTRUCTURE CHANGES, UNTIL
@ -3071,5 +3071,4 @@ Changes to the packages collection and infrastructure in 2010:
Updated x11/gtkmm to 2.20.3nb2 [wiz 2010-06-28]
Updated sysutils/fabric to 0.9.1 [gls 2010-06-28]
Updated security/py-openid to 2.2.5 [roy 2010-06-28]
Added security/pam-p11-0.1.5 [manu 2010-06-29]
Updated lang/python26 to 2.6.5nb1 [tron 2010-06-29]

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.385 2010/06/29 07:31:28 manu Exp $
# $NetBSD: Makefile,v 1.386 2010/06/29 13:42:10 manu Exp $
#
COMMENT= Security tools
@ -240,7 +240,6 @@ SUBDIR+= pam-fprint
SUBDIR+= pam-ldap
SUBDIR+= pam-mkhomedir
SUBDIR+= pam-mysql
SUBDIR+= pam-p11
SUBDIR+= pam-passwdqc
SUBDIR+= pam-pwauth_suid
SUBDIR+= pam-radius

View file

@ -1,9 +0,0 @@
Pam_p11 is a plugable authentication module (PAM) package for using
crpytographic PKCS#11 tokens such as smart cards and usb crypto
tokens for local authentication.
Pam_p11 implements two authentication modules:
* pam_p11_openssh authenticates the user against public keys found
in OpenSSH ~/.ssh/authorized_keys file.
* pam_p11_opensc authenticates the user against certificates found
in ~/.eid/authorized_certificates.

View file

@ -1,25 +0,0 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/06/29 07:29:32 manu Exp $
#
DISTNAME= pam_p11-0.1.5
CATEGORIES= security
MASTER_SITES= http://www.opensc-project.org/files/pam_p11/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.opensc-project.org/files/pam_p11/
COMMENT= Smart card PAM module
LICENSE= gnu-lgpl-v2.1
PKG_DESTDIR_SUPPORT= user-destdir
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_TOOLS+= gmake pkg-config
.include "../../security/openssl/buildlink3.mk"
.include "../../security/libp11/buildlink3.mk"
.include "../../mk/pam.buildlink3.mk"
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/06/29 07:29:32 manu Exp $
lib/security/pam_p11_openssh.so
lib/security/pam_p11_opensc.so

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2010/06/29 07:29:32 manu Exp $
SHA1 (pam_p11-0.1.5.tar.gz) = 4ff838140e452c84143445dcf6a3f158009b83b0
RMD160 (pam_p11-0.1.5.tar.gz) = 57930c4b93182dd36cd2a1c81231638f813b47d2
Size (pam_p11-0.1.5.tar.gz) = 348181 bytes
SHA1 (patch-aa) = c82f6de3fdb094601f5250280c7a5727d41d983d
SHA1 (patch-ab) = 701f8e878f928c98f0037b363099f9c12ece429e

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/06/29 07:29:32 manu Exp $
--- src/test.c.orig 2010-06-25 16:25:28.000000000 +0200
+++ src/test.c 2010-06-25 16:25:39.000000000 +0200
@@ -1,9 +1,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <security/pam_appl.h>
+#ifndef OPENPAM
#include <security/pam_misc.h>
+#endif /* OPENPAM */
#include <security/pam_modules.h>
int main(int argc, char **argv)
{

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/06/29 07:29:32 manu Exp $
--- src/pam_p11.c.orig 2010-06-29 08:56:07.000000000 +0200
+++ src/pam_p11.c 2010-06-29 09:05:03.000000000 +0200
@@ -21,10 +21,16 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <unistd.h>
+#include <openssl/sha.h>
+
#include <libp11.h>
+#ifdef __NetBSD__
+#define NO_STATIC_MODULES
+#endif
+
/* We have to make this definitions before we include the pam header files! */
#define PAM_SM_AUTH
#define PAM_SM_ACCOUNT
#define PAM_SM_SESSION
@@ -43,9 +49,9 @@
#define LOGNAME "pam_p11" /* name for log-file entries */
#define RANDOM_SOURCE "/dev/urandom"
-#define RANDOM_SIZE 128
+#define RANDOM_SIZE SHA_DIGEST_LENGTH
#define MAX_SIGSIZE 256
extern int match_user(X509 * x509, const char *login);