Use correct macros for installation, from FUKAUMI Naoki in PR 41563.

While here, fix .pc files (were missing -Wl,-R).

Bump PKGREVISION.
This commit is contained in:
wiz 2009-06-10 17:28:06 +00:00
parent 625e5ac86d
commit 966785ce99
5 changed files with 39 additions and 8 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.77 2009/06/10 10:47:22 hasso Exp $
# $NetBSD: Makefile,v 1.78 2009/06/10 17:28:06 wiz Exp $
PKGNAME= MesaLib-${MESA_PKGVERSION}
PKGREVISION= 2
COMMENT= Graphics library similar to SGI's OpenGL
PKGREVISION= 1
MESA_HEADERS= gl.h gl_mangle.h glext.h glx.h glxext.h \
glx_mangle.h osmesa.h xmesa.h xmesa_x.h \
@ -15,6 +15,12 @@ PKG_DESTDIR_SUPPORT= user-destdir
BUILD_DEFS+= MESA_HZ
PLIST_VARS= dri nodri
PKGCONFIG_OVERRIDE+= src/mesa/drivers/dri/dri.pc.in
PKGCONFIG_OVERRIDE+= src/mesa/gl.pc.in
PKGCONFIG_OVERRIDE+= src/glw/glw.pc.in
# no configure stage
PKGCONFIG_OVERRIDE_STAGE= pre-build
.include "glx-config.mk"
.include "../../graphics/Mesa/Makefile.lib"
.include "options.mk"
@ -63,4 +69,6 @@ pre-install:
pre-build:
cd ${WRKSRC} && ${RM} -fr src/glu src/glut progs
# no configure phase
.include "../../mk/configure/pkg-config-override.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.20 2009/06/05 11:10:35 wiz Exp $
@comment $NetBSD: PLIST,v 1.21 2009/06/10 17:28:06 wiz Exp $
include/GL/GLwDrawA.h
include/GL/GLwDrawAP.h
include/GL/GLwMDrawA.h
@ -29,6 +29,7 @@ ${PLIST.dri}lib/dri/sis_dri.la
${PLIST.dri}lib/dri/swrast_dri.la
${PLIST.dri}lib/dri/tdfx_dri.la
${PLIST.dri}lib/dri/unichrome_dri.la
lib/pkgconfig/dri.pc
lib/pkgconfig/gl.pc
lib/pkgconfig/glw.pc
${PLIST.dri}@dirrm lib/dri

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.63 2009/06/10 10:47:22 hasso Exp $
$NetBSD: distinfo,v 1.64 2009/06/10 17:28:07 wiz Exp $
SHA1 (Mesa-7.4.2/MesaDemos-7.4.2.tar.bz2) = cbba586829c76a5e7a54a906567b4b2174d6e1aa
RMD160 (Mesa-7.4.2/MesaDemos-7.4.2.tar.bz2) = c6434d325897540618130e97891f391721b543b5
@ -12,10 +12,11 @@ Size (Mesa-7.4.2/MesaLib-7.4.2.tar.bz2) = 3371577 bytes
SHA1 (patch-aa) = 9afc2758ebbef3737f8c858f74f0c93d86bb0861
SHA1 (patch-ab) = 27b44d856602d590d2596f41cd17cdaf18bdc96e
SHA1 (patch-ac) = ed3ec49ea2aacf231bbcb38093f3dc01a0cb2468
SHA1 (patch-ad) = 47da546b7cebd9d05a9122b606e71c0d83e98a05
SHA1 (patch-ad) = 080413cbdc2ed7484cc2fff25f00bc53dca3a393
SHA1 (patch-ae) = 07cf84391b4e828b558129eb90daaeb48e43e1ab
SHA1 (patch-af) = 670259e92d1cd3b2695113cfd5fb3ad4a46bdc04
SHA1 (patch-ag) = da4de00aaebf226489ca3f5c25470fe3ed41e3b7
SHA1 (patch-ah) = 2ecaee79c6b139272ef247d97d2a9f5834550a9f
SHA1 (patch-ai) = 620c80ffbca1249469138f0af28eec575c546b87
SHA1 (patch-aj) = 3749b279b500b1a93e45985ae956e8a70d854d9c
SHA1 (patch-am) = 744f13b6a2fc79746bcacecf11461e78de7bf1ef

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ad,v 1.14 2009/06/05 11:10:35 wiz Exp $
$NetBSD: patch-ad,v 1.15 2009/06/10 17:28:07 wiz Exp $
--- src/mesa/Makefile.orig 2009-03-13 05:28:49 +0200
+++ src/mesa/Makefile 2009-05-17 16:29:41 +0300
@ -70,7 +70,7 @@ $NetBSD: patch-ad,v 1.14 2009/06/05 11:10:35 wiz Exp $
- $(DESTDIR)$(INSTALL_LIB_DIR)
- $(INSTALL) -m 644 gl.pc $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ @if [ -f "$(TOP)/$(LIB_DIR)/$(GL_LIB_NAME:.so=.la)" ]; then \
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_LIB) \
+ $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME:.so=.la) \
@ -85,7 +85,7 @@ $NetBSD: patch-ad,v 1.14 2009/06/05 11:10:35 wiz Exp $
- $(DESTDIR)$(INSTALL_LIB_DIR)
- $(INSTALL) -m 644 osmesa.pc $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ @if [ -f "$(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME:.so=.la)" ]; then \
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_LIB) \
+ $(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME:.so=.la) \

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ah,v 1.10 2009/06/10 17:28:07 wiz Exp $
--- src/mesa/drivers/dri/Makefile.orig 2009-03-13 03:28:49.000000000 +0000
+++ src/mesa/drivers/dri/Makefile
@@ -38,11 +38,11 @@ install: dri.pc
(cd $$dir && $(MAKE) install) || exit 1 ; \
fi \
done
- $(INSTALL) -d $(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
- $(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h \
- $(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
- $(INSTALL) -d $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
- $(INSTALL) -m 0644 dri.pc $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ $(BSD_INSTALL_DATA) $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
+ $(BSD_INSTALL_DATA) dri.pc $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
clean: