libfilezilla: update to 0.37.2.
0.37.2 (2022-04-29) + Added a null_logger that doesn't do anything - MSW: fz::mkdir with restricted permissions now uses inheritable ACLs - MSW: Minor performance improvements reading from fz::process and explicit cancellation of pending I/O when killing child processes. 0.37.1 (2022-04-08) + Added convenience functions ot fz::json - MSW: Fixed spawning fz::process with blocking communication 0.37.0 (2022-04-01) + *nix: password-less impersonation can take an optional group + Added demo https client showcasing usage of fz::socket and fz::tls_layer + Added some compile-time checks for fz::sprintf arguments + MSW: Added fz::registry + Added a way to use non-blocking read/write with fz::process - Added fz::logger_interface::log_u which assumes string arguments are in UTF-8 as opposed to the character set used by the current locale - Disallow spawning additional threads while fz::thread_pool is in the process of being destroyed - *nix: poll() is now mandatory, the select() based socket event loop has been removed - Simplified fz::socket implementation through use of internal fz::poller
This commit is contained in:
parent
916939bc09
commit
9675ecb41b
4 changed files with 13 additions and 14 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.40 2022/02/07 10:48:26 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.41 2022/05/04 05:46:46 wiz Exp $
|
||||
|
||||
DISTNAME= libfilezilla-0.36.0
|
||||
DISTNAME= libfilezilla-0.37.2
|
||||
CATEGORIES= net
|
||||
# some kind of direct-download disabling
|
||||
#MASTER_SITES= https://dl3.cdn.filezilla-project.org/libfilezilla/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2022/02/07 10:48:26 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2022/05/04 05:46:46 wiz Exp $
|
||||
include/libfilezilla/apply.hpp
|
||||
include/libfilezilla/buffer.hpp
|
||||
include/libfilezilla/encode.hpp
|
||||
|
@ -10,7 +10,6 @@ include/libfilezilla/file.hpp
|
|||
include/libfilezilla/format.hpp
|
||||
include/libfilezilla/fsresult.hpp
|
||||
include/libfilezilla/glue/unix.hpp
|
||||
include/libfilezilla/glue/windows.hpp
|
||||
include/libfilezilla/glue/wx.hpp
|
||||
include/libfilezilla/glue/wxinvoker.hpp
|
||||
include/libfilezilla/hash.hpp
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.35 2022/02/07 10:53:52 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.36 2022/05/04 05:46:46 wiz Exp $
|
||||
|
||||
BLAKE2s (libfilezilla-0.36.0.tar.bz2) = 2f73811e989f0fb8fa2afbfbef3fcf99a4323ea147ffdda884c907ef0b3c9fee
|
||||
SHA512 (libfilezilla-0.36.0.tar.bz2) = c6b0240c560afb87426f7ccf01e34eb92975b043697be89f26a12dcfaf4a109d308eed200429f986b14f80111573ea5a869194375c844fa7b666d173e9629a0a
|
||||
Size (libfilezilla-0.36.0.tar.bz2) = 598327 bytes
|
||||
SHA1 (patch-lib_impersonation.cpp) = 6ae2b236ea553732d3de9949c88b65ae62e0ceee
|
||||
BLAKE2s (libfilezilla-0.37.2.tar.bz2) = 676cf6752f55ddbdae7c3416c05fa6835ae277fb36567a2ef063758e28e6491d
|
||||
SHA512 (libfilezilla-0.37.2.tar.bz2) = a8902977bae5f442045faa8a68c2f85e667a2371b1e643fde49e592fa9544b0a672c476246b01b2ba7b52390b37b0f1f33e5196be4499eddf5783f225091c93a
|
||||
Size (libfilezilla-0.37.2.tar.bz2) = 609128 bytes
|
||||
SHA1 (patch-lib_impersonation.cpp) = b3329868b8339bcdac6768768bfc3645de28d455
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-lib_impersonation.cpp,v 1.2 2022/02/07 10:53:52 wiz Exp $
|
||||
$NetBSD: patch-lib_impersonation.cpp,v 1.3 2022/05/04 05:46:46 wiz Exp $
|
||||
|
||||
Hide Linux-specific stuff in ifdef __Linux__
|
||||
https://trac.filezilla-project.org/ticket/12658
|
||||
|
||||
--- lib/impersonation.cpp.orig 2021-12-08 15:10:58.000000000 +0000
|
||||
--- lib/impersonation.cpp.orig 2022-04-01 12:35:07.000000000 +0000
|
||||
+++ lib/impersonation.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <optional>
|
||||
|
@ -14,8 +14,8 @@ https://trac.filezilla-project.org/ticket/12658
|
|||
#include <crypt.h>
|
||||
#include <shadow.h>
|
||||
#endif
|
||||
@@ -58,7 +58,7 @@ passwd_holder get_passwd(fz::native_stri
|
||||
return ret;
|
||||
@@ -79,7 +79,7 @@ std::optional<gid_t> get_group(fz::nativ
|
||||
return {};
|
||||
}
|
||||
|
||||
-#if FZ_UNIX
|
||||
|
@ -23,7 +23,7 @@ https://trac.filezilla-project.org/ticket/12658
|
|||
struct shadow_holder {
|
||||
shadow_holder() = default;
|
||||
shadow_holder(shadow_holder const&) = delete;
|
||||
@@ -150,7 +150,7 @@ std::vector<gid_t> get_supplementary(std
|
||||
@@ -171,7 +171,7 @@ std::vector<gid_t> get_supplementary(std
|
||||
|
||||
bool check_auth(fz::native_string const& username, fz::native_string const& password)
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue