Update ruby-debug-ide package to 0.4.16.
For Ruby 1.9 support, needs ruby-debug-base19 (unpackaged yet). Changes: Merged with ruby-debug-ide19, compatibility with ruby 1.9 Fixed segfaults on 1.9
This commit is contained in:
parent
4c4fd2b2cd
commit
96c182bce0
4 changed files with 25 additions and 30 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.6 2010/09/10 05:30:11 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2010/12/04 03:55:29 taca Exp $
|
||||
|
||||
DISTNAME= ruby-debug-ide-0.4.10
|
||||
DISTNAME= ruby-debug-ide-0.4.16
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/ruby-//}
|
||||
CATEGORIES= devel
|
||||
|
||||
|
@ -11,6 +11,9 @@ LICENSE= mit
|
|||
|
||||
DEPENDS+= ${RUBY_PKGPREFIX}-debug-base-[0-9]*:../../devel/ruby-debug-base
|
||||
|
||||
#
|
||||
# for 1.9, need ruby-debug-base-19
|
||||
#
|
||||
RUBY_VERSION_SUPPORTED= 18
|
||||
|
||||
pre-configure:
|
||||
|
|
|
@ -1,9 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2010/09/10 05:30:11 taca Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2010/12/04 03:55:29 taca Exp $
|
||||
bin/rdebug-ide
|
||||
${GEM_HOME}/cache/${GEM_NAME}.gem
|
||||
${GEM_LIBDIR}/CHANGES
|
||||
${GEM_LIBDIR}/ChangeLog
|
||||
${GEM_LIBDIR}/ChangeLog.archive
|
||||
${GEM_LIBDIR}/MIT-LICENSE
|
||||
${GEM_LIBDIR}/Rakefile
|
||||
${GEM_LIBDIR}/bin/rdebug-ide
|
||||
|
@ -17,7 +14,10 @@ ${GEM_LIBDIR}/lib/ruby-debug/commands/enable.rb
|
|||
${GEM_LIBDIR}/lib/ruby-debug/commands/eval.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/frame.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/inspect.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/jump.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/load.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/pause.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/set_type.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/stepping.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/threads.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/commands/variables.rb
|
||||
|
@ -26,15 +26,6 @@ ${GEM_LIBDIR}/lib/ruby-debug/helper.rb
|
|||
${GEM_LIBDIR}/lib/ruby-debug/interface.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/printers.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/processor.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/version.rb
|
||||
${GEM_LIBDIR}/lib/ruby-debug/xml_printer.rb
|
||||
${GEM_LIBDIR}/test/rd_basic_test.rb
|
||||
${GEM_LIBDIR}/test/rd_catchpoint_test.rb
|
||||
${GEM_LIBDIR}/test/rd_condition_test.rb
|
||||
${GEM_LIBDIR}/test/rd_enable_disable_test.rb
|
||||
${GEM_LIBDIR}/test/rd_inspect_test.rb
|
||||
${GEM_LIBDIR}/test/rd_stepping_breakpoints_test.rb
|
||||
${GEM_LIBDIR}/test/rd_test_base.rb
|
||||
${GEM_LIBDIR}/test/rd_threads_and_frames_test.rb
|
||||
${GEM_LIBDIR}/test/rd_variables_test.rb
|
||||
${GEM_LIBDIR}/test/ruby-debug/xml_printer_test.rb
|
||||
${GEM_HOME}/specifications/${GEM_NAME}.gemspec
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2010/09/10 05:30:11 taca Exp $
|
||||
$NetBSD: distinfo,v 1.6 2010/12/04 03:55:29 taca Exp $
|
||||
|
||||
SHA1 (ruby-debug-ide-0.4.10.gem) = 61a032b37c2e35eb1831a7ae6cb4acf7186c7927
|
||||
RMD160 (ruby-debug-ide-0.4.10.gem) = 1a81280d593a300792eaed7f25e6c7794b438451
|
||||
Size (ruby-debug-ide-0.4.10.gem) = 32768 bytes
|
||||
SHA1 (patch-aa) = 3390487967ae03f682453d41805767ff6abd5875
|
||||
SHA1 (ruby-debug-ide-0.4.16.gem) = 81568a7dc096663e598c13c6764d2a3bbca42a97
|
||||
RMD160 (ruby-debug-ide-0.4.16.gem) = 142d6638202eb87132449d76efd199ad95e610ca
|
||||
Size (ruby-debug-ide-0.4.16.gem) = 20480 bytes
|
||||
SHA1 (patch-aa) = 1c1b79a12585fb6b4c8d7619b3ff30535a31a573
|
||||
|
|
|
@ -1,23 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.3 2010/09/10 05:30:11 taca Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2010/12/04 03:55:29 taca Exp $
|
||||
|
||||
Extension is included in ruby-debug-base package and it should be
|
||||
installed by pkgsrc's dependency.
|
||||
|
||||
--- ../ruby-debug-ide-0.4.10.gemspec.orig 2010-09-07 03:10:28.000000000 +0000
|
||||
+++ ../ruby-debug-ide-0.4.10.gemspec
|
||||
@@ -28,8 +28,6 @@ description: |
|
||||
email: rubyeclipse-dev-list@sourceforge.net
|
||||
--- ../ruby-debug-ide-0.4.16.gemspec.orig 2010-12-01 02:42:53.000000000 +0000
|
||||
+++ ../ruby-debug-ide-0.4.16.gemspec
|
||||
@@ -28,8 +28,7 @@ description: |
|
||||
email: rubymine-feedback@jetbrains.com
|
||||
executables:
|
||||
- rdebug-ide
|
||||
-extensions:
|
||||
-- ext/mkrf_conf.rb
|
||||
+extensions: []
|
||||
extra_rdoc_files: []
|
||||
|
||||
files:
|
||||
@@ -69,7 +67,6 @@ files:
|
||||
- test/rd_condition_test.rb
|
||||
- test/rd_catchpoint_test.rb
|
||||
- test/rd_enable_disable_test.rb
|
||||
@@ -60,7 +59,6 @@ files:
|
||||
- lib/ruby-debug/version.rb
|
||||
- lib/ruby-debug/xml_printer.rb
|
||||
- lib/ruby-debug-ide.rb
|
||||
-- ext/mkrf_conf.rb
|
||||
has_rdoc: true
|
||||
homepage: http://rubyforge.org/projects/debug-commons/
|
||||
|
|
Loading…
Reference in a new issue