Update mikutter to 0.2.2.1328.

(drop dependency on libnotify, optional and alternative selectable).

bug fixes.
This commit is contained in:
obache 2013-08-14 13:06:13 +00:00
parent 9024e6255b
commit 973b8e6876
3 changed files with 22 additions and 8 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.70 2013/08/05 12:46:52 obache Exp $
# $NetBSD: Makefile,v 1.71 2013/08/14 13:06:13 obache Exp $
#
DISTNAME= mikutter.0.2.2.1318
DISTNAME= mikutter.0.2.2.1328
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/./-/}
CATEGORIES= net
MASTER_SITES= http://mikutter.hachune.net/bin/
@ -25,8 +25,6 @@ DEPENDS+= ${RUBY_PKGPREFIX}-bsearch>=1.5:../../devel/ruby-bsearch
DEPENDS+= ${RUBY_PKGPREFIX}-addressable-[0-9]*:../../net/ruby-addressable
DEPENDS+= ${RUBY_PKGPREFIX}-typed-array-[0-9]*:../../misc/ruby-typed-array
#DEPENDS+= ${RUBY_PKGPREFIX}-test-unit-[0-9]*:../../devel/ruby-test-unit
# notify-send
DEPENDS+= {libnotify-[0-9]*,libnotify07-[0-9]*}:../../sysutils/libnotify
WRKSRC= ${WRKDIR}/mikutter
USE_LANGUAGES= # none

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.62 2013/08/05 12:46:52 obache Exp $
$NetBSD: distinfo,v 1.63 2013/08/14 13:06:13 obache Exp $
SHA1 (mikutter.0.2.2.1318.tar.gz) = 8476433757cd073ec6db84d379f47ba9c92ff7f9
RMD160 (mikutter.0.2.2.1318.tar.gz) = 2ddfa836fb527e84f765d7fdd5b933163382d7a7
Size (mikutter.0.2.2.1318.tar.gz) = 2319662 bytes
SHA1 (mikutter.0.2.2.1328.tar.gz) = 1e8d8e44cc78eca4fb1c6c5a1d423fb9032d4792
RMD160 (mikutter.0.2.2.1328.tar.gz) = 58ee71735ed9ed8049fb3ed3e03a0558e2d4a014
Size (mikutter.0.2.2.1328.tar.gz) = 2319763 bytes
SHA1 (patch-core_plugin_libnotify_rnotify.rb) = 0bb5630f4411d11ad188c722fb1d14e2d6748d17

View file

@ -0,0 +1,15 @@
$NetBSD: patch-core_plugin_libnotify_rnotify.rb,v 1.1 2013/08/14 13:06:13 obache Exp $
* fixes module name
--- core/plugin/libnotify/rnotify.rb.orig 2013-08-13 23:22:37.000000000 +0000
+++ core/plugin/libnotify/rnotify.rb
@@ -14,7 +14,7 @@ Plugin::create(:libnotify) do
end
if user
- icon = Gtk::WebImageLoader.local_path(user[:profile_image_url])
+ icon = Gdk::WebImageLoader.local_path(user[:profile_image_url])
title = "@#{user[:idname]} (#{user[:name]})"
end