Add -unsafe-string to fix build with ocaml-4.06.0 and later. ++PKGREVISION
This commit is contained in:
parent
6bc5257eb6
commit
974649fa37
3 changed files with 20 additions and 14 deletions
|
@ -1,11 +1,11 @@
|
||||||
# $NetBSD: Makefile,v 1.27 2018/01/15 09:47:55 jperkin Exp $
|
# $NetBSD: Makefile,v 1.28 2018/01/27 18:24:16 abs Exp $
|
||||||
#
|
#
|
||||||
# VERSION is set in version.mk as it is shared with other packages
|
# VERSION is set in version.mk as it is shared with other packages
|
||||||
.include "version.mk"
|
.include "version.mk"
|
||||||
|
|
||||||
DISTNAME= xen-${VERSION}
|
DISTNAME= xen-${VERSION}
|
||||||
PKGNAME= xentools46-${VERSION}
|
PKGNAME= xentools46-${VERSION}
|
||||||
PKGREVISION= 2
|
PKGREVISION= 3
|
||||||
CATEGORIES= sysutils
|
CATEGORIES= sysutils
|
||||||
MASTER_SITES= https://downloads.xenproject.org/release/xen/${VERSION}/
|
MASTER_SITES= https://downloads.xenproject.org/release/xen/${VERSION}/
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.10 2017/10/28 03:14:17 khorben Exp $
|
$NetBSD: distinfo,v 1.11 2018/01/27 18:24:16 abs Exp $
|
||||||
|
|
||||||
SHA1 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = fecadf952821e830ce1a1d19655288eef8488f88
|
SHA1 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = fecadf952821e830ce1a1d19655288eef8488f88
|
||||||
RMD160 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = 539bfa12db7054228250d6dd380bbf96c1a040f8
|
RMD160 (ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz) = 539bfa12db7054228250d6dd380bbf96c1a040f8
|
||||||
|
@ -47,7 +47,7 @@ SHA1 (patch-libxl_libxl_internal.h) = 73a55e5370217278dc42682d9e5b7ae541d93dc8
|
||||||
SHA1 (patch-libxl_libxl_uuid.c) = d14286be8ccdbcb5fae544a1968e7b681b63e884
|
SHA1 (patch-libxl_libxl_uuid.c) = d14286be8ccdbcb5fae544a1968e7b681b63e884
|
||||||
SHA1 (patch-libxl_xl__cmdtable.c) = d149603cac13c996d7800cee94a9df3aaadf9625
|
SHA1 (patch-libxl_xl__cmdtable.c) = d149603cac13c996d7800cee94a9df3aaadf9625
|
||||||
SHA1 (patch-libxl_xl_cmdimpl.c) = 7aea48a9761b39cf620dcad2295a257c5fc53c8c
|
SHA1 (patch-libxl_xl_cmdimpl.c) = 7aea48a9761b39cf620dcad2295a257c5fc53c8c
|
||||||
SHA1 (patch-ocaml_common.make) = df631c2da394b6e021934d2508e9d9fb497c3d41
|
SHA1 (patch-ocaml_common.make) = 9be67ac373f21688d7d8ff92430b1185305d728a
|
||||||
SHA1 (patch-ocaml_xenstored_Makefile) = 237e26d3ec25d706e16b415f90e0fcc4913e02e5
|
SHA1 (patch-ocaml_xenstored_Makefile) = 237e26d3ec25d706e16b415f90e0fcc4913e02e5
|
||||||
SHA1 (patch-ocaml_xenstored_define.ml) = 18d6878ae536554e8831f3732d2a8ea1b13a9b63
|
SHA1 (patch-ocaml_xenstored_define.ml) = 18d6878ae536554e8831f3732d2a8ea1b13a9b63
|
||||||
SHA1 (patch-ocaml_xenstored_utils.ml) = 04997cb9189a3331522c344aa1957e61febfd4d2
|
SHA1 (patch-ocaml_xenstored_utils.ml) = 04997cb9189a3331522c344aa1957e61febfd4d2
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
$NetBSD: patch-ocaml_common.make,v 1.2 2017/08/23 02:38:38 maya Exp $
|
$NetBSD: patch-ocaml_common.make,v 1.3 2018/01/27 18:24:16 abs Exp $
|
||||||
|
|
||||||
Handle ocaml-findlib already appending DESTDIR
|
Add -unsafe-string to fix build with ocaml-4.06.0 and later
|
||||||
|
|
||||||
--- ocaml/common.make.orig 2015-01-12 17:53:24.000000000 +0100
|
--- ocaml/common.make.orig 2017-07-06 07:04:28.000000000 +0000
|
||||||
+++ ocaml/common.make 2015-01-19 13:16:38.000000000 +0100
|
+++ ocaml/common.make
|
||||||
@@ -3,7 +3,7 @@
|
@@ -3,7 +3,7 @@ include $(XEN_ROOT)/tools/Rules.mk
|
||||||
CC ?= gcc
|
CC ?= gcc
|
||||||
OCAMLOPT ?= ocamlopt
|
OCAMLOPT ?= ocamlopt
|
||||||
OCAMLC ?= ocamlc
|
OCAMLC ?= ocamlc
|
||||||
|
@ -13,12 +13,18 @@ Handle ocaml-findlib already appending DESTDIR
|
||||||
OCAMLDEP ?= ocamldep
|
OCAMLDEP ?= ocamldep
|
||||||
OCAMLLEX ?= ocamllex
|
OCAMLLEX ?= ocamllex
|
||||||
OCAMLYACC ?= ocamlyacc
|
OCAMLYACC ?= ocamlyacc
|
||||||
@@ -17,6 +17,6 @@ OCAMLCFLAGS += -g $(OCAMLINCLUDE) -w F -
|
@@ -12,11 +12,11 @@ OCAMLFIND ?= ocamlfind
|
||||||
|
CFLAGS += -fPIC -Werror -I$(shell ocamlc -where)
|
||||||
|
|
||||||
|
OCAMLOPTFLAG_G := $(shell $(OCAMLOPT) -h 2>&1 | sed -n 's/^ *\(-g\) .*/\1/p')
|
||||||
|
-OCAMLOPTFLAGS = $(OCAMLOPTFLAG_G) -ccopt "$(LDFLAGS)" -dtypes $(OCAMLINCLUDE) -cc $(CC) -w F -warn-error F
|
||||||
|
-OCAMLCFLAGS += -g $(OCAMLINCLUDE) -w F -warn-error F
|
||||||
|
+OCAMLOPTFLAGS = $(OCAMLOPTFLAG_G) -unsafe-string -ccopt "$(LDFLAGS)" -dtypes $(OCAMLINCLUDE) -cc $(CC) -w F -warn-error F
|
||||||
|
+OCAMLCFLAGS += -unsafe-string -g $(OCAMLINCLUDE) -w F -warn-error F
|
||||||
|
|
||||||
VERSION := 4.1
|
VERSION := 4.1
|
||||||
|
|
||||||
-OCAMLDESTDIR ?= $(DESTDIR)$(shell $(OCAMLFIND) printconf destdir)
|
-OCAMLDESTDIR ?= $(DESTDIR)$(shell $(OCAMLFIND) printconf destdir)
|
||||||
+OCAMLDESTDIR ?= $(shell $(OCAMLFIND) printconf destdir)
|
+OCAMLDESTDIR ?= $(shell $(OCAMLFIND) printconf destdir)
|
||||||
|
|
||||||
o= >$@.new && mv -f $@.new $@
|
o= >$@.new && mv -f $@.new $@
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue