SDL2: update to 2.0.16
General: Added SDL_FlashWindow() to get a user’s attention Added SDL_GetAudioDeviceSpec() to get the preferred audio format of a device Added SDL_SetWindowAlwaysOnTop() to dynamically change the SDL_WINDOW_ALWAYS_ON_TOP flag for a window Added SDL_SetWindowKeyboardGrab() to support grabbing the keyboard independently of the mouse Added SDL_SoftStretchLinear() to do bilinear scaling between 32-bit software surfaces Added SDL_UpdateNVTexture() to update streaming NV12/21 textures Added SDL_GameControllerSendEffect() and SDL_JoystickSendEffect() to allow sending custom trigger effects to the DualSense controller Added SDL_GameControllerGetSensorDataRate() to get the sensor data rate for PlayStation and Nintendo Switch controllers Added support for the Amazon Luna game controller Added rumble support for the Google Stadia controller using the HIDAPI driver Added SDL_GameControllerType constants for the Amazon Luna and Google Stadia controllers Added analog rumble for Nintendo Switch Pro controllers using the HIDAPI driver Reduced CPU usage when using SDL_WaitEvent() and SDL_WaitEventTimeout()
This commit is contained in:
parent
624af70d8a
commit
9769e27757
4 changed files with 42 additions and 34 deletions
|
@ -1,7 +1,6 @@
|
||||||
# $NetBSD: Makefile,v 1.57 2021/07/30 12:26:43 ryoon Exp $
|
# $NetBSD: Makefile,v 1.58 2021/08/11 20:12:24 nia Exp $
|
||||||
|
|
||||||
DISTNAME= SDL2-2.0.14
|
DISTNAME= SDL2-2.0.16
|
||||||
PKGREVISION= 3
|
|
||||||
CATEGORIES= devel
|
CATEGORIES= devel
|
||||||
MASTER_SITES= https://www.libsdl.org/release/
|
MASTER_SITES= https://www.libsdl.org/release/
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.45 2021/03/09 20:41:08 mrg Exp $
|
$NetBSD: distinfo,v 1.46 2021/08/11 20:12:24 nia Exp $
|
||||||
|
|
||||||
SHA1 (SDL2-2.0.14.tar.gz) = 212b17d988c417a1a905ab09c50d1845cc48ddb7
|
SHA1 (SDL2-2.0.16.tar.gz) = 57825428174adb2ac947e4014080c262505aa972
|
||||||
RMD160 (SDL2-2.0.14.tar.gz) = 24ddf4bab53fae92fb0c96c7d3e6ceecca91c5df
|
RMD160 (SDL2-2.0.16.tar.gz) = 82315a0e9562755d9d7d6b958fc6fc478676efe9
|
||||||
SHA512 (SDL2-2.0.14.tar.gz) = ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee
|
SHA512 (SDL2-2.0.16.tar.gz) = ec75ef8526792650c2647b78bb0244f973774418aeae33a2182d90ce696b30acb652f8be9c2012a16c1c5d5622f7630ff2e1eadae27ea3dc78ab47730cf5e62f
|
||||||
Size (SDL2-2.0.14.tar.gz) = 6089974 bytes
|
Size (SDL2-2.0.16.tar.gz) = 7227262 bytes
|
||||||
SHA1 (patch-src_audio_netbsd_SDL_netbsdaudio.c) = e62b5b57d90b2f79c58b665e6f9f5f45893206f8
|
SHA1 (patch-src_video_wayland_SDL__waylandmessagebox.c) = 676972b1b489d8c6138866ace28867a77efb7e56
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
$NetBSD: patch-src_audio_netbsd_SDL_netbsdaudio.c,v 1.1 2021/03/09 20:41:08 mrg Exp $
|
|
||||||
|
|
||||||
check the return value of ioctl() on audio device and report error
|
|
||||||
if it doesn't work. stops eg mpv from hanging when it thinks that
|
|
||||||
it opened the audio device.
|
|
||||||
|
|
||||||
--- src/audio/netbsd/SDL_netbsdaudio.c.orig 2020-12-21 11:44:36.000000000 -0600
|
|
||||||
+++ src/audio/netbsd/SDL_netbsdaudio.c 2021-03-09 14:27:27.994211006 -0600
|
|
||||||
@@ -291,9 +291,14 @@
|
|
||||||
info.lowat = 3;
|
|
||||||
prinfo->sample_rate = this->spec.freq;
|
|
||||||
prinfo->channels = this->spec.channels;
|
|
||||||
- (void) ioctl(this->hidden->audio_fd, AUDIO_SETINFO, &info);
|
|
||||||
|
|
||||||
- (void) ioctl(this->hidden->audio_fd, AUDIO_GETINFO, &info);
|
|
||||||
+ if (ioctl(this->hidden->audio_fd, AUDIO_SETINFO, &info) < 0) {
|
|
||||||
+ return SDL_SetError("Couldn't AUDIO_SETINFO %s: %s", devname, strerror(errno));
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (ioctl(this->hidden->audio_fd, AUDIO_GETINFO, &info) < 0) {
|
|
||||||
+ return SDL_SetError("Couldn't AUDIO_GETINFO %s: %s", devname, strerror(errno));
|
|
||||||
+ }
|
|
||||||
this->spec.freq = prinfo->sample_rate;
|
|
||||||
this->spec.channels = prinfo->channels;
|
|
||||||
|
|
|
@ -0,0 +1,34 @@
|
||||||
|
$NetBSD: patch-src_video_wayland_SDL__waylandmessagebox.c,v 1.1 2021/08/11 20:12:25 nia Exp $
|
||||||
|
|
||||||
|
Avoid conflict if stdout is a macro.
|
||||||
|
|
||||||
|
--- src/video/wayland/SDL_waylandmessagebox.c.orig 2021-07-27 14:52:29.000000000 +0000
|
||||||
|
+++ src/video/wayland/SDL_waylandmessagebox.c
|
||||||
|
@@ -116,7 +116,7 @@ Wayland_ShowMessageBox(const SDL_Message
|
||||||
|
size_t output_len = 1;
|
||||||
|
char* output = NULL;
|
||||||
|
char* tmp = NULL;
|
||||||
|
- FILE* stdout = NULL;
|
||||||
|
+ FILE* stdout_ = NULL;
|
||||||
|
|
||||||
|
close(fd_pipe[1]); /* no writing to pipe */
|
||||||
|
/* At this point, if no button ID is needed, we can just bail as soon as the
|
||||||
|
@@ -144,14 +144,14 @@ Wayland_ShowMessageBox(const SDL_Message
|
||||||
|
}
|
||||||
|
output[0] = '\0';
|
||||||
|
|
||||||
|
- stdout = fdopen(fd_pipe[0], "r");
|
||||||
|
- if (!stdout) {
|
||||||
|
+ stdout_ = fdopen(fd_pipe[0], "r");
|
||||||
|
+ if (!stdout_) {
|
||||||
|
SDL_free(output);
|
||||||
|
close(fd_pipe[0]);
|
||||||
|
return SDL_SetError("Couldn't open pipe for reading: %s", strerror(errno));
|
||||||
|
}
|
||||||
|
- tmp = fgets(output, output_len + 1, stdout);
|
||||||
|
- fclose(stdout);
|
||||||
|
+ tmp = fgets(output, output_len + 1, stdout_);
|
||||||
|
+ fclose(stdout_);
|
||||||
|
|
||||||
|
if ((tmp == NULL) || (*tmp == '\0') || (*tmp == '\n')) {
|
||||||
|
SDL_free(output);
|
Loading…
Reference in a new issue