Re-import the previous gpgme version for packages that still use the
older interface. Does not coexist with newer version, so the PKGNAMEs are intended to be the same.
This commit is contained in:
parent
90da47a589
commit
978951a718
6 changed files with 87 additions and 0 deletions
4
security/gpgme03/DESCR
Normal file
4
security/gpgme03/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
|
||||
easier for applications. It provides a High-Level Crypto API for
|
||||
encryption, decryption, signing, signature verification and key
|
||||
management.
|
30
security/gpgme03/Makefile
Normal file
30
security/gpgme03/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/12/14 17:51:04 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gpgme-0.3.15
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/gpgme/
|
||||
|
||||
MAINTAINER= oishi@ims.ac.jp
|
||||
HOMEPAGE= http://www.gnupg.org/gpgme.html
|
||||
COMMENT= GnuPG Made Easy
|
||||
|
||||
DEPENDS+= gnupg>=1.2.0:../../security/gnupg
|
||||
|
||||
USE_BUILDLINK2= YES
|
||||
GNU_CONFIGURE= YES
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
|
||||
.if ${PTHREAD_TYPE} == "native"
|
||||
CONFIGURE_ARGS+= --without-pth --without-pth-test
|
||||
.endif
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
|
||||
INFO_FILES= gpgme.info
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
14
security/gpgme03/PLIST
Normal file
14
security/gpgme03/PLIST
Normal file
|
@ -0,0 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/14 17:51:04 wiz Exp $
|
||||
bin/gpgme-config
|
||||
include/gpgme.h
|
||||
info/gpgme.info
|
||||
info/gpgme.info-1
|
||||
info/gpgme.info-2
|
||||
info/gpgme.info-3
|
||||
info/gpgme.info-4
|
||||
lib/libgpgme.a
|
||||
lib/libgpgme.la
|
||||
lib/libgpgme.so
|
||||
lib/libgpgme.so.9
|
||||
lib/libgpgme.so.9.6
|
||||
share/aclocal/gpgme.m4
|
20
security/gpgme03/buildlink2.mk
Normal file
20
security/gpgme03/buildlink2.mk
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/12/14 17:51:04 wiz Exp $
|
||||
#
|
||||
|
||||
.if !defined(GPGME_BUILDLINK2_MK)
|
||||
GPGME_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= gpgme
|
||||
BUILDLINK_DEPENDS.gpgme?= gpgme>=0.3.15nb1
|
||||
BUILDLINK_PKGSRCDIR.gpgme?= ../../security/gpgme
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.gpgme=gpgme
|
||||
BUILDLINK_PREFIX.gpgme_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.gpgme+= include/gpgme.h
|
||||
BUILDLINK_FILES.gpgme+= lib/libgpgme.*
|
||||
|
||||
BUILDLINK_TARGETS+= gpgme-buildlink
|
||||
|
||||
gpgme-buildlink: _BUILDLINK_USE
|
||||
|
||||
.endif # GPGME_BUILDLINK2_MK
|
5
security/gpgme03/distinfo
Normal file
5
security/gpgme03/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/12/14 17:51:04 wiz Exp $
|
||||
|
||||
SHA1 (gpgme-0.3.15.tar.gz) = cc61450d2412786ab234d23b17b1682b51046443
|
||||
Size (gpgme-0.3.15.tar.gz) = 674568 bytes
|
||||
SHA1 (patch-ab) = d73b151c643d6ae5b2a321e58291a6b48892fd03
|
14
security/gpgme03/patches/patch-ab
Normal file
14
security/gpgme03/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/12/14 17:51:04 wiz Exp $
|
||||
--- tests/gpg/mkdemodirs.orig Wed Oct 17 06:08:55 2001
|
||||
+++ tests/gpg/mkdemodirs Wed Jan 30 14:17:56 2002
|
||||
@@ -25,7 +25,9 @@
|
||||
echo -n "Creating:"
|
||||
for name in $NAMES; do
|
||||
echo -n " $name"
|
||||
- [ -d $name ] && rm -r $name
|
||||
+ if [ -d $name ]; then
|
||||
+ rm -r $name
|
||||
+ fi
|
||||
mkdir $name
|
||||
$GPGDEMO --export-secret-key -o - $name > $name/Secret.gpg
|
||||
$GPG --homedir $name --allow-secret-key-import --import $name/Secret.gpg
|
Loading…
Reference in a new issue