Fix obviously wrong code handling XSLTPARAMS with the --stringparam option.

PR 44126 from Goetz Isenmann. PKGREVISION++.

While here, add comment to patch-ab.
This commit is contained in:
dholland 2010-11-22 05:54:17 +00:00
parent 978f37177e
commit 978af91e91
3 changed files with 20 additions and 5 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.16 2008/11/18 15:20:54 wiz Exp $
# $NetBSD: Makefile,v 1.17 2010/11/22 05:54:17 dholland Exp $
#
DISTNAME= xmlto-0.0.21
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= textproc
MASTER_SITES= # ftp(1) doesn't speak https: https://fedorahosted.org/xmlto/browser
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2008/11/10 23:01:38 wiz Exp $
$NetBSD: distinfo,v 1.6 2010/11/22 05:54:17 dholland Exp $
SHA1 (xmlto-0.0.21.tar.bz2) = 691202620b337d9c35c95c81306ea629248a8850
RMD160 (xmlto-0.0.21.tar.bz2) = 21d4f82c1e9dcb8617132f097921db722bc901c6
Size (xmlto-0.0.21.tar.bz2) = 99554 bytes
SHA1 (patch-aa) = 24c15146e9d4a2147b24ab192c5af68af0cabd21
SHA1 (patch-ab) = ad056853e64c810e392347a5d939b0629cff53bd
SHA1 (patch-ab) = 174184839d52fb170f3b5adf01c9867588cf5be6

View file

@ -1,4 +1,8 @@
$NetBSD: patch-ab,v 1.2 2008/11/10 23:01:38 wiz Exp $
$NetBSD: patch-ab,v 1.3 2010/11/22 05:54:17 dholland Exp $
- don't hardwire paths
- fix obvious bug handling XSLTPARAMS (PR 44126), already fixed upstream
- xmllint needs --nonet
--- xmlto.in.orig 2008-05-30 13:41:31.000000000 +0000
+++ xmlto.in
@ -29,6 +33,17 @@ $NetBSD: patch-ab,v 1.2 2008/11/10 23:01:38 wiz Exp $
then
charmap=$(locale charmap 2>/dev/null)
@@ -273,8 +273,8 @@ while [ "$#" -gt "0" ]; do
;;
--stringparam)
MYPARAM="$2"
- XSLTPARAMS="XSLTPARAMS --stringparam ${MYPARAM%=*}"
- XSLTPARAMS="XSLTPARAMS $MYPARAM#*=}"
+ XSLTPARAMS="$XSLTPARAMS --stringparam ${MYPARAM%=*}"
+ XSLTPARAMS="$XSLTPARAMS $MYPARAM#*=}"
shift 2
;;
--noclean)
@@ -427,8 +427,8 @@ if [ "$SKIP_VALIDATION" -eq 0 ] && [ "$S
then
VALIDATION="${XSLT_PROCESSED_DIR}/validation-errors"