Update to 4.11.1:
v4.11.1 3rd July 2014 - Added the -tr-function, -trUtf8-function and -translate-function command line options to pylupdate4. - Bug fixes. v4.11 26th May 2014 - By default a Python slot is only invoked if the underlying C++ instance still exists. - Added the no_receiver_check argument to connect(). - Added support for Qt v4.8.6. - Added --target-py-version, --sysroot and --no-tools options to configure-ng.py. - Cross-compiling (specifically to iOS and Android when building against Qt v5) is now supported. - SIP v4.16 is now required. - Bug fixes. v4.10.4 14th March 2014 - Added the port of the webftpclient from Moritz Warning. - The --use-arch argument to configure.py can now be specified more than once. - Bug fixes. v4.10.3 21st August 2013 - Bug fixes.
This commit is contained in:
parent
c466237e21
commit
97d0c76d34
4 changed files with 16 additions and 20 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.73 2014/02/12 23:18:53 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.74 2014/08/21 21:33:07 wiz Exp $
|
||||
|
||||
PKGNAME= ${PYPKGPREFIX}-qt4-${PYQT_VERSION}
|
||||
PYQT_VERSION= 4.10.2
|
||||
PKGREVISION= 1
|
||||
PYQT_VERSION= 4.11.1
|
||||
CATEGORIES= x11 python
|
||||
#MASTER_SITES= http://www.riverbankcomputing.com/static/Downloads/PyQt4/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pyqt/}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST.common,v 1.23 2013/09/05 15:29:05 drochner Exp $
|
||||
@comment $NetBSD: PLIST.common,v 1.24 2014/08/21 21:33:07 wiz Exp $
|
||||
bin/pylupdate4
|
||||
bin/pyrcc4
|
||||
bin/pyuic4
|
||||
|
@ -205,6 +205,7 @@ share/sip${PYVERSSUFFIX}/QtDesigner/qpydesignerpropertysheetextension.sip
|
|||
share/sip${PYVERSSUFFIX}/QtDesigner/qpydesignertaskmenuextension.sip
|
||||
share/sip${PYVERSSUFFIX}/QtDesigner/taskmenu.sip
|
||||
share/sip${PYVERSSUFFIX}/QtGui/QtGuimod.sip
|
||||
share/sip${PYVERSSUFFIX}/QtGui/opengl_types.sip
|
||||
share/sip${PYVERSSUFFIX}/QtGui/qabstractbutton.sip
|
||||
share/sip${PYVERSSUFFIX}/QtGui/qabstractitemdelegate.sip
|
||||
share/sip${PYVERSSUFFIX}/QtGui/qabstractitemview.sip
|
||||
|
@ -460,7 +461,6 @@ share/sip${PYVERSSUFFIX}/QtNetwork/qtcpsocket.sip
|
|||
share/sip${PYVERSSUFFIX}/QtNetwork/qudpsocket.sip
|
||||
share/sip${PYVERSSUFFIX}/QtNetwork/qurlinfo.sip
|
||||
share/sip${PYVERSSUFFIX}/QtOpenGL/QtOpenGLmod.sip
|
||||
share/sip${PYVERSSUFFIX}/QtOpenGL/opengl_types.sip
|
||||
share/sip${PYVERSSUFFIX}/QtOpenGL/qgl.sip
|
||||
share/sip${PYVERSSUFFIX}/QtOpenGL/qglbuffer.sip
|
||||
share/sip${PYVERSSUFFIX}/QtOpenGL/qglcolormap.sip
|
||||
|
|
|
@ -1,10 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.32 2014/01/09 19:03:08 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.33 2014/08/21 21:33:07 wiz Exp $
|
||||
|
||||
SHA1 (PyQt-mac-gpl-4.10.2.tar.gz) = 40362e6b9f476683e4e35b83369e30a8dfff99ad
|
||||
RMD160 (PyQt-mac-gpl-4.10.2.tar.gz) = a2a829f41e0753dc93efaf0d9e4e76d2c54d6d2c
|
||||
Size (PyQt-mac-gpl-4.10.2.tar.gz) = 11277392 bytes
|
||||
SHA1 (PyQt-x11-gpl-4.10.2.tar.gz) = 9a90e74c73f7c3e4a91eeb6f268f323a5722d9b6
|
||||
RMD160 (PyQt-x11-gpl-4.10.2.tar.gz) = 530ec99325bade7c0451d3458da020e9ab981a1c
|
||||
Size (PyQt-x11-gpl-4.10.2.tar.gz) = 11280941 bytes
|
||||
SHA1 (patch-aa) = 726a9be11f0fa8a275daa61358557cf37a6bf531
|
||||
SHA1 (PyQt-x11-gpl-4.11.1.tar.gz) = 83a0740545d51c179a1b316b664b0f9ff5e0f5af
|
||||
RMD160 (PyQt-x11-gpl-4.11.1.tar.gz) = 37f5dc06b4d06720a9f94dcd50f67a011c2dad78
|
||||
Size (PyQt-x11-gpl-4.11.1.tar.gz) = 11118850 bytes
|
||||
SHA1 (patch-aa) = 218eb50a2b027384030e5ba9900631138687fac3
|
||||
SHA1 (patch-sip_QtCore_qlist.sip) = 4fb548d4ee755cbc955ec32a6b1702a71a9815f1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.10 2013/09/05 15:29:05 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.11 2014/08/21 21:33:07 wiz Exp $
|
||||
|
||||
--- configure.py.orig 2013-04-21 12:01:57.000000000 +0000
|
||||
--- configure.py.orig 2014-07-03 14:00:02.000000000 +0000
|
||||
+++ configure.py
|
||||
@@ -345,7 +345,7 @@ class ConfigurePyQt4:
|
||||
@@ -346,7 +346,7 @@ class ConfigurePyQt4:
|
||||
pyqt_modules.append("QtCore")
|
||||
|
||||
check_module("QtGui", "qwidget.h", "new QWidget()")
|
||||
|
@ -11,9 +11,9 @@ $NetBSD: patch-aa,v 1.10 2013/09/05 15:29:05 drochner Exp $
|
|||
check_module("QtMultimedia", "QAudioDeviceInfo",
|
||||
"new QAudioDeviceInfo()")
|
||||
check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
|
||||
@@ -369,8 +369,8 @@ class ConfigurePyQt4:
|
||||
@@ -372,8 +372,8 @@ class ConfigurePyQt4:
|
||||
check_module("QtTest", "QtTest", "QTest::qSleep(0)")
|
||||
check_module("QtWebKit", "qwebpage.h", "new QWebPage()")
|
||||
check_module("QtXml", "qdom.h", "new QDomDocument()")
|
||||
check_module("QtXmlPatterns", "qxmlname.h", "new QXmlName()")
|
||||
- check_module("phonon", "phonon/videowidget.h",
|
||||
- "new Phonon::VideoWidget()")
|
||||
|
@ -22,14 +22,14 @@ $NetBSD: patch-aa,v 1.10 2013/09/05 15:29:05 drochner Exp $
|
|||
check_module("QtAssistant", "qassistantclient.h",
|
||||
"new QAssistantClient(\"foo\")", extra_lib_dirs=ass_lib_dirs,
|
||||
extra_libs=ass_libs)
|
||||
@@ -2093,11 +2093,7 @@ int main(int argc, char **argv)
|
||||
@@ -2027,11 +2027,7 @@ int main(int argc, char **argv)
|
||||
|
||||
out << QLibraryInfo::licensee() << '\\n';
|
||||
|
||||
-#if defined(QT_SHARED) || defined(QT_DLL)
|
||||
out << "shared\\n";
|
||||
-#else
|
||||
- out << "\\n";
|
||||
- out << "static\\n";
|
||||
-#endif
|
||||
|
||||
// Determine which features should be disabled.
|
||||
|
|
Loading…
Reference in a new issue