Restore "cdrecord-current" package. It was already updated to a more recent
version than the "cdrecord" package.
This commit is contained in:
parent
04e287ce52
commit
97dca07834
10 changed files with 125 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.58 2000/03/03 23:46:16 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.59 2000/03/04 10:10:09 tron Exp $
|
||||
# FreeBSD Id: Makefile,v 1.23 1997/09/30 06:14:59 asami Exp
|
||||
#
|
||||
|
||||
|
@ -14,6 +14,7 @@
|
|||
SUBDIR += bchunk
|
||||
SUBDIR += cdrdao
|
||||
SUBDIR += cdrecord
|
||||
# SUBDIR += cdrecord-current # disabled by default
|
||||
SUBDIR += cfengine
|
||||
SUBDIR += cpogm
|
||||
SUBDIR += crashme
|
||||
|
|
34
sysutils/cdrecord-current/Makefile
Normal file
34
sysutils/cdrecord-current/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# $NetBSD: Makefile,v 1.8 2000/03/04 10:10:10 tron Exp $
|
||||
|
||||
DISTNAME= cdrecord-1.8.1a01
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/alpha/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:C/a.*//}
|
||||
TARGET_ARCH= ${MACHINE}-netbsd-cc
|
||||
TARGET_DIR= OBJ/${TARGET_ARCH}
|
||||
|
||||
do-configure:
|
||||
${MKDIR} ${WRKSRC}/include/sys
|
||||
${LN} -fs /usr/include/soundcard.h ${WRKSRC}/include/sys
|
||||
cd ${WRKSRC}/RULES; \
|
||||
${TEST} -f netbsd-cc.rul || ${MV} i386-netbsd-cc.rul netbsd-cc.rul; \
|
||||
${TEST} -f netbsd-gcc.rul || ${MV} i386-netbsd-gcc.rul netbsd-gcc.rul; \
|
||||
${LN} -sf netbsd-gcc.rul ${MACHINE}-netbsd-gcc.rul; \
|
||||
${LN} -sf netbsd-cc.rul ${TARGET_ARCH}.rul
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/cdda2wav; \
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdda2wav ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdda2wav.1 ${PREFIX}/man/man1
|
||||
cd ${WRKSRC}/cdrecord; \
|
||||
${INSTALL_PROGRAM} ${TARGET_DIR}/cdrecord ${PREFIX}/bin; \
|
||||
${INSTALL_MAN} cdrecord.1 ${PREFIX}/man/man1
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/misc/${TARGET_DIR}/readcd ${PREFIX}/bin
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/cdrecord-current/files/md5
Normal file
3
sysutils/cdrecord-current/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.6 2000/03/04 10:10:10 tron Exp $
|
||||
|
||||
MD5 (cdrecord-1.8.1a01.tar.gz) = 35d0d86fa8c96c752b72f2e2293b3771
|
5
sysutils/cdrecord-current/files/patch-sum
Normal file
5
sysutils/cdrecord-current/files/patch-sum
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: patch-sum,v 1.7 2000/03/04 10:10:10 tron Exp $
|
||||
|
||||
MD5 (patch-aa) = ce1e36780a6289a44496d355e35da71c
|
||||
MD5 (patch-ab) = 3a20ed15fd69037fc67d9d7172125c23
|
||||
MD5 (patch-ae) = 4c3938baa5a03adc55193361aa43c697
|
10
sysutils/cdrecord-current/patches/patch-aa
Normal file
10
sysutils/cdrecord-current/patches/patch-aa
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.3 2000/03/04 10:10:10 tron Exp $
|
||||
|
||||
--- TARGETS/Targetdirs.orig Mon Aug 30 17:19:44 1999
|
||||
+++ TARGETS/Targetdirs Fri Sep 17 00:29:27 1999
|
||||
@@ -1,4 +1,4 @@
|
||||
#ident %W% %E% %Q%
|
||||
###########################################################################
|
||||
-DIRS= patches conf inc lib libdeflt libscg cdrecord mkisofs-1.12b5 mkisofs-1.12b5/diag cdda2wav misc man
|
||||
+DIRS= patches conf inc lib libdeflt libscg cdrecord cdda2wav misc
|
||||
###########################################################################
|
22
sysutils/cdrecord-current/patches/patch-ab
Normal file
22
sysutils/cdrecord-current/patches/patch-ab
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ab,v 1.4 2000/03/04 10:10:11 tron Exp $
|
||||
|
||||
--- DEFAULTS/Defaults.netbsd.orig Tue Nov 2 12:41:03 1999
|
||||
+++ DEFAULTS/Defaults.netbsd Mon Nov 15 20:29:31 1999
|
||||
@@ -19,7 +19,7 @@
|
||||
CWARNOPTS=
|
||||
|
||||
DEFINCDIRS= $(SRCROOT)/include
|
||||
-LDPATH= -L/opt/schily/lib
|
||||
+LDPATH= -L$(SRCROOT)/lib
|
||||
#RUNPATH= -R $(INS_BASE)/lib -R /opt/schily/lib -R $(OLIBSDIR) Will probably not work
|
||||
|
||||
###########################################################################
|
||||
@@ -27,7 +27,7 @@
|
||||
# Installation config stuff
|
||||
#
|
||||
###########################################################################
|
||||
-INS_BASE= /opt/schily
|
||||
+INS_BASE= $(PREFIX)
|
||||
INS_KBASE= /
|
||||
#
|
||||
DEFUMASK= 002
|
23
sysutils/cdrecord-current/patches/patch-ae
Normal file
23
sysutils/cdrecord-current/patches/patch-ae
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-ae,v 1.5 2000/03/04 10:10:11 tron Exp $
|
||||
|
||||
--- cdda2wav/Makefile.orig Tue Nov 16 00:48:52 1999
|
||||
+++ cdda2wav/Makefile Tue Nov 16 00:49:23 1999
|
||||
@@ -7,7 +7,8 @@
|
||||
|
||||
INSDIR= bin
|
||||
TARGET= cdda2wav
|
||||
-CPPOPTS += -DFIFO -I../cdrecord $(CDDA2WAVDEFS)
|
||||
+CPPOPTS += -DFIFO -I../cdrecord $(CDDA2WAVDEFS) \
|
||||
+ -DECHO_TO_SOUNDCARD -DHAVE_OSS=1 -DHAVE_SYS_SOUNDCARD_H
|
||||
CFILES= cdda2wav.c interface.c semshm.c resample.c \
|
||||
toc.c wav.c sun.c raw.c md5c.c setuid.c ringbuff.c \
|
||||
sndconfig.c scsi_cmds.c aiff.c aifc.c \
|
||||
@@ -17,7 +18,7 @@
|
||||
config.h saveargs.h sndfile.h aiff.h aifc.h \
|
||||
sndconfig.h scsi_cmds.h lowlevel.h byteorder.h mycdrom.h \
|
||||
base64.h sha.h mmsystem.h
|
||||
-LIBS= -lscg -lschily $(SCSILIB) $(EXTRALIB)
|
||||
+LIBS= -lscg -lschily $(SCSILIB) $(EXTRALIB) -lossaudio
|
||||
XMK_FILE= Makefile.man
|
||||
|
||||
LCONFIG= local.cnf
|
1
sysutils/cdrecord-current/pkg/COMMENT
Normal file
1
sysutils/cdrecord-current/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
This program allows you to create CD's on a CD-Recorder
|
19
sysutils/cdrecord-current/pkg/DESCR
Normal file
19
sysutils/cdrecord-current/pkg/DESCR
Normal file
|
@ -0,0 +1,19 @@
|
|||
Cdrecord allows you to create CD's on a CD-Recorder.
|
||||
|
||||
Cdrecord has been implemented with a Philips CDD 521.
|
||||
Cdrecord now is maintained with a Philips CDD-2000
|
||||
It should run also on:
|
||||
|
||||
Philips CDD 522
|
||||
Philips CDD 2000
|
||||
Philips CDD 2600
|
||||
HP C4324/C4325 (HP SureStore 4020i/6020i)
|
||||
Plasmon RF-41000
|
||||
Plasmon CDR 4220 (not tested)
|
||||
Grundig CDR-100 (not tested)
|
||||
Mitsumi CR-2401-TS (not tested)
|
||||
Yamaha CDR-100
|
||||
Yamaha CDR-102
|
||||
Sony CDU-924
|
||||
|
||||
Multi-session has not been tested with the Plasmon RF-4100
|
6
sysutils/cdrecord-current/pkg/PLIST
Normal file
6
sysutils/cdrecord-current/pkg/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2000/03/04 10:10:11 tron Exp $
|
||||
bin/cdda2wav
|
||||
bin/cdrecord
|
||||
bin/readcd
|
||||
man/man1/cdda2wav.1
|
||||
man/man1/cdrecord.1
|
Loading…
Reference in a new issue