Fix build failure due to 64-bit time_t.

This commit is contained in:
tnn 2009-03-17 13:52:08 +00:00
parent 26ccec474a
commit 98190c9b0c
2 changed files with 18 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.31 2009/03/15 18:14:24 jmcneill Exp $
$NetBSD: distinfo,v 1.32 2009/03/17 13:52:08 tnn Exp $
SHA1 (gnome-keyring-2.26.0.tar.bz2) = dcbc2f06bca8f8d6d310064a85f5ab97a6af8889
RMD160 (gnome-keyring-2.26.0.tar.bz2) = 0cbf6208864f39a9437faadd9fb348eaccef65ba
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 7f7c15099b1abedf24493c4a14d6a71941ed09bd
SHA1 (patch-ac) = 550b4ebfdf9ae7653d0174e6857e32c8453f2ca7
SHA1 (patch-ad) = df4a9a69ca9262066daf2272869ce63471c15bd3
SHA1 (patch-ae) = c727e8e6fa07daf2c40cf2a2de4322eb4f683b96
SHA1 (patch-af) = 72c8b88b21c71f94efd2e5f684f9007ed567b0aa

View file

@ -0,0 +1,16 @@
$NetBSD: patch-af,v 1.1 2009/03/17 13:52:08 tnn Exp $
--- egg/egg-asn1.h.orig 2009-03-02 16:43:19.000000000 +0100
+++ egg/egg-asn1.h
@@ -75,9 +75,9 @@ gchar* egg_asn1_read_dn
gchar* egg_asn1_read_dn_part (ASN1_TYPE asn, const gchar *part, const gchar *match);
-glong egg_asn1_time_parse_utc (const gchar* value);
+time_t egg_asn1_time_parse_utc (const gchar* value);
-glong egg_asn1_time_parse_general (const gchar* value);
+time_t egg_asn1_time_parse_general (const gchar* value);
typedef void (*EggAsn1DnCallback) (guint index, GQuark oid, const guchar *value,