Fix build on DragonFly 1.6+.

This commit is contained in:
joerg 2006-09-24 15:40:38 +00:00
parent 530c943863
commit 982e92296e
2 changed files with 19 additions and 6 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.8 2006/01/25 15:48:50 joerg Exp $
$NetBSD: distinfo,v 1.9 2006/09/24 15:40:38 joerg Exp $
SHA1 (ruby-quota-0.5.1.tar.gz) = 9edf6054c465af80d7a3534b8fed89fbafc01ec1
RMD160 (ruby-quota-0.5.1.tar.gz) = 85189827a256d0cfeaa0e755db37b85c625c18df
Size (ruby-quota-0.5.1.tar.gz) = 5110 bytes
SHA1 (patch-aa) = 354277b1f3e174d7de742d965c0b788ec04350a8
SHA1 (patch-ab) = dff362167380e72a7fc6be4fcb580a10a1e17e87
SHA1 (patch-ab) = 061755cac0cbed45ed05157cd646c2746f30b71c

View file

@ -1,8 +1,21 @@
$NetBSD: patch-ab,v 1.3 2006/01/25 15:48:50 joerg Exp $
$NetBSD: patch-ab,v 1.4 2006/09/24 15:40:38 joerg Exp $
--- quota.c.orig 2002-03-30 23:59:12.000000000 +0900
--- quota.c.orig 2002-03-30 14:59:12.000000000 +0000
+++ quota.c
@@ -159,7 +159,11 @@ rb_quotactl(int cmd, char *dev, VALUE vu
@@ -51,6 +51,12 @@
#if defined(SYS_UCRED_H)
# include <sys/ucred.h> /* required by NetBSD,FreeBSD */
#endif
+#if defined(__DragonFly__)
+# include <sys/param.h>
+# if __DragonFly_version >= 160000
+# define dqblk ufs_dqblk
+# endif
+#endif
#endif
static VALUE rb_mQuota;
@@ -159,7 +165,11 @@ rb_quotactl(int cmd, char *dev, VALUE vu
char *path;
int is_gid;
uid_t uid;
@ -14,7 +27,7 @@ $NetBSD: patch-ab,v 1.3 2006/01/25 15:48:50 joerg Exp $
int i, count, ret;
buff = 0;
@@ -187,12 +191,16 @@ rb_quotactl(int cmd, char *dev, VALUE vu
@@ -187,12 +197,16 @@ rb_quotactl(int cmd, char *dev, VALUE vu
static int
rb_quotactl(int cmd, char *dev, VALUE vuid, caddr_t addr)
{