Try to fix build.
* Merge checks in emacs20's patch-ab. Fix PR pkg/45669 like problem. * Now I have gotten temacs sagfault, maybe related to PR pkg/45716.
This commit is contained in:
parent
2d2c0d18a3
commit
98deb21e04
3 changed files with 37 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.46 2011/09/13 08:48:40 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.47 2011/12/19 21:36:07 ryoon Exp $
|
||||
|
||||
DISTNAME= mule-2.3
|
||||
PKGREVISION= 7
|
||||
|
@ -8,6 +8,7 @@ MASTER_SITES= ftp://ftp.m17n.org/pub/mule/
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.m17n.org/mule/
|
||||
COMMENT= Multilingual GNU editing macros (editor)
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2010/07/11 03:00:33 obache Exp $
|
||||
$NetBSD: distinfo,v 1.9 2011/12/19 21:36:07 ryoon Exp $
|
||||
|
||||
SHA1 (mule-2.3.tar.gz) = 52737767955caf2fde34b994f367a89c5d8a045f
|
||||
RMD160 (mule-2.3.tar.gz) = 52b93e746a7a796549a44104ab1898954df044bf
|
||||
|
@ -6,7 +6,7 @@ Size (mule-2.3.tar.gz) = 10240256 bytes
|
|||
SHA1 (patch-aa) = 927ec514204ef97101fb3f4ab77eec1c71af23f1
|
||||
SHA1 (patch-ab) = ffb7afcac57932cfe477b87daa5579b54aea3672
|
||||
SHA1 (patch-ac) = 170fa4f6c17c805dd32a90e8bfb3e38c48a9fc20
|
||||
SHA1 (patch-ad) = 668aea174d80616ce1fd93d9dd4134d5027d9df8
|
||||
SHA1 (patch-ad) = 70f4a983aab2bd7c6255a448992ac717f5e962ac
|
||||
SHA1 (patch-ae) = 1f020aaeb75cd7dd2b827ab34382e472add09719
|
||||
SHA1 (patch-af) = 2672b9c724cfed135218a76e857fd26ebe3676ac
|
||||
SHA1 (patch-ag) = 590fe919b44722f7ba1e390cf7fecbc20eeeba06
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: patch-ad,v 1.4 2006/01/04 20:35:08 joerg Exp $
|
||||
$NetBSD: patch-ad,v 1.5 2011/12/19 21:36:07 ryoon Exp $
|
||||
|
||||
* "Should be one line" test is for gcc 4.5's cpp from emacs20's patch-ab.
|
||||
|
||||
--- configure.orig 1995-06-05 01:11:38.000000000 +0000
|
||||
+++ configure
|
||||
|
@ -25,3 +27,33 @@ $NetBSD: patch-ad,v 1.4 2006/01/04 20:35:08 joerg Exp $
|
|||
*-nextstep* ) opsys=mach2 ;;
|
||||
## Otherwise, we'll fall through to the generic opsys code at the bottom.
|
||||
esac
|
||||
@@ -1384,10 +1387,13 @@ if test -z "$CPP"; then
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
Syntax Error
|
||||
+Should \\
|
||||
+be one line.
|
||||
EOF
|
||||
# Some shells (Coherent) do redirections in the wrong order, so need
|
||||
# the parens.
|
||||
-ac_err=`eval "($ac_cpp conftest.${ac_ext} >/dev/null) 2>&1"`
|
||||
+ac_err=`eval "($ac_cpp conftest.${ac_ext} > conftest2.out) 2>&1 ; \
|
||||
+grep -L \"Should *be one line\" conftest2.out"`
|
||||
if test -z "$ac_err"; then
|
||||
:
|
||||
else
|
||||
@@ -1397,10 +1403,13 @@ else
|
||||
#include "confdefs.h"
|
||||
#include <stdio.h>
|
||||
Syntax Error
|
||||
+Should \\
|
||||
+be one line.
|
||||
EOF
|
||||
# Some shells (Coherent) do redirections in the wrong order, so need
|
||||
# the parens.
|
||||
-ac_err=`eval "($ac_cpp conftest.${ac_ext} >/dev/null) 2>&1"`
|
||||
+ac_err=`eval "($ac_cpp conftest.${ac_ext} >/dev/null) 2>&1 ; \
|
||||
+grep -L \"Should *be one line\" conftest2.out"`
|
||||
if test -z "$ac_err"; then
|
||||
:
|
||||
else
|
||||
|
|
Loading…
Reference in a new issue