Revert previous and make perl an option instead, since it actually links
to the perl interpreter; and if the option isn't selected, disable perl explicitly to avoid accidentally finding a builtin version.
This commit is contained in:
parent
72ba6661a2
commit
997172acdc
4 changed files with 43 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.39 2015/11/07 21:18:23 dholland Exp $
|
||||
# $NetBSD: Makefile,v 1.40 2015/11/07 21:36:57 dholland Exp $
|
||||
#
|
||||
|
||||
DISTNAME= epic4-2.10.2
|
||||
|
@ -17,7 +17,6 @@ EXTRACT_SUFX= .tar.bz2
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.epicsol.org/
|
||||
COMMENT= The (E)nhanced (P)rogrammable (I)RC-II (C)lient
|
||||
USE_TOOLS+= perl
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
|
@ -25,6 +24,8 @@ INSTALL_MAKE_FLAGS+= IP=${DESTDIR}
|
|||
|
||||
CFLAGS.OSF1+= -D_SOCKADDR_LEN
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.13 2015/11/03 01:20:18 agc Exp $
|
||||
$NetBSD: distinfo,v 1.14 2015/11/07 21:36:57 dholland Exp $
|
||||
|
||||
SHA1 (epic4-2.10.2.tar.bz2) = 5b6538d9c1465bc861295f54fe375f326921dcb7
|
||||
RMD160 (epic4-2.10.2.tar.bz2) = 38af0d56fdb315c4ce47bf531a4e00d79f13eb5f
|
||||
SHA512 (epic4-2.10.2.tar.bz2) = 648bcdca52d376705d4459853a316e1027e7c9c00cb0a8b56ad45c13e4019fb790bd10c6686103064994133ddc26f280925b24cdc4932bd986b127b7033a558c
|
||||
Size (epic4-2.10.2.tar.bz2) = 633946 bytes
|
||||
SHA1 (patch-configure) = d75eba5b1e6c223f8f166f3e9dedc7f2925b6393
|
||||
SHA1 (patch-source_Makefile.in) = ea4b6520c228b22b43dc391725f3a0d616aeb729
|
||||
|
|
15
chat/epic4/options.mk
Normal file
15
chat/epic4/options.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: options.mk,v 1.1 2015/11/07 21:36:57 dholland Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.epic4
|
||||
PKG_SUPPORTED_OPTIONS+= perl
|
||||
PKG_SUGGESTED_OPTIONS=
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mperl)
|
||||
USE_TOOLS+= perl:run
|
||||
CONFIGURE_ARGS+= --with-perl
|
||||
.include "../../lang/perl5/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-perl
|
||||
.endif
|
23
chat/epic4/patches/patch-configure
Normal file
23
chat/epic4/patches/patch-configure
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-configure,v 1.1 2015/11/07 21:36:57 dholland Exp $
|
||||
|
||||
- Disable part of the perl probe so pkgsrc perl works.
|
||||
|
||||
--- configure~ 2008-03-20 04:20:49.000000000 +0000
|
||||
+++ configure
|
||||
@@ -5051,11 +5051,11 @@ fi
|
||||
|
||||
test "xno" != "x$withval" && for base in $withval /usr/local /usr /
|
||||
do
|
||||
- FOUND=
|
||||
- for ext in so a dll ; do
|
||||
- test -r $base/lib/libperl.$ext && FOUND=1
|
||||
- test -r $base/libperl.$ext && FOUND=1
|
||||
- done
|
||||
+ FOUND=1
|
||||
+ #for ext in so a dll ; do
|
||||
+ # test -r $base/lib/libperl.$ext && FOUND=1
|
||||
+ # test -r $base/libperl.$ext && FOUND=1
|
||||
+ #done
|
||||
test -n "$FOUND" || continue
|
||||
echo "$ac_t""yes" 1>&6
|
||||
LIBS="$LIBS `perl -MExtUtils::Embed -e ldopts`"
|
Loading…
Reference in a new issue