binutils: update to 2.41.

This release contains numerous bug fixes, and also the
following new features:

  In the assembler:
    * Add support for Intel FRED instructions.
    * Add support for Intel LKGS instructions.
    * Add support for Intel AMX-COMPLEX instructions.
    * Add SME2 support to the AArch64 port.
    * A new .insn directive is recognized by x86 gas.
    * Add support for LoongArch LSX instructions.
    * Add support for LoongArch LASX instructions.
    * Add support for LoongArch LVZ instructions.
    * Add support for LoongArch LBT instructions.
    * Initial LoongArch support for linker relaxation has been added.
    * Deprecate the LoongArch register aliases $v0, $v1, $x, $fv0 and $fv1.

  In the linker:
    * The linker now accepts a command line option of --remap-inputs
      <PATTERN>=<FILE> to relace any input file that matches <PATTERN> with
      <FILE>.  In addition the option --remap-inputs-file=<FILE> can be used to
      specify a file containing any number of these remapping directives.

    * The linker command line option --print-map-locals can be used to include
      local symbols in a linker map.  (ELF targets only).

    * For most ELF based targets, if the --enable-linker-version option is used
      then the version of the linker will be inserted as a string into the .comment
      section.

    * The linker script syntax has a new command for output sections: ASCIZ "string"
      This will insert a zero-terminated string at the current location.

    * Add command-line option, -z nosectionheader, to omit ELF section
      header.

  In the other binary tools:
    * The MIPS port now supports the Sony Interactive Entertainment Allegrex
      processor, used with the PlayStation Portable, which implements the MIPS
      II ISA along with a single-precision FPU and a few implementation-specific
      integer instructions.

    * Objdump's --private option can now be used on PE format files to display the
      fields in the file header and section headers.

    * New versioned release of libsframe: libsframe.so.1.  This release introduces
      versioned symbols with version node name LIBSFRAME_1.0.  This release also
      updates the ABI in an incompatible way: this includes removal of
      sframe_get_funcdesc_with_addr API, change in the behavior of
      sframe_fre_get_ra_offset and sframe_fre_get_fp_offset APIs.

    * SFrame Version 2 is now the default (and only) format version supported by
      gas, ld, readelf and objdump.

    * Add command-line option, --strip-section-headers, to objcopy and strip to
      remove ELF section header from ELF file.

    * The RISC-V port now supports the following new standard extensions:
      - Zicond (conditional zero instructions)
      - Zfa (additional floating-point instructions)
      - Zvbb, Zvbc, Zvkg, Zvkned, Zvknh[ab], Zvksed, Zvksh, Zvkn, Zvknc, Zvkng,
        Zvks, Zvksc, Zvkg, Zvkt (vector crypto instructions)

    * The RISC-V port now supports the following vendor-defined extensions:
       - XVentanaCondOps

    * The LoongArch port now supports the following extensions:
      - LSX (Loongson SIMD eXtension; 128-bit vectors)
      - LASX (Loongson Advanced SIMD eXtension; 256-bit vectors)
      - LVZ (Loongson Virtualization extension)
      - LBT (Loongson Binary Translation extension)

    * The LoongArch disassembly output received the following tweaks:
      - Colored output is now supported.
      - Some pseudo-instructions are now shown in place of the canonical forms,
        where semantics are equivalent. A disassembler option '-M no-aliases' is
        added to disable the new behavior.
      - Signed immediates are no longer printed with their hex representation.
      - Unrecognized instruction words are now shown with '.word'.
This commit is contained in:
fcambus 2023-07-31 14:08:34 +00:00
parent 0ce6dfa4e4
commit 99a786e4e3
6 changed files with 25 additions and 23 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.111 2023/01/29 09:54:32 jperkin Exp $
# $NetBSD: Makefile,v 1.112 2023/07/31 14:08:34 fcambus Exp $
DISTNAME= binutils-2.40
DISTNAME= binutils-2.41
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU:=binutils/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.common,v 1.40 2023/01/14 20:11:04 fcambus Exp $
@comment $NetBSD: PLIST.common,v 1.41 2023/07/31 14:08:34 fcambus Exp $
${MACHINE_GNU_PLATFORM}/bin/ar
${PLIST.gas}${MACHINE_GNU_PLATFORM}/bin/as
${PLIST.gld}${MACHINE_GNU_PLATFORM}/bin/ld
@ -81,6 +81,7 @@ info/binutils.info
${PLIST.ctf}info/ctf-spec.info
${PLIST.gprof}info/gprof.info
${PLIST.gld}info/ld.info
info/ldint.info
info/sframe-spec.info
${PLIST.gld}lib/bfd-plugins/libdep.so
lib/libbfd.la
@ -165,6 +166,7 @@ ${PLIST.gas}share/locale/ja/LC_MESSAGES/gas.mo
${PLIST.gold}share/locale/ja/LC_MESSAGES/gold.mo
${PLIST.gprof}share/locale/ja/LC_MESSAGES/gprof.mo
${PLIST.gld}share/locale/ja/LC_MESSAGES/ld.mo
share/locale/ka/LC_MESSAGES/bfd.mo
${PLIST.gprof}share/locale/ka/LC_MESSAGES/gprof.mo
${PLIST.gprof}share/locale/ms/LC_MESSAGES/gprof.mo
${PLIST.gprof}share/locale/nl/LC_MESSAGES/gprof.mo

View file

@ -1,17 +1,17 @@
$NetBSD: distinfo,v 1.50 2023/01/14 20:11:04 fcambus Exp $
$NetBSD: distinfo,v 1.51 2023/07/31 14:08:34 fcambus Exp $
BLAKE2s (binutils-2.40.tar.bz2) = 84b64f0551b4246de84141814ce012ccbb121835e3b1235eff22bbf60300fd73
SHA512 (binutils-2.40.tar.bz2) = 30256362945184329c994730f60d8493292547e0e5de5f49d57490d8d9b1a0a18393bf7f70934ba5061ee2001ec4cbf5f206d310df9512a7fb3625a362e358f9
Size (binutils-2.40.tar.bz2) = 35227554 bytes
BLAKE2s (binutils-2.41.tar.bz2) = bd20a803c6f86632b62e27fce2cb07eb0ee4aa06fb374d80c8ba235568466dd2
SHA512 (binutils-2.41.tar.bz2) = 8c4303145262e84598d828e1a6465ddbf5a8ff757efe3fd981948854f32b311afe5b154be3966e50d85cf5d25217564c1f519d197165aac8e82efcadc9e1e47c
Size (binutils-2.41.tar.bz2) = 37132937 bytes
SHA1 (patch-bfd_cache.c) = e2d96bad350552eacdffa83532f9dc9e15ee9be9
SHA1 (patch-gold_Makefile.in) = e01d973f9625a1653851f796c123efec37102fbd
SHA1 (patch-gold_options.h) = 03816bbf157d781820d96a4d3af0885dc2bbbaa9
SHA1 (patch-gold_system.h) = 9b4130b5315763daa66e0a91a8be6d1df0d10344
SHA1 (patch-gold_testsuite_Makefile.in) = 24ede750675829281436d728d77073638f58d6b9
SHA1 (patch-include_safe-ctype.h) = 66e636f8200ff5e9b4bfa0a5aee13cd072a23887
SHA1 (patch-ld_Makefile.am) = 61d8fdf1b0d29e596f0ab8a3b6723bf26ecf889c
SHA1 (patch-ld_Makefile.in) = a4c66da20b782b91ca477de7d209bb7c42a88ef3
SHA1 (patch-ld_configure.tgt) = 74896a720bddefd459aa5835df04804547cf6c99
SHA1 (patch-ld_Makefile.am) = 884eb668545d3229809b7fc51cc05b51d799b51a
SHA1 (patch-ld_Makefile.in) = 7a6a9fb3aed47ddaec0f36c8cec4e0bd6b926027
SHA1 (patch-ld_configure.tgt) = 4e277c9aa53926059d3227c7e85b3eb3ac60f29d
SHA1 (patch-ld_emulparams_aarch64nbsd.sh) = 6489e5996eefdb8ba66c73d7425443109d47e6a9
SHA1 (patch-ld_emulparams_aarch64nbsdb.sh) = 9980f3ca8cb7cac1b56c71c482b691fa2f7659a1
SHA1 (patch-ld_emulparams_armelf__nbsd__eabi.sh) = 464b0957f95a1a8ba6a92ee0091b929d9c980470

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ld_Makefile.am,v 1.5 2023/01/14 20:11:04 fcambus Exp $
$NetBSD: patch-ld_Makefile.am,v 1.6 2023/07/31 14:08:34 fcambus Exp $
NetBSD/aarch64 support patches for ld from src.
--- ld/Makefile.am.orig 2023-01-14 00:00:00.000000000 +0000
--- ld/Makefile.am.orig 2023-07-02 23:00:00.000000000 +0000
+++ ld/Makefile.am
@@ -173,6 +173,8 @@ ALL_EMULATION_SOURCES = \
earmelf_linux_fdpiceabi.c \
@ -28,6 +28,6 @@ NetBSD/aarch64 support patches for ld from src.
eaarch64linuxb.c \
+ eaarch64nbsd.c \
+ eaarch64nbsdb.c \
eaarch64nto.c \
eaarch64pe.c \
eelf32_x86_64.c \
eelf32b4300.c \
earm64pe.c \

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ld_Makefile.in,v 1.5 2023/01/14 20:11:04 fcambus Exp $
$NetBSD: patch-ld_Makefile.in,v 1.6 2023/07/31 14:08:34 fcambus Exp $
NetBSD/aarch64 support patches for ld from src.
--- ld/Makefile.in.orig 2023-01-14 00:00:00.000000000 +0000
--- ld/Makefile.in.orig 2023-07-02 23:00:00.000000000 +0000
+++ ld/Makefile.in
@@ -674,6 +674,8 @@ ALL_EMULATION_SOURCES = \
earmelf_linux_fdpiceabi.c \
@ -28,6 +28,6 @@ NetBSD/aarch64 support patches for ld from src.
eaarch64linuxb.c \
+ eaarch64nbsd.c \
+ eaarch64nbsdb.c \
eaarch64nto.c \
eaarch64pe.c \
eelf32_x86_64.c \
eelf32b4300.c \
earm64pe.c \

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ld_configure.tgt,v 1.9 2023/01/14 20:11:04 fcambus Exp $
$NetBSD: patch-ld_configure.tgt,v 1.10 2023/07/31 14:08:34 fcambus Exp $
NetBSD/aarch64 support patches for ld from src.
--- ld/configure.tgt.orig 2023-01-14 00:00:00.000000000 +0000
--- ld/configure.tgt.orig 2023-07-02 23:00:00.000000000 +0000
+++ ld/configure.tgt
@@ -118,6 +118,12 @@ aarch64-*-linux*) targ_emul=aarch64linux
aarch64-*-haiku*) targ_emul=aarch64haiku
@ -14,6 +14,6 @@ NetBSD/aarch64 support patches for ld from src.
+aarch64-*-netbsd*) targ_emul=aarch64nbsd
+ targ_extra_emuls="aarch64nbsdb aarch64elf aarch64elfb armelf_nbsd_eabihf armelfb_nbsd_eabihf armelf_nbsd_eabi armelfb_nbsd_eabi armelf_nbsd armelfb_nbsd armelf armelfb"
+ ;;
aarch64-*-pe*)
targ_emul=aarch64pe
targ_extra_ofiles="deffilep.o pep-dll-aarch64.o"
aarch64-*-nto*) targ_emul=aarch64nto
targ_extra_emuls="aarch64elf aarch64elf32 aarch64elf32b aarch64elfb armelf armelfb"
;;