On 21.4, line-move only takes one argument.
Patch lisp/xemacs-base/simple-more.el to accomodate.
This commit is contained in:
parent
cbd607c017
commit
99b72c8f64
3 changed files with 36 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.78 2021/07/21 16:22:50 hauke Exp $
|
||||
# $NetBSD: Makefile,v 1.79 2021/09/15 21:06:42 hauke Exp $
|
||||
|
||||
DISTNAME= xemacs-packages
|
||||
PKGNAME= xemacs-packages-1.18
|
||||
PKGREVISION= 7
|
||||
PKGREVISION= 8
|
||||
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_XEMACS:=${XEMACSPKG_PATH}/}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.26 2019/07/31 14:04:40 hauke Exp $
|
||||
$NetBSD: distinfo,v 1.27 2021/09/15 21:06:42 hauke Exp $
|
||||
|
||||
SHA1 (xemacs-packages/Sun-1.19-pkg.tar.gz) = de24d0bf78e753e733138c6a2bec0ecf414511e0
|
||||
RMD160 (xemacs-packages/Sun-1.19-pkg.tar.gz) = 5f6bec6276f8b5a59ea6532f12c06a474571a274
|
||||
|
@ -520,3 +520,4 @@ SHA1 (patch-lisp_guided-tour_guided-tour.el) = 28556cc7fbb9a18ba88d6e2cf23f3b517
|
|||
SHA1 (patch-lisp_vc_vc-git.el) = 8b5aa902cc56a256c9c2210b49437bf7929f6e30
|
||||
SHA1 (patch-lisp_vc_vc.el) = ec13ecf02b41dca5bb80afc63ee4fb9f0b283a45
|
||||
SHA1 (patch-lisp_w3_url.el) = 551e11abffe6df7693003ca2aad5238fbd6c0116
|
||||
SHA1 (patch-lisp_xemacs-base_simple-more.el) = 20ccf1afff6b69f33209f179e96822cce8f25a26
|
||||
|
|
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-lisp_xemacs-base_simple-more.el,v 1.1 2021/09/15 21:06:42 hauke Exp $
|
||||
|
||||
On 21.4, line-move only takes one argument.
|
||||
|
||||
--- lisp/xemacs-base/simple-more.el.orig 2015-12-14 21:30:40.000000000 +0000
|
||||
+++ lisp/xemacs-base/simple-more.el
|
||||
@@ -40,7 +40,11 @@ To ignore intangibility, bind `inhibit-p
|
||||
|
||||
;; Move by lines, if ARG is not 1 (the default).
|
||||
(if (/= arg 1)
|
||||
- (line-move (1- arg) 'noerror))
|
||||
+ (if (and (featurep 'xemacs)
|
||||
+ (<= emacs-major-version 21)
|
||||
+ (< emacs-minor-version 5)))
|
||||
+ (line-move (1- arg))
|
||||
+ (line-move (1- arg) 'noerror))
|
||||
|
||||
;; Move to beginning-of-line, ignoring fields and invisible text.
|
||||
(skip-chars-backward "^\n")
|
||||
@@ -78,7 +82,11 @@ If point reaches the beginning or end of
|
||||
(let ((newpos
|
||||
(save-excursion
|
||||
(let ((goal-column 0))
|
||||
- (line-move arg 'noerror)
|
||||
+ (if (and (featurep 'xemacs)
|
||||
+ (<= emacs-major-version 21)
|
||||
+ (< emacs-minor-version 5))
|
||||
+ (line-move arg)
|
||||
+ (line-move arg 'noerror))
|
||||
(and
|
||||
;; With bidi reordering, we may not be at bol,
|
||||
;; so make sure we are.
|
Loading…
Reference in a new issue