fix build with gnutls-3

This commit is contained in:
drochner 2012-07-06 15:37:23 +00:00
parent 90b7951e2b
commit 99eb9af2e0
3 changed files with 17 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.30 2012/07/02 19:23:29 drochner Exp $
# $NetBSD: Makefile,v 1.31 2012/07/06 15:37:23 drochner Exp $
#
VERSION= 3.5.0
@ -14,7 +14,6 @@ HOMEPAGE= http://filezilla-project.org/
COMMENT= FTP, FTPS and SFTP client with intuitive GUI
LICENSE= gnu-gpl-v2
DEPENDS+= gnutls>=2.8.3:../../security/gnutls
DEPENDS+= xdg-utils-[0-9]*:../../misc/xdg-utils
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.15 2011/06/03 00:22:19 wiz Exp $
$NetBSD: distinfo,v 1.16 2012/07/06 15:37:23 drochner Exp $
SHA1 (FileZilla_3.5.0_src.tar.bz2) = 0d351b74bbe70cbfea1d315fd07193089e6e1c9d
RMD160 (FileZilla_3.5.0_src.tar.bz2) = c3ffc60ced15b7055c34d6ef07c97f516e6f276d
Size (FileZilla_3.5.0_src.tar.bz2) = 3348649 bytes
SHA1 (patch-aa) = 78237ce599dafa640b1488f188376ecc835dfe45
SHA1 (patch-data_makezip.sh.in) = 80acc96fce08e2e0831a4da0613f7b2eaebad465

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1 2012/07/06 15:37:23 drochner Exp $
fix build with gnutls-3
--- src/engine/tlssocket.cpp.orig 2011-05-02 03:30:19.000000000 +0000
+++ src/engine/tlssocket.cpp
@@ -113,7 +113,6 @@ bool CTlsSocket::Init()
gnutls_transport_set_push_function(m_session, PushFunction);
gnutls_transport_set_pull_function(m_session, PullFunction);
gnutls_transport_set_ptr(m_session, (gnutls_transport_ptr_t)this);
- gnutls_transport_set_lowat(m_session, 0);
m_shutdown_requested = false;