Always return a value in non-void functions.

This commit is contained in:
joerg 2012-11-19 23:15:52 +00:00
parent 3608efed24
commit 99f1e3e867
2 changed files with 27 additions and 3 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2012/04/22 14:09:09 obache Exp $
$NetBSD: distinfo,v 1.3 2012/11/19 23:15:52 joerg Exp $
SHA1 (ibus-array-0.0.2.tar.gz) = 1b2c65b0a5d45f858014d892ec9036918ce85a54
RMD160 (ibus-array-0.0.2.tar.gz) = 40dbed9c00cc83855af05350da244f668fddb751
Size (ibus-array-0.0.2.tar.gz) = 2759103 bytes
SHA1 (patch-src_engine.c) = 35c7a1783dddeea99f40d319b6584b8b4f42c36e
SHA1 (patch-src_engine.c) = fcd75da6cb349a7dd2f2caa8dae4b9ebb23668c7

View file

@ -1,4 +1,4 @@
$NetBSD: patch-src_engine.c,v 1.1 2012/04/22 14:09:10 obache Exp $
$NetBSD: patch-src_engine.c,v 1.2 2012/11/19 23:15:53 joerg Exp $
* for ibus-1.4
@ -51,6 +51,30 @@ $NetBSD: patch-src_engine.c,v 1.1 2012/04/22 14:09:10 obache Exp $
}
}
@@ -349,7 +351,7 @@ ibus_array_engine_update_symbol_lookup_t
if (arrayeng->preedit->len == 0) {
ibus_engine_hide_lookup_table ((IBusEngine *) arrayeng);
- return;
+ return FALSE;
}
ibus_lookup_table_clear (arrayeng->table);
@@ -360,12 +362,12 @@ ibus_array_engine_update_symbol_lookup_t
if (candidates == NULL) {
ibus_engine_hide_lookup_table ((IBusEngine *) arrayeng);
- return;
+ return FALSE;
}
else if (candidates->len == 0) {
array_release_candidates(candidates);
ibus_engine_hide_lookup_table ((IBusEngine *) arrayeng);
- return;
+ return FALSE;
}
for (i = 0; i < candidates->len; i++) {
@@ -754,14 +756,14 @@ static void ibus_array_engine_property_a
static void ibus_config_value_changed (IBusConfig *config,
const gchar *section,