Undefine open in ndbm_wrap.c. This fixes a build problem on Solaris.

This commit is contained in:
gavan 2004-10-06 17:18:32 +00:00
parent 7d36e4d924
commit 9a103e8c28
2 changed files with 14 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.5 2004/09/14 14:41:34 jlam Exp $
$NetBSD: distinfo,v 1.6 2004/10/06 17:18:32 gavan Exp $
SHA1 (heimdal-0.6.3.tar.gz) = 91863a1bd9f8a55063a09c28a5f41985b7a31145
Size (heimdal-0.6.3.tar.gz) = 3333604 bytes
SHA1 (patch-ab) = 400a9ac3a76ac7e8b4dcc230e0bdf7fc5222fbb7
SHA1 (patch-ac) = 121961811f559822c6a4f3d7f7e4646b16908942
SHA1 (patch-ad) = e14359cb79eba9a3742f5cb7df4b85befc59db75
SHA1 (patch-ae) = 518eabed07d4fc69e86ace3f02d23ca3064d4bd1

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.3 2004/10/06 17:18:32 gavan Exp $
--- lib/roken/ndbm_wrap.c.orig 2003-08-29 18:00:34.000000000 +0100
+++ lib/roken/ndbm_wrap.c
@@ -50,6 +50,7 @@ RCSID("$Id: ndbm_wrap.c,v 1.1.8.1 2003/0
#include <string.h>
#include <fcntl.h>
+#undef open
#define DBT2DATUM(DBT, DATUM) do { (DATUM)->dptr = (DBT)->data; (DATUM)->dsize = (DBT)->size; } while(0)
#define DATUM2DBT(DATUM, DBT) do { (DBT)->data = (DATUM)->dptr; (DBT)->size = (DATUM)->dsize; } while(0)