Add option for toolbar mode.
Thomas E. Dickey says it has hard-to-fix layout issues and slows the startup, so turn the option default off. Bump PKGREVISION for the default change from on to off.
This commit is contained in:
parent
e284e5fac0
commit
9a46f7bf53
4 changed files with 18 additions and 31 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.81 2013/07/11 09:37:01 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.82 2013/07/11 11:44:07 wiz Exp $
|
||||
|
||||
DISTNAME= xterm-296
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://invisible-island.net/xterm/ \
|
||||
http://www.sfr-fresh.com/unix/misc/
|
||||
|
@ -19,7 +20,6 @@ CONFIGURE_ARGS+= --enable-88-color
|
|||
CONFIGURE_ARGS+= --enable-256-color
|
||||
CONFIGURE_ARGS+= --enable-paste64
|
||||
CONFIGURE_ARGS+= --enable-readline-mouse
|
||||
CONFIGURE_ARGS+= --enable-toolbar # Resource disabled by default
|
||||
|
||||
CONFIGURE_ARGS.standard=# empty
|
||||
CONFIGURE_ARGS.3d= --with-Xaw3d
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.52 2013/07/11 09:37:01 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.53 2013/07/11 11:44:07 wiz Exp $
|
||||
|
||||
SHA1 (xterm-296.tgz) = 50d9aa65ef878b026519d82f2ec843b33d932463
|
||||
RMD160 (xterm-296.tgz) = a7cf53fe301b469a562b89505a6873b63702dc34
|
||||
Size (xterm-296.tgz) = 1112847 bytes
|
||||
SHA1 (patch-aa) = 46076243c1b53d481b4cafe3d3f6f1f35291a153
|
||||
|
|
|
@ -1,20 +1,20 @@
|
|||
# $NetBSD: options.mk,v 1.13 2012/10/10 16:29:35 wiz Exp $
|
||||
# $NetBSD: options.mk,v 1.14 2013/07/11 11:44:07 wiz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.xterm
|
||||
PKG_SUPPORTED_OPTIONS= debug pcre freetype luit xpm
|
||||
PKG_SUPPORTED_OPTIONS= debug pcre freetype luit xpm xterm-toolbar
|
||||
PKG_SUGGESTED_OPTIONS= freetype luit xpm
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdebug)
|
||||
CONFIGURE_ARGS+= --enable-trace
|
||||
CONFIGURE_ARGS+= --enable-warnings
|
||||
CONFIGURE_ARGS+= --enable-trace
|
||||
CONFIGURE_ARGS+= --enable-warnings
|
||||
.elif defined(PKG_DEVELOPER) && !empty(PKG_DEVELOPER:M[Yy][Ee][Ss])
|
||||
CONFIGURE_ARGS+= --enable-warnings
|
||||
CONFIGURE_ARGS+= --enable-warnings
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mfreetype)
|
||||
CONFIGURE_ARGS+= --enable-freetype
|
||||
CONFIGURE_ARGS+= --enable-freetype
|
||||
. include "../../x11/libXft/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-freetype
|
||||
|
@ -33,13 +33,19 @@ CONFIGURE_ENV+= ac_cv_lib_pcreposix_pcreposix_regcomp=yes
|
|||
|
||||
.if !empty(PKG_OPTIONS:Mluit)
|
||||
DEPENDS+= luit-[0-9]*:../../x11/luit
|
||||
CONFIGURE_ARGS+= --enable-luit --enable-mini-luit
|
||||
CONFIGURE_ARGS+= --enable-luit --enable-mini-luit
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-luit --disable-mini-luit
|
||||
CONFIGURE_ARGS+= --disable-luit --disable-mini-luit
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mxpm)
|
||||
### nothing
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-xpm
|
||||
CONFIGURE_ARGS+= --without-xpm
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mxterm-toolbar)
|
||||
CONFIGURE_ARGS+= --enable-toolbar
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-toolbar
|
||||
.endif
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.10 2009/05/22 19:52:02 tnn Exp $
|
||||
|
||||
One needs to explicitly enable building in the toolbar code, yet
|
||||
this turns it on by default, which not everyone wants.
|
||||
|
||||
Let's attempt to convince xterm of this here.
|
||||
|
||||
--- main.c.orig 2009-01-24 17:08:01.000000000 +0100
|
||||
+++ main.c
|
||||
@@ -881,7 +881,7 @@ static XtResource application_resources[
|
||||
Bres("sessionMgt", "SessionMgt", sessionMgt, True),
|
||||
#endif
|
||||
#if OPT_TOOLBAR
|
||||
- Bres(XtNtoolBar, XtCToolBar, toolBar, True),
|
||||
+ Bres(XtNtoolBar, XtCToolBar, toolBar, False),
|
||||
#endif
|
||||
#if OPT_MAXIMIZE
|
||||
Bres(XtNmaximized, XtCMaximized, maximized, False),
|
Loading…
Reference in a new issue