gstreamer1: Build fixes for Solarish

PR pkg/56509 from Claes Nästén
This commit is contained in:
nia 2021-11-18 20:25:45 +00:00
parent 19ff6c8b72
commit 9a64180729
4 changed files with 26 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.27 2021/11/15 22:01:18 wiz Exp $
# $NetBSD: Makefile,v 1.28 2021/11/18 20:25:45 nia Exp $
PKGNAME= ${DISTNAME:S/plugins/plugins1/}
CATEGORIES= multimedia gnome
@ -35,6 +35,8 @@ GST_PLUGINS+= introspection
GST_PLUGINS+= tools
GST_PLUGINS+= nls
LDFLAGS.SunOS+= -lsocket -lnsl
# for tests
# generate with:
# find work/gst-*/ -name *.so | sed -e "s,/[^/]*$,:," -e 's,work/[^/]*/,${WRKSRC}/,' | tr -d \\n

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.42 2021/11/15 22:01:18 wiz Exp $
$NetBSD: distinfo,v 1.43 2021/11/18 20:25:45 nia Exp $
BLAKE2s (gst-plugins-base-1.18.5.tar.xz) = a0a795afe1a0cd2d7edce7b18c9d6051ec6f95719d5bbedd4e2e5b2b3c0a3c66
SHA512 (gst-plugins-base-1.18.5.tar.xz) = b336cf3a3a5357429f3ae2bcfa9e4c367646360a1d7a74f8f2458703d232b5a5f6dcf865ba27a15c7e8e1e1cbde08b8c345104f792d16232f5833f52767a08b4
Size (gst-plugins-base-1.18.5.tar.xz) = 3176212 bytes
SHA1 (patch-ext_cdparanoia_gstcdparanoiasrc.h) = 5325f27c81cd9dc2f998bcb7733ef6b0c9a902e8
SHA1 (patch-gst_tcp_gstmultifdsink.c) = 43715806cc0801388550126a1f7a0b301b895620

View file

@ -0,0 +1,18 @@
$NetBSD: patch-gst_tcp_gstmultifdsink.c,v 1.1 2021/11/18 20:25:45 nia Exp $
PR pkg/56509 gstreamer1 build issues on Solaris (and SmartOS) after
upgrade to 1.18.5
--- gst/tcp/gstmultifdsink.c.orig 2021-09-08 19:02:22.195757900 +0000
+++ gst/tcp/gstmultifdsink.c
@@ -121,6 +121,10 @@
#include "gstmultifdsink.h"
+#if !defined(FIONREAD) && defined(__sun)
+#include <sys/filio.h>
+#endif
+
#define NOT_IMPLEMENTED 0
GST_DEBUG_CATEGORY_STATIC (multifdsink_debug);

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.51 2021/11/15 22:01:21 wiz Exp $
# $NetBSD: Makefile,v 1.52 2021/11/18 20:25:45 nia Exp $
DISTNAME= gstreamer-1.18.5
PKGNAME= ${DISTNAME:S/gstreamer/gstreamer1/}
@ -15,6 +15,8 @@ USE_TOOLS+= bison flex perl pkg-config xgettext
TEST_TARGET= check
FLEX_REQD= 2.5.31
LDFLAGS.SunOS+= -lsocket -lnsl -lrt
.include "options.mk"
PKGCONFIG_OVERRIDE+= pkgconfig/gstreamer-controller.pc.in