Update to 2.2.3. Changes are:
Qt 2.2.3 is a bugfix release. It keeps both forward and backward compatibility (source and binary) with Qt 2.2.2 **************************************************************************** * General * **************************************************************************** - Platform fixes for Red Hat 7.0, Unixware 7, SCO OpenServer 5.0.5, LinuxPPC, True64. - Basic multihead support for MS-Windows 98/2000: Popup windows, tooltips and What's This? help texts now appear on the correct screen, QApplication::desktop() is now as big as the virtual screen. - Documented previously internal QEmbed utility. The tool converts arbitrary files into C++ code. This is useful for including image files and other resources directly into your application rather than loading the data from external files. You find it in qt/tools/qembed. - X11 only: Fixed font sizes on higher resolution displays. When asking for a specific point size, you should always receive a font with an adequate pixel size depending on the dpi value of the display. This was supposed to work before, but broke for certain cases on XFree 4.x. - Many minor bugfixes and small improvements, see detailed lists below. **************************************************************************** * Designer * **************************************************************************** - Minor fixes for custom widget handling - Minor user interfaces fixes - Fixed uic-generated code for dialogs that are not completely layouted - Improved code generation for non-ascii and non-latin1 text **************************************************************************** * Library * **************************************************************************** QAction: Deletes generated widgets on the action's destruction time QApplication: Cleans thread-pipe on destruction time Fixed crash when passing 0/0 as argc/argv QClipboard: MS-Windows only: Try harder to get the unicode contents from the system clipboard QComboBox: Fixes for NoInsertion policy QDir: Gives ';' higher priority than ' ' as a filter separator QDom: Support for NOTATION and ENTITY declarations was missing. QFileDialog: MS-Windows only: safer handling of non-existing directories QFont: X11 only: Fixed font sizes on higher resolution displays. When asking for a specific point size, you should always receive a font with an adequate pixel size depending on the dpi value of the display. This was supposed to work before, but broke for certain cases on XFree 4.x. QGl: MS-Windows only: added some missing Q_EXPORTS for using the OpenGL module in a DLL QIconView: Fixed icon selection in case icons overlap Fixed crash when trying to drag items in NoSelection mode QImage: MS-Windows only: Fixed problems with reading 15/16/32 bits-per-pixel Windows DIBs QListView: currentChanged() signal in takeItem() is now safe to use QMainWindow: Small layout fix QMetaObject: Fixed numClassInfo() QMotifPlusStyle: Added support for Tristate checkboxes QPointArray: Avoid overflow if the array gets too big QPopupMenu: Improved auto-placement QPrinter: Saves last printer dialog configuration by default Unix only: a memory leak fixed QPushButton: Improved popup menu placement QString: Fixed toDouble() for strings containing non latin1 characters QTabBar: Optimizations QTable: Several minor bugfixes including a possible crash fix QTextCodec: Support for the changed posix charmap tables on Red Hat 7.0 QToolButton: Improved popup menu placement QThread: MS-Windows only: minor bugs and race conditions fixed QUrl: Fixed parser, path can start with a digit QWidget: Revised lastWindowClosed() signal, it was ocassionally emitted too often QWindowsMime: MS-Windows only: Try harder to get unicode contents QWindowsStyle: Draws disabled radio buttons grayed out QXml: Fix missing distinction between external parsed and external unparsed entities. The reporting of some processing instructions were missing. **************************************************************************** * Extensions * **************************************************************************** Xt Extension: Prioritize timers over posted events. This is necessary to ensure that paintEvents are processed in a timely manner after QWidget::update is called from a slot that is connected to a QTimer signal NS Plugin: Bugfixes and maintainance **************************************************************************** * Other * **************************************************************************** - Meta Object Compiler (moc): Improved namespace support with MSVC. **************************************************************************** * Third party * **************************************************************************** None **************************************************************************** * Changes that might affect runtime behavior * **************************************************************************** None **************************************************************************** * Qt/Embedded-specific changes * **************************************************************************** - The libqt.* library file is now called libqte.* on Qt/Embedded so you can easily have both Qt/X11 and Qt/Embedded installed on the same system. - 4bpp grayscale and 24bpp color is supported. - Some additional Window Manager styles are provided. - Setable "desktop" color/image. - Performance improvements.
This commit is contained in:
parent
3ba45c5f9b
commit
9a80789547
9 changed files with 19 additions and 22 deletions
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 2000/12/05 18:32:04 drochner Exp $
|
||||
$NetBSD: md5,v 1.3 2000/12/26 13:00:14 skrll Exp $
|
||||
|
||||
MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
|
||||
MD5 (qt-x11-2.2.3.tar.gz) = 964ca0e7e641271a2f5706a0e4383fcf
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/10/19 07:45:12 skrll Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2000/12/26 13:00:14 skrll Exp $
|
||||
|
||||
qt2/bin/uic
|
||||
qt2/bin/designer
|
||||
qt2/bin/uic
|
||||
qt2/lib/libqutil.a
|
||||
qt2/lib/libqutil.la
|
||||
qt2/lib/libqutil.so.1.0
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 2000/12/05 18:32:04 drochner Exp $
|
||||
$NetBSD: md5,v 1.3 2000/12/26 13:00:14 skrll Exp $
|
||||
|
||||
MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
|
||||
MD5 (qt-x11-2.2.3.tar.gz) = 964ca0e7e641271a2f5706a0e4383fcf
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/12/05 18:32:04 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/12/26 13:00:14 skrll Exp $
|
||||
|
||||
qt2/doc/README
|
||||
qt2/doc/README.QT
|
||||
|
@ -305,7 +305,6 @@ qt2/doc/man/man3/QValueStack.3
|
|||
qt2/doc/man/man3/QVariant.3
|
||||
qt2/doc/man/man3/QVector.3
|
||||
qt2/doc/man/man3/QWMatrix.3
|
||||
qt2/doc/man/man3/QWSDecoration.3
|
||||
qt2/doc/man/man3/QWaitCondition.3
|
||||
qt2/doc/man/man3/QWhatsThis.3
|
||||
qt2/doc/man/man3/QWheelEvent.3
|
||||
|
@ -645,7 +644,6 @@ qt2/doc/man/man3/qwindowsstyle.3
|
|||
qt2/doc/man/man3/qwizard.3
|
||||
qt2/doc/man/man3/qwmatrix.3
|
||||
qt2/doc/man/man3/qworkspace.3
|
||||
qt2/doc/man/man3/qwsdecoration.3
|
||||
qt2/doc/man/man3/qxmlattributes.3
|
||||
qt2/doc/man/man3/qxmlcontenthandler.3
|
||||
qt2/doc/man/man3/qxmldeclhandler.3
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 2000/12/05 18:32:04 drochner Exp $
|
||||
$NetBSD: md5,v 1.3 2000/12/26 13:00:15 skrll Exp $
|
||||
|
||||
MD5 (qt-x11-2.2.2.tar.gz) = 682e8f62af48770aea52036eb6329792
|
||||
MD5 (qt-x11-2.2.3.tar.gz) = 964ca0e7e641271a2f5706a0e4383fcf
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-sum,v 1.6 2000/12/12 06:30:26 jlam Exp $
|
||||
$NetBSD: patch-sum,v 1.7 2000/12/26 13:00:15 skrll Exp $
|
||||
|
||||
MD5 (patch-aa) = 58526c496bb5ff5ada2279c6c1b67bf0
|
||||
MD5 (patch-ab) = aa1df5b080b35d1d26f89ea8d593b571
|
||||
MD5 (patch-ac) = 04de629d6d27a0030c190b175940d9ef
|
||||
MD5 (patch-ad) = 6bb4068dfa73008cefd6a860391caaf9
|
||||
MD5 (patch-ae) = c6dec6d76eb38b86169453677e1f0abe
|
||||
MD5 (patch-ae) = be8dc17040a8c0acb8d8fb793cf2513d
|
||||
MD5 (patch-af) = eabc3b9b2a37d3b278ef9781305d4c93
|
||||
MD5 (patch-ag) = e37a1c2177d634a10cd13e3831317be6
|
||||
MD5 (patch-ah) = 17097e2d1020179a52b1df16bf69fdd1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ae,v 1.4 2000/12/11 23:02:37 skrll Exp $
|
||||
$NetBSD: patch-ae,v 1.5 2000/12/26 13:00:15 skrll Exp $
|
||||
|
||||
--- src/Makefile.in.orig Wed Nov 8 17:06:56 2000
|
||||
--- src/Makefile.in.orig Tue Dec 12 11:16:33 2000
|
||||
+++ src/Makefile.in
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
|
@ -19,8 +19,8 @@ $NetBSD: patch-ae,v 1.4 2000/12/11 23:02:37 skrll Exp $
|
|||
+DESTDIR =
|
||||
VER_MAJ = 2
|
||||
VER_MIN = 2
|
||||
VER_PATCH = 2
|
||||
@@ -370,19 +370,7 @@
|
||||
VER_PATCH = 3
|
||||
@@ -369,19 +369,7 @@
|
||||
.SUFFIXES: .cpp .cxx .cc .C .c
|
||||
|
||||
.cpp.o:
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/12/05 18:32:05 drochner Exp $
|
||||
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/12/26 13:00:15 skrll Exp $
|
||||
qt2/bin/moc
|
||||
qt2/include/jri.h
|
||||
qt2/include/jritypes.h
|
||||
|
@ -43,7 +42,6 @@ qt2/include/qconfig-dist.h
|
|||
qt2/include/qconfig-large.h
|
||||
qt2/include/qconfig-medium.h
|
||||
qt2/include/qconfig-minimal.h
|
||||
qt2/include/qconfig-qpe.h
|
||||
qt2/include/qconfig-small.h
|
||||
qt2/include/qconfig.h
|
||||
qt2/include/qconnect.h
|
||||
|
@ -265,6 +263,7 @@ qt2/include/qvariant.h
|
|||
qt2/include/qvbox.h
|
||||
qt2/include/qvbuttongroup.h
|
||||
qt2/include/qvector.h
|
||||
qt2/include/qvfbhdr.h
|
||||
qt2/include/qvgroupbox.h
|
||||
qt2/include/qwhatsthis.h
|
||||
qt2/include/qwidcoll.h
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2000/12/09 17:21:49 skrll Exp $
|
||||
# $NetBSD: Makefile.common,v 1.2 2000/12/26 13:00:13 skrll Exp $
|
||||
#
|
||||
|
||||
QTVERSION= 2.2.2
|
||||
QTVERSION= 2.2.3
|
||||
|
||||
MAINTAINER= skrll@netbsd.org
|
||||
HOMEPAGE= http://www.trolltech.com/products/qt.html
|
||||
|
|
Loading…
Reference in a new issue