Re-import devel/g-wrap as g-wrap1 to make space for a guile-1.6 version

of g-wrap without breaking dependencies.
This commit is contained in:
wiz 2004-12-03 16:02:25 +00:00
parent ddc383b402
commit 9a9cad3178
8 changed files with 139 additions and 0 deletions

3
devel/g-wrap1/DESCR Normal file
View file

@ -0,0 +1,3 @@
G-Wrap is a tool for specifying types, functions, and constants to
import into a Scheme interpreter, and for generating code (in C) to
interface these to the Guile interpreter in particular.

30
devel/g-wrap1/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
DISTNAME= g-wrap-1.3.4
PKGREVISION= 5
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gnucash.org/pub/g-wrap/source/
MAINTAINER= rh@NetBSD.org
HOMEPAGE= http://www.gnucash.org/
COMMENT= Tool for importing types, functions, and constants into guile
DEPENDS+= guile-slib>=2.4.2:../../devel/guile-slib
USE_BUILDLINK3= YES
GNU_CONFIGURE= YES
USE_GNU_TOOLS+= make
USE_LIBTOOL= YES
MAKE_ENV+= GUILE14_SUBDIR=${GUILE14_SUBDIR:Q}
USE_MAKEINFO= YES
INFO_FILES= g-wrap.info
CONFIGURE_ARGS+= --with-modules-dir=${PREFIX}/${GUILE14_SUBDIR}/share/guile
CONFIGURE_ENV+= ac_cv_path_RSCHEME="nope"
.include "../../devel/glib/buildlink3.mk"
.include "../../lang/guile14/buildlink3.mk"
.include "../../devel/guile14-gtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

30
devel/g-wrap1/PLIST Normal file
View file

@ -0,0 +1,30 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
bin/g-wrap-config
guile/1.4/share/guile/g-wrap.scm
guile/1.4/share/guile/g-wrap/enumeration.scm
guile/1.4/share/guile/g-wrap/g-translate.scm
guile/1.4/share/guile/g-wrap/gtkobj.scm
guile/1.4/share/guile/g-wrap/gw-glib-spec.scm
guile/1.4/share/guile/g-wrap/gw-glib.scm
guile/1.4/share/guile/g-wrap/gw-gtk-spec.scm
guile/1.4/share/guile/g-wrap/gw-gtk.scm
guile/1.4/share/guile/g-wrap/gw-standard-spec.scm
guile/1.4/share/guile/g-wrap/gw-standard.scm
guile/1.4/share/guile/g-wrap/gw-wct-spec.scm
guile/1.4/share/guile/g-wrap/gw-wct.scm
guile/1.4/share/guile/g-wrap/output-file.scm
guile/1.4/share/guile/g-wrap/runtime.scm
guile/1.4/share/guile/g-wrap/simple-type.scm
guile/1.4/share/guile/g-wrap/sorting.scm
include/g-wrap/g-wrap-compatibility.h
include/g-wrap/g-wrap-glib.h
include/g-wrap/g-wrap-wct.h
lib/libgw-glib.la
lib/libgw-gtk.la
lib/libgw-standard.la
lib/libgw-wct.la
lib/libgwrap-glib.la
lib/libgwrap-wct.la
share/aclocal/g-wrap.m4
@dirrm include/g-wrap
@dirrm guile/1.4/share/guile/g-wrap

View file

@ -0,0 +1,24 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
G_WRAP_BUILDLINK3_MK:= ${G_WRAP_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= g-wrap
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ng-wrap}
BUILDLINK_PACKAGES+= g-wrap
.if !empty(G_WRAP_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.g-wrap+= g-wrap>=1.3.4nb3
BUILDLINK_DEPENDS.g-wrap+= g-wrap<1.4
BUILDLINK_RECOMMENDED.g-wrap+= g-wrap>=1.3.4nb4
BUILDLINK_PKGSRCDIR.g-wrap?= ../../devel/g-wrap1
.endif # G_WRAP_BUILDLINK3_MK
.include "../../devel/glib/buildlink3.mk"
.include "../../lang/guile14/buildlink3.mk"
.include "../../devel/guile14-gtk/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

7
devel/g-wrap1/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
SHA1 (g-wrap-1.3.4.tar.gz) = 764f1c878e18341bf437f3e1ddc5f8618019bfc2
Size (g-wrap-1.3.4.tar.gz) = 403570 bytes
SHA1 (patch-aa) = 284e62e9a3456ab03a8337298fde587b2729c786
SHA1 (patch-ab) = 92f8e1ed55a3ba563837b36e2f39888734aebefe
SHA1 (patch-ac) = 7bd1543e1941668d71507d8ee6e1c5f1614f6472

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
--- doc/g-wrap.texi.orig 2002-11-07 17:23:43.000000000 +0000
+++ doc/g-wrap.texi
@@ -14,6 +14,11 @@
@parskip 4pt plus 1pt
@end iftex
+@dircategory Programming
+@direntry
+* g-wrap: (g-wrap). Create C bindings for Scheme/Guile.
+@end direntry
+
@titlepage
@title g-wrap
@subtitle A tool to wrap C APIs for Guile use.

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
--- bin/g-wrap-config.in.orig Thu Nov 7 17:23:43 2002
+++ bin/g-wrap-config.in Thu Feb 6 17:23:29 2003
@@ -56,7 +56,7 @@
(lambda (lib) (stdout " @-libdir-@/lib" lib ".a"))
(cdr libs))
(begin
- (stdout "-L@-libdir-@")
+ (stdout "-Wl,-R@-libdir-@ -L@-libdir-@")
(for-each
(lambda (lib) (stdout " -l" lib))
(cdr libs))))

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/12/03 16:02:25 wiz Exp $
--- bin/Makefile.in.orig 2002-11-08 05:40:46.000000000 +0100
+++ bin/Makefile.in
@@ -333,9 +333,9 @@ g-wrap: g-wrap.in Makefile
g-wrap-config: g-wrap-config.in
rm -f $@.tmp
sed < $@.in > $@.tmp \
- -e 's:@-GUILE-@:${GUILE}:' \
+ -e 's:@-GUILE-@:${PREFIX}/${GUILE14_SUBDIR}/bin/guile:' \
-e 's:@-VERSION-@:${VERSION}:' \
- -e 's:@-libdir-@:${libdir}:' \
+ -e 's:@-libdir-@:${libdir}:g' \
-e 's:@-includedir-@:${includedir}:' \
-e 's:@-GUILE_MODULE_DIR-@:${GUILEMODDIR}:'
chmod +x $@.tmp