gerbera: updated to 1.12.0

v1.12.0

NEW Features

- Support for NFO files as additional resources: Set up in `resources` and place nfo-files (https://kodi.wiki/view/NFO_files/Templates) next to your media files.
- Tweaking mimetypes for clients
- Editing Flags in web UI
- More statistics on web UI
- Add support for ip subnets in client config
- Defaults for virtual container upnp class
- Configuration for SQLite database modes
- Offline mode for initial scan large libraries

FIXES
- Database update on autoscan table
- Transcoding for external items
- Sqlite errors because of deleted objects
- Sorting by certain keys
- Broken path comparison (skipped renaming, adding files)
- Update docker images to alpine 3.16

Code Improvements
- Xml2Json rework
- build with latest versions of pupnp (1.14.14), wavpack (5.5.0), ebml (1.4.4), matroska (1.7.1), exiv2 (0.27.5), fmt (9.1.0) and spdlog (1.10.0)
- Further Cleanups

General
If you activated nfo-metafile resources you have to reimport your media files.
This commit is contained in:
adam 2022-11-30 21:28:36 +00:00
parent 61a66d1796
commit 9aae7e7cb5
6 changed files with 15 additions and 71 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.9 2022/11/23 16:20:43 adam Exp $
# $NetBSD: Makefile,v 1.10 2022/11/30 21:28:36 adam Exp $
DISTNAME= gerbera-1.11.0
PKGREVISION= 5
DISTNAME= gerbera-1.12.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GITHUB:=gerbera/}
GITHUB_TAG= v${PKGVERSION_NOREV}
@ -82,11 +81,10 @@ post-install:
.include "../../graphics/libexif/buildlink3.mk"
.include "../../net/libupnp/buildlink3.mk"
.include "../../sysutils/file/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../textproc/fmtlib/buildlink3.mk"
.include "../../textproc/pugixml/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,10 +1,11 @@
@comment $NetBSD: PLIST,v 1.2 2022/07/11 11:49:48 adam Exp $
@comment $NetBSD: PLIST,v 1.3 2022/11/30 21:28:36 adam Exp $
bin/gerbera
man/man1/gerbera.1
share/applications/gerbera.desktop
share/examples/gerbera/config.xml
share/gerbera/js/common.js
share/gerbera/js/import.js
share/gerbera/js/metadata.js
share/gerbera/js/playlists.js
share/gerbera/mysql-upgrade.xml
share/gerbera/mysql.sql

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.4 2022/10/10 12:47:51 adam Exp $
$NetBSD: distinfo,v 1.5 2022/11/30 21:28:36 adam Exp $
BLAKE2s (gerbera-1.11.0.tar.gz) = b5262860214cd153029adb3895f4c6d332a3ebd40d38f45728af001b80a71eaa
SHA512 (gerbera-1.11.0.tar.gz) = ae2b3342b3b57ce6d656d0ebadfd73b5f2764f2164314f6b0deac170a82e6861349c37732e6914454918112124038b221dbd4882001b5de51a49326432ccd70f
Size (gerbera-1.11.0.tar.gz) = 4115178 bytes
SHA1 (patch-CMakeLists.txt) = 37a399d71cb6f798fd29a64d7b16bb6215c41f6f
SHA1 (patch-src_database_sql__format.h) = db65159e215067f648857d05439c327adeab0e72
BLAKE2s (gerbera-1.12.0.tar.gz) = 20776d74a445cc53996b0f737caf726b0bc963a7f0cf4cc80da8ecb4307d977b
SHA512 (gerbera-1.12.0.tar.gz) = 0dd051058638dc5c3a834f92e6733a3e3f2833c73dd8184f4878d6dd1f3b9e5dabba5d62c13fc9a0e2424b8efb5501dab9acbb8befa1bdfbf178894a6c70bc16
Size (gerbera-1.12.0.tar.gz) = 4363130 bytes
SHA1 (patch-CMakeLists.txt) = 7b8e0e42547da4545be4fdf19dd27e6b5592f21d
SHA1 (patch-src_main.cc) = b7b59975bc477141c8a92af9200ba2b301e55926
SHA1 (patch-src_util_string__converter.cc) = f60a91b8ccdb851c5e939254e429ac08f5715196

View file

@ -1,26 +1,14 @@
$NetBSD: patch-CMakeLists.txt,v 1.2 2022/10/10 12:47:51 adam Exp $
$NetBSD: patch-CMakeLists.txt,v 1.3 2022/11/30 21:28:36 adam Exp $
Fix build on systems that have const in second argument to iconv.
Darwin does not require libuuid.
--- CMakeLists.txt.orig 2022-05-03 17:39:25.000000000 +0000
--- CMakeLists.txt.orig 2022-11-04 11:22:55.000000000 +0000
+++ CMakeLists.txt
@@ -326,9 +326,20 @@ target_link_libraries(libgerbera PUBLIC
find_package(Iconv REQUIRED)
target_link_libraries(libgerbera PUBLIC Iconv::Iconv)
+include(CheckPrototypeDefinition)
+set(CMAKE_REQUIRED_LIBRARIES Iconv::Iconv)
+check_prototype_definition(iconv
+ "size_t iconv(iconv_t cd, const char ** src, size_t * srcl, char ** dst, size_t * dstl)"
+ 0 "iconv.h" ICONV_CONST)
+if(ICONV_CONST)
+ target_compile_definitions(libgerbera PRIVATE ICONV_CONST)
+endif()
+unset(CMAKE_REQUIRED_LIBRARIES)
@@ -337,7 +337,9 @@ endif()
unset(CMAKE_REQUIRED_LIBRARIES)
find_package(UUID REQUIRED)
+if (NOT APPLE)
+if(NOT APPLE)
target_link_libraries(libgerbera PUBLIC UUID::UUID)
+endif()

View file

@ -1,24 +0,0 @@
$NetBSD: patch-src_database_sql__format.h,v 1.1 2022/10/10 12:47:51 adam Exp $
https://github.com/gerbera/gerbera/pull/2694
--- src/database/sql_format.h.orig 2022-05-03 17:39:25.000000000 +0000
+++ src/database/sql_format.h
@@ -42,7 +42,7 @@ struct SQLIdentifier {
template <>
struct fmt::formatter<SQLIdentifier> : formatter<std::string_view> {
template <typename FormatContext>
- auto format(const SQLIdentifier& tn, FormatContext& ctx) -> decltype(ctx.out())
+ auto format(const SQLIdentifier& tn, FormatContext& ctx) const -> decltype(ctx.out())
{
return format_to(ctx.out(), "{}{}{}", tn.quote_begin, tn.name, tn.quote_end);
}
@@ -61,7 +61,7 @@ struct ColumnUpdate {
template <>
struct fmt::formatter<ColumnUpdate> : formatter<std::string_view> {
template <typename FormatContext>
- auto format(const ColumnUpdate& a, FormatContext& ctx) -> decltype(ctx.out())
+ auto format(const ColumnUpdate& a, FormatContext& ctx) const -> decltype(ctx.out())
{
return format_to(ctx.out(), "{} = {}", a.column, a.value);
}

View file

@ -1,17 +0,0 @@
$NetBSD: patch-src_util_string__converter.cc,v 1.3 2022/10/06 08:41:03 nros Exp $
* fix build on systems that have const in second argument to iconv
--- src/util/string_converter.cc.orig 2022-10-06 08:09:22.564707578 +0000
+++ src/util/string_converter.cc
@@ -122,8 +122,8 @@ std::string StringConverter::_convert(co
// log_debug(("iconv: BEFORE: input bytes left: {} output bytes left: {}",
// input_bytes, output_bytes));
#if defined(ICONV_CONST) || defined(SOLARIS)
- int ret = iconv(cd, inputPtr, &input_bytes,
- output_ptr, &output_bytes);
+ int ret = iconv(cd, inputPtr, &inputBytes,
+ outputPtr, &outputBytes);
#else
int ret = iconv(cd, const_cast<char**>(inputPtr), &inputBytes,
outputPtr, &outputBytes);