PR pkg/48840: Fix configuration issues on Darwin
* On Darwin the profiler only supports x86 and x86_64. * Cocoa gamepad backend can only be used if the toolkit is cocoa too.
This commit is contained in:
parent
9e685c6c41
commit
9aeb91d08c
2 changed files with 47 additions and 17 deletions
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.144 2014/05/28 04:34:52 pho Exp $
|
||||
$NetBSD: distinfo,v 1.145 2014/05/28 04:55:30 pho Exp $
|
||||
|
||||
SHA1 (firefox-29.0.1.source.tar.bz2) = 2819ef63403de2bcfff5496bd21a3b8cb5dfce82
|
||||
RMD160 (firefox-29.0.1.source.tar.bz2) = f728179a12a46824971ca01cf79eb0318e4775c5
|
||||
Size (firefox-29.0.1.source.tar.bz2) = 142735471 bytes
|
||||
SHA1 (patch-aa) = e8e6918a0fe41ff65c656334843b216c5e958936
|
||||
SHA1 (patch-aa) = 2965a91cb4a3911ccd9d21bad8568cf809dfc08e
|
||||
SHA1 (patch-ak) = 971ddb1f12b14bcee604c9d7e72da5e7bf47d9be
|
||||
SHA1 (patch-al) = cca5df21d018bb9f428ad26d00718f33afe88ec5
|
||||
SHA1 (patch-ao) = ca7e6723a10b9f6e3306cd12557e1856727edee9
|
||||
|
|
|
@ -1,8 +1,27 @@
|
|||
$NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
||||
$NetBSD: patch-aa,v 1.26 2014/05/28 04:55:30 pho Exp $
|
||||
|
||||
--- configure.in.orig 2014-04-18 02:02:39.000000000 +0000
|
||||
* On Darwin the profiler only supports x86 and x86_64.
|
||||
|
||||
* Cocoa gamepad backend can only be used if the toolkit is cocoa too.
|
||||
|
||||
--- configure.in.orig 2014-05-06 22:55:16.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -2534,118 +2534,15 @@ MOZ_CXX11
|
||||
@@ -1613,7 +1613,13 @@ Linux)
|
||||
MOZ_ENABLE_PROFILER_SPS=
|
||||
esac
|
||||
;;
|
||||
-WINNT|Darwin) ;;
|
||||
+WINNT|Darwin)
|
||||
+ case "${CPU_ARCH}" in
|
||||
+ x86 | x86_64) ;;
|
||||
+ *)
|
||||
+ MOZ_ENABLE_PROFILER_SPS=
|
||||
+ esac
|
||||
+ ;;
|
||||
*)
|
||||
MOZ_ENABLE_PROFILER_SPS=
|
||||
;;
|
||||
@@ -2534,118 +2540,15 @@ MOZ_CXX11
|
||||
|
||||
AC_LANG_C
|
||||
|
||||
|
@ -128,7 +147,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
fi # GNU_CC
|
||||
|
||||
# visibility hidden flag for Sun Studio on Solaris
|
||||
@@ -3711,6 +3608,14 @@ if test -n "$YASM"; then
|
||||
@@ -3711,6 +3614,14 @@ if test -n "$YASM"; then
|
||||
_YASM_BUILD=` echo ${YASM_VERSION} | $AWK -F\. '{ print $4 }'`
|
||||
fi
|
||||
|
||||
|
@ -143,7 +162,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
if test -z "$SKIP_LIBRARY_CHECKS"; then
|
||||
dnl system JPEG support
|
||||
dnl ========================================================
|
||||
@@ -3738,11 +3643,7 @@ if test "$MOZ_NATIVE_JPEG" = 1; then
|
||||
@@ -3738,11 +3649,7 @@ if test "$MOZ_NATIVE_JPEG" = 1; then
|
||||
#include <jpeglib.h> ],
|
||||
[ #if JPEG_LIB_VERSION < $MOZJPEG
|
||||
#error "Insufficient JPEG library version ($MOZJPEG required)."
|
||||
|
@ -156,7 +175,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
MOZ_NATIVE_JPEG=1,
|
||||
AC_MSG_ERROR([Insufficient JPEG library version for --with-system-jpeg]))
|
||||
fi
|
||||
@@ -3940,6 +3841,22 @@ fi
|
||||
@@ -3940,6 +3847,22 @@ fi
|
||||
AC_SUBST(MOZ_NATIVE_ICU)
|
||||
|
||||
dnl ========================================================
|
||||
|
@ -179,7 +198,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
dnl Java SDK support
|
||||
dnl ========================================================
|
||||
|
||||
@@ -3974,6 +3891,7 @@ MOZ_SAMPLE_TYPE_FLOAT32=
|
||||
@@ -3974,6 +3897,7 @@ MOZ_SAMPLE_TYPE_FLOAT32=
|
||||
MOZ_SAMPLE_TYPE_S16=
|
||||
MOZ_OPUS=1
|
||||
MOZ_WEBM=1
|
||||
|
@ -187,7 +206,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
MOZ_DIRECTSHOW=
|
||||
MOZ_WMF=
|
||||
MOZ_FMP4=
|
||||
@@ -5135,6 +5053,9 @@ if test -n "$MOZ_WEBRTC"; then
|
||||
@@ -5135,6 +5059,9 @@ if test -n "$MOZ_WEBRTC"; then
|
||||
MOZ_VPX=1
|
||||
MOZ_VPX_ERROR_CONCEALMENT=1
|
||||
|
||||
|
@ -197,7 +216,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
dnl enable once Signaling lands
|
||||
MOZ_WEBRTC_SIGNALING=1
|
||||
AC_DEFINE(MOZ_WEBRTC_SIGNALING)
|
||||
@@ -5157,15 +5078,18 @@ AC_SUBST(MOZ_SRTP)
|
||||
@@ -5157,15 +5084,18 @@ AC_SUBST(MOZ_SRTP)
|
||||
|
||||
dnl Use integers over floats for audio on B2G and Android, because audio
|
||||
dnl backends for those platforms don't support floats.
|
||||
|
@ -219,7 +238,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
|
||||
dnl ========================================================
|
||||
dnl = Disable Speech API code
|
||||
@@ -5229,6 +5153,57 @@ if test -n "$MOZ_OGG"; then
|
||||
@@ -5229,6 +5159,57 @@ if test -n "$MOZ_OGG"; then
|
||||
fi
|
||||
|
||||
dnl ========================================================
|
||||
|
@ -277,7 +296,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
dnl = Disable Opus audio codec support
|
||||
dnl ========================================================
|
||||
MOZ_ARG_DISABLE_BOOL(opus,
|
||||
@@ -5237,6 +5212,76 @@ MOZ_ARG_DISABLE_BOOL(opus,
|
||||
@@ -5237,6 +5218,76 @@ MOZ_ARG_DISABLE_BOOL(opus,
|
||||
MOZ_OPUS=1)
|
||||
|
||||
dnl ========================================================
|
||||
|
@ -354,7 +373,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
dnl = Disable VP8 decoder support
|
||||
dnl ========================================================
|
||||
MOZ_ARG_DISABLE_BOOL(webm,
|
||||
@@ -5615,44 +5660,61 @@ WINNT|Darwin|Android)
|
||||
@@ -5615,44 +5666,61 @@ WINNT|Darwin|Android)
|
||||
;;
|
||||
*)
|
||||
MOZ_GSTREAMER=1
|
||||
|
@ -440,7 +459,18 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
fi
|
||||
|
||||
|
||||
@@ -7939,6 +8001,52 @@ if test "$USE_FC_FREETYPE"; then
|
||||
@@ -5866,7 +5934,9 @@ MOZ_ARG_DISABLE_BOOL(gamepad,
|
||||
if test "$MOZ_GAMEPAD"; then
|
||||
case "$OS_TARGET" in
|
||||
Darwin)
|
||||
- MOZ_GAMEPAD_BACKEND=cocoa
|
||||
+ if test "$MOZ_WIDGET_TOOLKIT" = "cocoa"; then
|
||||
+ MOZ_GAMEPAD_BACKEND=cocoa
|
||||
+ fi
|
||||
;;
|
||||
WINNT)
|
||||
if test -n "$MOZ_DIRECTX_SDK_PATH" ; then
|
||||
@@ -7939,6 +8009,52 @@ if test "$USE_FC_FREETYPE"; then
|
||||
fi
|
||||
|
||||
dnl ========================================================
|
||||
|
@ -493,7 +523,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
dnl Check for pixman and cairo
|
||||
dnl ========================================================
|
||||
|
||||
@@ -8189,7 +8297,7 @@ case "$OS_TARGET" in
|
||||
@@ -8189,7 +8305,7 @@ case "$OS_TARGET" in
|
||||
NECKO_WIFI=1
|
||||
fi
|
||||
;;
|
||||
|
@ -502,7 +532,7 @@ $NetBSD: patch-aa,v 1.25 2014/05/05 00:53:35 ryoon Exp $
|
|||
NECKO_WIFI=1
|
||||
;;
|
||||
Linux)
|
||||
@@ -8736,6 +8844,20 @@ AC_SUBST(MOZ_ENABLE_SZIP)
|
||||
@@ -8736,6 +8852,20 @@ AC_SUBST(MOZ_ENABLE_SZIP)
|
||||
AC_SUBST(MOZ_SZIP_FLAGS)
|
||||
|
||||
if test -n "$COMPILE_ENVIRONMENT"; then
|
||||
|
|
Loading…
Reference in a new issue