Fix build error introduced by gcc3.

ftp://ftp.netbsd.org/pub/NetBSD/misc/agc/borked-current/audio/spiralsynth/.broken.sys2.html
This commit is contained in:
ben 2003-12-19 16:48:06 +00:00
parent 6fb96afadf
commit 9af7b585f0
8 changed files with 107 additions and 5 deletions

View file

@ -1,7 +1,13 @@
$NetBSD: distinfo,v 1.4 2003/07/22 20:43:04 jmmv Exp $
$NetBSD: distinfo,v 1.5 2003/12/19 16:48:06 ben Exp $
SHA1 (SpiralSynth-0.1.7.tar.gz) = 8b66749b940c9dcfcd4a71c319ac233139014204
Size (SpiralSynth-0.1.7.tar.gz) = 62393 bytes
SHA1 (patch-aa) = f2c61de20ca47da2f64d4c8f78491519a7f0b94d
SHA1 (patch-ab) = 4e9ce3281a9f6b1dac3c120cbe600fb60ed379f7
SHA1 (patch-ab) = b107fccc27b3ec1e115b93aacc216b472070b792
SHA1 (patch-ad) = 207bc32f2991f99ba2e907a417d127f0073b3d24
SHA1 (patch-ae) = b0c36c839504ecef6c781609ebd9fef266249645
SHA1 (patch-af) = beb35f52d7bf1facfa8fab41889fc099b55a3517
SHA1 (patch-ag) = 87457e618774f8cf7c0d81022d14533a72203099
SHA1 (patch-ah) = de76624b1d007e6c41a0c8dc19a167107e82009b
SHA1 (patch-ai) = e21a111e3e52fc3c24433f248fa1bfdf566e72dd
SHA1 (patch-aj) = 7e3e29fbfd38428d68f195db8a7f5007c1417c88

View file

@ -1,8 +1,17 @@
$NetBSD: patch-ab,v 1.2 2003/07/22 20:43:04 jmmv Exp $
$NetBSD: patch-ab,v 1.3 2003/12/19 16:48:06 ben Exp $
--- SpiralInfo.C.orig Sun Nov 26 07:52:43 2000
--- SpiralInfo.C.orig 2000-11-26 07:52:43.000000000 -0800
+++ SpiralInfo.C
@@ -41,7 +41,7 @@
@@ -22,7 +22,7 @@
#include "SpiralSound/SpiralInfo.h"
-float RandFloat(float s=0.0f, float e=1.0f)
+float RandFloat(float s, float e)
{
return s+((rand()%10000/10000.0)*(e-s));
}
@@ -41,7 +41,7 @@ long SpiralInfo::MAXSAMPLE = 32767;
float SpiralInfo::VALUECONV = 1.0f/MAXSAMPLE;
bool SpiralInfo::WANTMIDI = true;
int SpiralInfo::FILTERGRAN = 50;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2003/12/19 16:48:06 ben Exp $
--- SpiralSound/SpiralInfo.h.orig 2000-11-26 07:52:46.000000000 -0800
+++ SpiralSound/SpiralInfo.h
@@ -16,6 +16,8 @@
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*/
+using namespace std;
+
#include <iostream.h>
#include <string>
#include <stdlib.h>

View file

@ -0,0 +1,22 @@
$NetBSD: patch-af,v 1.1 2003/12/19 16:48:06 ben Exp $
--- GUI/ScopeGUI.C.orig 2000-11-26 07:52:39.000000000 -0800
+++ GUI/ScopeGUI.C
@@ -22,7 +22,7 @@
#include <FL/fl_draw.H>
-ScopeWidget::ScopeWidget(int x,int y,int w,int h,const char *l=0) :
+ScopeWidget::ScopeWidget(int x,int y,int w,int h,const char *l) :
Fl_Widget(x,y,w,h,l)
{
}
@@ -53,7 +53,7 @@ void ScopeGUI::Display(short *data)
if (!m_Bypass) m_Scope->redraw();
}
-void ScopeGUI::CreateGUI(int xoff=0, int yoff=0, char *name)
+void ScopeGUI::CreateGUI(int xoff, int yoff, char *name)
{
Fl_Group* o = GUIScopeGroup = new Fl_Group(xoff, yoff, 225, 110, name);
o->type(1);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2003/12/19 16:48:06 ben Exp $
--- GUI/OutputGUI.C.orig 2000-11-26 07:52:39.000000000 -0800
+++ GUI/OutputGUI.C
@@ -26,7 +26,7 @@ OutputGUI::OutputGUI(Output *o)
if (!m_out) cerr<<"WARNING: Output not correctly set up"<<endl;
}
-void OutputGUI::CreateGUI(int xoff=0, int yoff=0, char *name)
+void OutputGUI::CreateGUI(int xoff, int yoff, char *name)
{
Fl_Group* o = GUIMixGroup = new Fl_Group(xoff, yoff, 85, 110, name);
o->type(1);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ah,v 1.1 2003/12/19 16:48:06 ben Exp $
--- GUI/Widgets/Fl_Knob.cxx.orig 2000-09-11 12:52:03.000000000 -0700
+++ GUI/Widgets/Fl_Knob.cxx
@@ -4,7 +4,7 @@
#include <FL/fl_draw.H>
#include <math.h>
-Fl_Knob::Fl_Knob(int xx,int yy,int ww,int hh,const char *l=0): Fl_Valuator(xx,yy,ww,hh,l) {
+Fl_Knob::Fl_Knob(int xx,int yy,int ww,int hh,const char *l): Fl_Valuator(xx,yy,ww,hh,l) {
a1 = 35;
a2 = 325;
_type = DOTLIN;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1 2003/12/19 16:48:06 ben Exp $
--- SpiralSound/RiffWav.h.orig 2000-11-26 07:52:45.000000000 -0800
+++ SpiralSound/RiffWav.h
@@ -16,6 +16,8 @@
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*/
+using namespace std;
+
#include <string>
#ifndef WAVFILE

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aj,v 1.1 2003/12/19 16:48:06 ben Exp $
--- GUI/MixerGUI.C.orig 2000-11-26 07:52:40.000000000 -0800
+++ GUI/MixerGUI.C
@@ -24,7 +24,7 @@ MixerGUI::MixerGUI(Mixer *o)
if (!m_mix) cerr<<"WARNING: Mixer not correctly set up"<<endl;
}
-void MixerGUI::CreateGUI(int xoff=0, int yoff=0, char *name)
+void MixerGUI::CreateGUI(int xoff, int yoff, char *name)
{
Fl_Group* o = GUIMixGroup = new Fl_Group(xoff, yoff, 100, 110, name);
o->type(1);