Re-Added upclient-4.2.1.23: Keeps track of your server uptime
Upclient is a program that keeps track of your server uptime, and lets you compare it with the uptime of other (similar) hosts. It consists of two parts, a client- and a serverpart. The client runs on your server and sends the uptime every few minutes to the server. The server collects all data in a table on this site. Package re-added after the service formerly offered by uptimes.net is now again online as http://www.wonko.com/
This commit is contained in:
parent
6c365d797a
commit
9b3ba13c68
9 changed files with 110 additions and 3 deletions
|
@ -1,5 +1,5 @@
|
|||
======================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2002/05/07 22:20:59 hubertf Exp $
|
||||
$NetBSD: MESSAGE,v 1.2 2002/05/07 22:25:02 hubertf Exp $
|
||||
|
||||
To start the Uptime Client, run the ${PREFIX}/etc/rc.d/upclient
|
||||
script either manually or via /etc/rc.local.
|
||||
|
|
41
net/upclient/Makefile
Normal file
41
net/upclient/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $NetBSD: Makefile,v 1.11 2002/05/07 22:25:03 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= upclient-4.2.1.23
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://uptimes.atomicvoid.net/files/
|
||||
|
||||
MAINTAINER= hubertf@netbsd.org
|
||||
HOMEPAGE= http://uptimes.wonko.com/
|
||||
COMMENT= Keeps track of your server uptime, and compares it to other hosts
|
||||
|
||||
ALL_TARGET= bsd
|
||||
|
||||
post-patch:
|
||||
${MV} ${WRKSRC}/scripts/upchk ${WRKSRC}/scripts/upchk.bak
|
||||
${SED} \
|
||||
-e 's|@PREFIX@|${PREFIX}|g' \
|
||||
>${WRKSRC}/scripts/upchk <${WRKSRC}/scripts/upchk.bak
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/src && ${MAKE} ${ALL_TARGET}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/upclient ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/HISTORY ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/FAQ ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/upclient
|
||||
${INSTALL_DATA} ${WRKSRC}/conf/upclient.conf ${PREFIX}/etc
|
||||
${SED} \
|
||||
-e 's|@PREFIX@|${PREFIX}|g' \
|
||||
-e 's|@INSTALL@|${INSTALL}|g' \
|
||||
-e 's|@SU@|${SU}|g' \
|
||||
${FILESDIR}/upclient.sh >${PREFIX}/etc/rc.d/upclient
|
||||
${CHMOD} +x ${PREFIX}/etc/rc.d/upclient
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/05/07 22:20:59 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2002/05/07 22:25:03 hubertf Exp $
|
||||
bin/upclient
|
||||
etc/rc.d/upclient
|
||||
etc/upclient.conf
|
||||
|
|
8
net/upclient/distinfo
Normal file
8
net/upclient/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2002/05/07 22:25:03 hubertf Exp $
|
||||
|
||||
SHA1 (upclient-4.2.1.23.tar.gz) = c6595959c6a5058b03ab7096a6bf9c0dbfa4285a
|
||||
Size (upclient-4.2.1.23.tar.gz) = 29386 bytes
|
||||
SHA1 (patch-aa) = 4492c6741adc516171ecba4d272f5ab46ec28ebe
|
||||
SHA1 (patch-ab) = dd1e318cee6e27fcf433b2123cf8f3f6ed8eb548
|
||||
SHA1 (patch-ac) = 3641ee544199aa0b63ddfb090b64cbab60e9bb8c
|
||||
SHA1 (patch-ad) = a850246e88af38aa3c64cf18b40f5702208c5887
|
15
net/upclient/files/upclient.sh
Normal file
15
net/upclient/files/upclient.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
#!/bin/sh
|
||||
|
||||
pidfile=/var/run/upclient.pid
|
||||
|
||||
if [ "$1" = "stop" ]; then
|
||||
kill `cat $pidfile`
|
||||
|
||||
else
|
||||
if [ -x @PREFIX@/bin/upclient ]
|
||||
then
|
||||
@INSTALL@ -o nobody -m 644 /dev/null $pidfile
|
||||
@SU@ -m nobody -c @PREFIX@/bin/upclient
|
||||
echo -n ' upclient'
|
||||
fi
|
||||
fi
|
18
net/upclient/patches/patch-aa
Normal file
18
net/upclient/patches/patch-aa
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-aa,v 1.7 2002/05/07 22:25:03 hubertf Exp $
|
||||
|
||||
--- src/options.c Sat Jun 16 14:15:04 2001
|
||||
+++ src/options.c Tue Jun 19 10:48:25 2001
|
||||
@@ -298,8 +298,11 @@
|
||||
if(!(fp = fopen("/etc/"CONFIGFILE, "r"))) {
|
||||
/* Failed, now try to open config file in /usr/local/etc */
|
||||
if(!(fp = fopen("/usr/local/etc/"CONFIGFILE, "r"))) {
|
||||
- printf("Error: couldn't open config file %s for reading in:\n- current directory\n- /etc\n- /usr/local/etc\n", CONFIGFILE);
|
||||
- exit(-1);
|
||||
+ /* Failed, now try to open config file in /usr/pkg/etc */
|
||||
+ if (!(fp = fopen("/usr/pkg/etc/"CONFIGFILE, "r"))) {
|
||||
+ printf("Error: couldn't open config file %s for reading in:\n- current directory\n- /etc\n- /usr/local/etc\n- /usr/pkg/etc\n", CONFIGFILE);
|
||||
+ exit(-1);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
13
net/upclient/patches/patch-ab
Normal file
13
net/upclient/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.5 2002/05/07 22:25:04 hubertf Exp $
|
||||
|
||||
--- scripts/upchk.orig Tue Jun 19 11:15:24 2001
|
||||
+++ scripts/upchk Tue Jun 19 11:15:51 2001
|
||||
@@ -24,7 +24,7 @@
|
||||
#
|
||||
|
||||
# change this to the full path AND name of your upclient executable:
|
||||
-upclient="/usr/local/sbin/upclient"
|
||||
+upclient="@PREFIX@/bin/upclient"
|
||||
|
||||
# change this to the name of your upclient's pidfile (as defined in
|
||||
# config.h of the upclient distribution)
|
12
net/upclient/patches/patch-ac
Normal file
12
net/upclient/patches/patch-ac
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ac,v 1.5 2002/05/07 22:25:04 hubertf Exp $
|
||||
|
||||
--- src/stats-bsd.c.orig Sat Jun 16 21:12:53 2001
|
||||
+++ src/stats-bsd.c
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <sys/dkstat.h>
|
||||
#include <sys/sysctl.h>
|
||||
#include <sys/utsname.h>
|
||||
+#include <sys/sched.h>
|
||||
|
||||
/**
|
||||
* @desc Get statistics
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2002/05/07 22:20:59 hubertf Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2002/05/07 22:25:04 hubertf Exp $
|
||||
|
||||
--- conf/upclient.conf.orig Sat Jun 16 18:33:54 2001
|
||||
+++ conf/upclient.conf
|
||||
|
|
Loading…
Reference in a new issue