Update to 2.0.1:

2.0.1

* Make ObConf work when the .obt file has been renamed (e.g. by box-look.org)
* Update swedish translation
* Update to Openbox 3.4.2 libraries

2.0.0

* Add the ability to install .obt theme archives
* Add the ability to create .obt theme archives
* Double clicking a .obt file will launch it with ObConf, install
  the theme, and select it for both KDE and GNOME desktops
* Fix for writing invalid font entries when none existed in the
  config file already
* Add new dock options showDelay and noStrut
* Add mouse option for double click time and drag threshold
* Add option for animate iconify/restore
* Make Openbox reconfigure with communication through the X server
  rather than by PID

1.6.3

* Add the ability to change your fonts
* Add the <focusLast> config option
* When changing the number of desktops, or their names, ObConf will
  set them in the current session as well as saving them to the
  Openbox config file.
* Improve how ObConf sets the desktop names. You can leave them
  empty and it will use the default translated names from Openbox.

1.6.1

* Update to the Openbox 3.4 series libraries.
This commit is contained in:
wiz 2007-06-12 18:02:01 +00:00
parent 2df5b7db40
commit 9b461d0f0c
4 changed files with 28 additions and 61 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.19 2007/01/13 17:48:34 joerg Exp $
# $NetBSD: Makefile,v 1.20 2007/06/12 18:02:01 wiz Exp $
DISTNAME= obconf-1.5
PKGREVISION= 8
DISTNAME= obconf-2.0.1
CATEGORIES= wm
MASTER_SITES= http://icculus.org/openbox/obconf/
@ -13,7 +12,11 @@ USE_TOOLS+= pkg-config
USE_DIRS+= xdg-1.1
GNU_CONFIGURE= YES
.include "../../databases/shared-mime-info/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/buildlink3.mk"
BUILDLINK_API_DEPENDS.openbox+= openbox>=3.4.2
.include "../../wm/openbox/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"

View file

@ -1,6 +1,13 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/13 21:10:21 xtraeme Exp $
@comment $NetBSD: PLIST,v 1.2 2007/06/12 18:02:01 wiz Exp $
bin/obconf
share/applications/obconf.desktop
share/locale/en@boldquot/LC_MESSAGES/obconf.mo
share/locale/en@quot/LC_MESSAGES/obconf.mo
share/locale/sv/LC_MESSAGES/obconf.mo
share/mime/packages/obconf.xml
share/mimelnk/application/x-openbox-theme.desktop
share/obconf/obconf.glade
@dirrm share/obconf
@unexec ${RMDIR} %D/share/mimelnk/application 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/mimelnk 2>/dev/null || ${TRUE}
@comment in gnome2-dirs: @dirrm share/applications

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2005/02/23 18:43:54 wiz Exp $
$NetBSD: distinfo,v 1.4 2007/06/12 18:02:01 wiz Exp $
SHA1 (obconf-1.5.tar.gz) = a82067d5cd79d13df4c1c77e2a281a37fa5de7d2
RMD160 (obconf-1.5.tar.gz) = c21efab25bd712ec18f0cae9d160336b715e59cc
Size (obconf-1.5.tar.gz) = 163007 bytes
SHA1 (patch-aa) = 3aedcfc85c81e075ef07b07d06cb427c5aaf6b53
SHA1 (obconf-2.0.1.tar.gz) = 927b19995d4e8d235b14bceeed382865ec2e98f5
RMD160 (obconf-2.0.1.tar.gz) = 4561f03fba4e48d57f4eb704bdc56f1b05b5f9d7
Size (obconf-2.0.1.tar.gz) = 204780 bytes
SHA1 (patch-aa) = 0de087b762e8f545fa361f480a0e2e30e0ac40ee

View file

@ -1,55 +1,12 @@
$NetBSD: patch-aa,v 1.1 2004/01/14 22:33:28 wiz Exp $
$NetBSD: patch-aa,v 1.2 2007/06/12 18:02:02 wiz Exp $
--- src/handlers.c.orig Sun Sep 28 11:10:25 2003
+++ src/handlers.c
@@ -45,13 +45,12 @@ void setup_behavior_tab()
GtkWidget *edgeresist = glade_xml_get_widget(glade, "resist_edge");
GtkSizeGroup *group1 = gtk_size_group_new(GTK_SIZE_GROUP_HORIZONTAL);
--- po/Makefile.in.in.orig 2007-05-31 16:26:26.000000000 +0000
+++ po/Makefile.in.in
@@ -30,6 +30,7 @@ gettextsrcdir = $(datadir)/gettext/po
- gtk_size_group_add_widget(group1, winresist);
- gtk_size_group_add_widget(group1, edgeresist);
-
GtkWidget *winresist_l = glade_xml_get_widget(glade, "resist_window_label");
GtkWidget *edgeresist_l = glade_xml_get_widget(glade, "resist_edge_label");
GtkSizeGroup *group2 = gtk_size_group_new(GTK_SIZE_GROUP_HORIZONTAL);
+ gtk_size_group_add_widget(group1, winresist);
+ gtk_size_group_add_widget(group1, edgeresist);
gtk_size_group_add_widget(group2, winresist_l);
gtk_size_group_add_widget(group2, edgeresist_l);
}
@@ -62,13 +61,12 @@ void setup_dock_tab()
GtkWidget *dir = glade_xml_get_widget(glade, "dock_direction");
GtkSizeGroup *group1 = gtk_size_group_new(GTK_SIZE_GROUP_HORIZONTAL);
- gtk_size_group_add_widget(group1, posi);
- gtk_size_group_add_widget(group1, dir);
-
GtkWidget *posi_l = glade_xml_get_widget(glade, "dock_position_label");
GtkWidget *dir_l = glade_xml_get_widget(glade, "dock_direction_label");
GtkSizeGroup *group2 = gtk_size_group_new(GTK_SIZE_GROUP_HORIZONTAL);
+ gtk_size_group_add_widget(group1, posi);
+ gtk_size_group_add_widget(group1, dir);
gtk_size_group_add_widget(group2, posi_l);
gtk_size_group_add_widget(group2, dir_l);
}
@@ -979,14 +977,15 @@ static void on_desktop_names_cell_edited
const gchar *new_text,
gpointer data)
{
- if (mapping) return;
-
- GtkTreePath *path = gtk_tree_path_new_from_string (path_string);
+ GtkTreePath *path;
GtkTreeIter it;
gchar *old_text;
GList *lit;
gint i;
xmlNodePtr n, c;
+
+ if (mapping) return;
+ path = gtk_tree_path_new_from_string (path_string);
gtk_tree_model_get_iter(GTK_TREE_MODEL(desktop_store), &it, path);
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
+install_sh = @install_sh@
mkinstalldirs = $(SHELL) @install_sh@ -d
mkdir_p = @mkdir_p@