use awk instead of csplit during the build. csplit was only

used in one place and it generated a build dependency on a package
which conflicts with many other pkgs.
This commit is contained in:
dmcmahill 2005-03-19 20:47:46 +00:00
parent bb26667984
commit 9b64948851
3 changed files with 11 additions and 15 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2005/03/16 02:10:30 dmcmahill Exp $
# $NetBSD: Makefile,v 1.9 2005/03/19 20:47:46 dmcmahill Exp $
DISTNAME= octave-forge-2004.11.16
CATEGORIES= cad
@ -8,13 +8,6 @@ MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://octave.sourceforge.net/
COMMENT= Extensions to Octave
.if exists(/bin/csplit)
MAKE_ENV+= CSPLIT=/bin/csplit
.else
BUILD_DEPENDS+= coreutils-*:../../sysutils/coreutils
MAKE_ENV+= CSPLIT=${LOCALBASE}/bin/${GNU_PROGRAM_PREFIX}csplit
.endif
PKG_INSTALLATION_TYPES= overwrite pkgviews
USE_BUILDLINK3= YES

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.6 2005/03/14 04:08:42 dmcmahill Exp $
$NetBSD: distinfo,v 1.7 2005/03/19 20:47:46 dmcmahill Exp $
SHA1 (octave-forge-2004.11.16.tar.gz) = a27dbccd1665eb99b1457d23c1ac6b75eb3a9800
RMD160 (octave-forge-2004.11.16.tar.gz) = 9356864920a5a4d4a4c1786c3ea74be0ec1e760d
Size (octave-forge-2004.11.16.tar.gz) = 3639093 bytes
SHA1 (patch-aa) = 1723f94e7532dd8ddd691bf5a348c5447b4d312b
SHA1 (patch-aa) = d48898ade563f2ad62f1558f6b6ae98bf18b91ef
SHA1 (patch-ab) = a9c46217e12f9278dfa9123707183c6d9e702070
SHA1 (patch-ac) = fdd01692f5f762da42551a816972a80eb27a3819
SHA1 (patch-ad) = 463f05f1061f4ff0e28f91f04be0aee348044ef8

View file

@ -1,12 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/08/14 13:29:56 dmcmahill Exp $
$NetBSD: patch-aa,v 1.2 2005/03/19 20:47:46 dmcmahill Exp $
--- main/gsl/replace_template.sh.orig Tue May 4 15:49:42 2004
+++ main/gsl/replace_template.sh
@@ -1,8 +1,8 @@
--- main/gsl/replace_template.sh.orig 2004-05-04 15:49:42.000000000 +0000
+++ main/gsl/replace_template.sh 2005-03-18 20:26:03.000000000 +0000
@@ -1,8 +1,11 @@
#!/bin/sh
-csplit -f tmp_gsl $1 /DEFUN/ /GSL_FUNC_DOCSTRING/ /./ > /dev/null
+${CSPLIT} -f tmp_gsl $1 /DEFUN/ /GSL_FUNC_DOCSTRING/ /./ > /dev/null
+awk '/DEFUN/ {exit} {print}' $1 > tmp_gsl00
+awk '/DEFUN/ {state=1} /GSL_FUNC_DOCSTRING/ {if(state==1){exit}} state==1{print}' $1 > tmp_gsl01
+awk '/DEFUN/ {state=1} /GSL_FUNC_DOCSTRING/ {if(state==1){print ; exit}}' $1 > tmp_gsl02
+awk 'state==2{print} /DEFUN/ {state=1} /GSL_FUNC_DOCSTRING/ {if(state==1){state=2}}' $1 > tmp_gsl03
cat tmp_gsl01 | sed "s/GSL_OCTAVE_NAME/$octave_name/g"
cat docstring.txt | sed 's/\\/\\\\/g' | sed 's/$/\\n\\/g'
cat tmp_gsl03 | sed "s/GSL_OCTAVE_NAME/$octave_name/g" | sed "s/GSL_FUNC_NAME/$funcname/g"