completely ignore system php.ini for all pear-related operations; this

is necessary to avoid being subject to e.g. open_basedir or safe_mode settings
This commit is contained in:
jdolecek 2004-12-12 11:03:33 +00:00
parent 1c217a3f54
commit 9b81fff133
7 changed files with 30 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: pear.mk,v 1.4 2004/12/12 09:41:14 jdolecek Exp $
# $NetBSD: pear.mk,v 1.5 2004/12/12 11:03:33 jdolecek Exp $
#
# This Makefile fragment is intended to be included by packages that build
# and install pear packages.
@ -43,7 +43,7 @@ PEAR_GENERATE_PLIST= \
${ECHO} "@comment The following lines are automatically generated"; \
PEAR_LIB="${PEAR_LIB}" WRKSRC="${WRKSRC}" \
PEAR_DIRRM_BASEDIR="${PEAR_DIRRM_BASEDIR}" \
${PREFIX}/bin/php ${PKGDIR}/../../lang/php/pear_plist.php;
${PREFIX}/bin/php -C -n ${PKGDIR}/../../lang/php/pear_plist.php;
GENERATE_PLIST+= ${PEAR_GENERATE_PLIST}
NO_BUILD= # defined

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.4 2004/11/04 18:38:55 jdolecek Exp $
# $NetBSD: Makefile,v 1.5 2004/12/12 11:03:33 jdolecek Exp $
#
PKGNAME= php-${PHP_BASE_VERS}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= lang
MAINTAINER= pancake@phreaker.net

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2004/10/31 21:14:54 jdolecek Exp $
$NetBSD: distinfo,v 1.3 2004/12/12 11:03:33 jdolecek Exp $
SHA1 (php-5.0.2.tar.bz2) = 85e4635ce764199d60329a578421159f338be082
Size (php-5.0.2.tar.bz2) = 4577974 bytes
SHA1 (patch-aj) = 88e456015f4d8e92ea57019df39195905b3f6c28
SHA1 (patch-ak) = 0faa523103e0a9a3c01c78c2fe9a64c0a9b2fc43
SHA1 (patch-al) = 28ad9006b387e2b9984ad49beea21c9d46e63b46

View file

@ -0,0 +1,10 @@
$NetBSD: patch-al,v 1.1 2004/12/12 11:03:33 jdolecek Exp $
--- pear/scripts/pear.sh.orig 2004-12-12 10:44:13.000000000 +0100
+++ pear/scripts/pear.sh 2004-12-12 10:44:21.000000000 +0100
@@ -25,4 +25,4 @@
fi
fi
-exec $PHP -C -q $INCARG -d output_buffering=1 $INCDIR/pearcmd.php "$@"
+exec $PHP -C -q $INCARG -d output_buffering=1 -n $INCDIR/pearcmd.php "$@"

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile.php,v 1.19 2004/11/27 14:00:08 jdolecek Exp $
# $NetBSD: Makefile.php,v 1.20 2004/12/12 11:03:33 jdolecek Exp $
.include "../../www/php4/Makefile.common"
# revision of the core PHP interpreter package
PKGREVISION= 2
PKGREVISION= 3
DISTINFO_FILE= ${.CURDIR}/../../www/php4/distinfo
PATCHDIR= ${.CURDIR}/../../www/php4/patches

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.34 2004/12/09 14:50:23 jlam Exp $
$NetBSD: distinfo,v 1.35 2004/12/12 11:03:33 jdolecek Exp $
SHA1 (php-4.3.9.tar.bz2) = 9995ce1f0b84a6d3c230552446dbcd91dbf426b0
Size (php-4.3.9.tar.bz2) = 4001681 bytes
@ -10,3 +10,4 @@ SHA1 (patch-ah) = 0ac37bd35c4594cb58f1ea85ef811154b644a931
SHA1 (patch-ai) = 0b9c1c9fb75a64026f2fb3cbd44cc19e0a1f186c
SHA1 (patch-aj) = 132b5b5b802f1795deda9487db5f22cfe9edce5d
SHA1 (patch-ak) = bd2aac1a91ed77208b45747c9d11e87731c6b46f
SHA1 (patch-al) = 28ad9006b387e2b9984ad49beea21c9d46e63b46

10
www/php4/patches/patch-al Normal file
View file

@ -0,0 +1,10 @@
$NetBSD: patch-al,v 1.1 2004/12/12 11:03:33 jdolecek Exp $
--- pear/scripts/pear.sh.orig 2004-12-12 10:44:13.000000000 +0100
+++ pear/scripts/pear.sh 2004-12-12 10:44:21.000000000 +0100
@@ -25,4 +25,4 @@
fi
fi
-exec $PHP -C -q $INCARG -d output_buffering=1 $INCDIR/pearcmd.php "$@"
+exec $PHP -C -q $INCARG -d output_buffering=1 -n $INCDIR/pearcmd.php "$@"