Fix build with newer GCC
This commit is contained in:
parent
6de67c8841
commit
9bd1bb8e67
8 changed files with 117 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/11/05 14:18:52 adam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
SHA1 (cone-0.84.tar.bz2) = 507962bd666c4435e66f7653670c9aee360fd771
|
||||
RMD160 (cone-0.84.tar.bz2) = 88a76c71807269daa7094206a39ce566726c0b23
|
||||
|
@ -9,3 +9,10 @@ SHA1 (patch-ac) = 2a6a8ad9c8cc6773b219bfbefabc11eac31f6cb3
|
|||
SHA1 (patch-ad) = 578dde2e725ca4e1b332ad2e9135446534aa3184
|
||||
SHA1 (patch-ae) = f11842f29aadd91aaab74dff8583d6b62c06673d
|
||||
SHA1 (patch-af) = e78186b709c4eae63b5b05e5bf57dcc6a2967613
|
||||
SHA1 (patch-libmail-maildir.C) = 82962f71d9cfc4e6e124504bf2bbacde8487baf4
|
||||
SHA1 (patch-libmail-mbox.C) = 964e0901341d2ebdd1ac1fef2349d0565f5df188
|
||||
SHA1 (patch-libmail-mboxadd.C) = 614c95af75eba90c29868dc78f220df0fe9cdc77
|
||||
SHA1 (patch-libmail-mboxfolder.C) = 1ad0bc2ecfde93b941204501afa241f56e572dd0
|
||||
SHA1 (patch-libmail-mboxgetmessage.C) = fde73c28f91efbd9ca86e17f0980edd3d7994178
|
||||
SHA1 (patch-libmail-mboxread.C) = dea06e218ccbf683102d4c05a8ec8a4c64d96f4b
|
||||
SHA1 (patch-libmail-tmpaccount.C) = 5333f86f4ee37fb1b146048d37d70c7647b127ba
|
||||
|
|
15
mail/cone/patches/patch-libmail-maildir.C
Normal file
15
mail/cone/patches/patch-libmail-maildir.C
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libmail-maildir.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/maildir.C.orig 2011-11-22 16:26:47.000000000 +0000
|
||||
+++ libmail/maildir.C
|
||||
@@ -31,6 +31,8 @@
|
||||
#include <list>
|
||||
#include <map>
|
||||
|
||||
+#undef ferror
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
/////////////////////////////////////////////////////////////////////////////
|
17
mail/cone/patches/patch-libmail-mbox.C
Normal file
17
mail/cone/patches/patch-libmail-mbox.C
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-libmail-mbox.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/mbox.C.orig 2011-11-22 16:27:37.000000000 +0000
|
||||
+++ libmail/mbox.C
|
||||
@@ -32,6 +32,10 @@
|
||||
#include <signal.h>
|
||||
#include <ctype.h>
|
||||
|
||||
+#undef feof
|
||||
+#undef ferror
|
||||
+#undef getc
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
/////////////////////////////////////////////////////////////////////////////
|
17
mail/cone/patches/patch-libmail-mboxadd.C
Normal file
17
mail/cone/patches/patch-libmail-mboxadd.C
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-libmail-mboxadd.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/mboxadd.C.orig 2011-11-22 16:29:21.000000000 +0000
|
||||
+++ libmail/mboxadd.C
|
||||
@@ -16,6 +16,10 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
+#undef feof
|
||||
+#undef ferror
|
||||
+#undef getc
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
mail::mbox::folder::add::add(mail::mbox &mboxArg, string pathArg,
|
15
mail/cone/patches/patch-libmail-mboxfolder.C
Normal file
15
mail/cone/patches/patch-libmail-mboxfolder.C
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libmail-mboxfolder.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/mboxfolder.C.orig 2011-11-22 16:30:20.000000000 +0000
|
||||
+++ libmail/mboxfolder.C
|
||||
@@ -40,6 +40,8 @@
|
||||
|
||||
#include <vector>
|
||||
|
||||
+#undef feof
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
mail::mbox::folder::folder(string pathArg,
|
15
mail/cone/patches/patch-libmail-mboxgetmessage.C
Normal file
15
mail/cone/patches/patch-libmail-mboxgetmessage.C
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libmail-mboxgetmessage.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/mboxgetmessage.C.orig 2011-11-22 16:30:48.000000000 +0000
|
||||
+++ libmail/mboxgetmessage.C
|
||||
@@ -16,6 +16,8 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
+#undef feof
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
mail::mbox::GenericGetMessageTask::GenericGetMessageTask(mail::mbox &mboxAccount,
|
15
mail/cone/patches/patch-libmail-mboxread.C
Normal file
15
mail/cone/patches/patch-libmail-mboxread.C
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libmail-mboxread.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/mboxread.C.orig 2011-11-22 16:32:57.000000000 +0000
|
||||
+++ libmail/mboxread.C
|
||||
@@ -12,6 +12,8 @@
|
||||
#include <ctype.h>
|
||||
#include <errno.h>
|
||||
|
||||
+#undef feof
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
mail::mbox::GenericReadTask::GenericReadTask(mail::mbox &mboxAccount,
|
15
mail/cone/patches/patch-libmail-tmpaccount.C
Normal file
15
mail/cone/patches/patch-libmail-tmpaccount.C
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-libmail-tmpaccount.C,v 1.1 2011/11/22 18:12:35 joerg Exp $
|
||||
|
||||
Use stdio functions to ensure that the mail::file cast to FILE * happens.
|
||||
|
||||
--- libmail/tmpaccount.C.orig 2011-11-22 16:37:21.000000000 +0000
|
||||
+++ libmail/tmpaccount.C
|
||||
@@ -14,6 +14,8 @@
|
||||
#include <errno.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
+#undef ferror
|
||||
+
|
||||
using namespace std;
|
||||
|
||||
LIBMAIL_START
|
Loading…
Reference in a new issue