* Fix enigmail runtime error

** Add NetBSD and DragonFly uname etc.
* Readd enigmail distfile
This commit is contained in:
ryoon 2012-04-04 20:05:09 +00:00
parent 721132d138
commit 9bd47ceab2
6 changed files with 42 additions and 4 deletions

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2012/03/15 09:45:29 ryoon Exp $
$NetBSD: distinfo,v 1.2 2012/04/04 20:05:44 ryoon Exp $
SHA1 (enigmail-1.4.tar.gz) = 1ee4bcd8d38685af44c1aeeea4fbba7bf30513e4
RMD160 (enigmail-1.4.tar.gz) = b3c717e150c826faae1daa09806e07dd16619c51
Size (enigmail-1.4.tar.gz) = 1323467 bytes
SHA1 (thunderbird-10.0.3esr.source.tar.bz2) = d348e4b630750685556811279f876ba885ba28b3
RMD160 (thunderbird-10.0.3esr.source.tar.bz2) = d04e24f4fd50b2aab923d25e44fa59b3dbef2404
Size (thunderbird-10.0.3esr.source.tar.bz2) = 97709099 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: enigmail.mk,v 1.1.1.1 2012/03/15 09:45:29 ryoon Exp $
# $NetBSD: enigmail.mk,v 1.2 2012/04/04 20:05:44 ryoon Exp $
#
# This Makefile fragment hooks the Enigmail OpenPGP extension
# (see http://www.mozilla-enigmail.org/ ) into the build.
@ -21,6 +21,8 @@ post-extract: enigmail-post-extract
.PHONY: enigmail-post-extract
enigmail-post-extract:
${RUN} mv ${WRKDIR}/enigmail ${WRKSRC}/mailnews/extensions/
${RUN} cd ${WRKSRC} && \
${PATCH} < ${FILESDIR}/mailnews_extensions_enigmail_ipc_modules_subprocess.jsm
post-configure: enigmail-post-configure
.PHONY: enigmail-post-configure

View file

@ -0,0 +1,14 @@
$NetBSD: mailnews_extensions_enigmail_ipc_modules_subprocess.jsm,v 1.1 2012/04/04 20:05:44 ryoon Exp $
--- mailnews/extensions/enigmail/ipc/modules/subprocess.jsm.orig 2012-02-09 16:50:47.000000000 +0000
+++ mailnews/extensions/enigmail/ipc/modules/subprocess.jsm
@@ -312,7 +312,9 @@ function getPlatformValue(valueType) {
// library name O_NONBLOCK RLIM_T RLIMIT_NOFILE
'darwin': [ 'libc.dylib', 0x04 , ctypes.uint64_t , 8 ],
'linux': [ 'libc.so.6', 2024 , ctypes.unsigned_long, 7 ],
+ 'dragonfly': [ 'libc.so', 0x04 , ctypes.int64_t , 8 ],
'freebsd': [ 'libc.so.7', 0x04 , ctypes.int64_t , 8 ],
+ 'netbsd': [ 'libc.so', 0x04 , ctypes.int64_t , 8 ],
'openbsd': [ 'libc.so.61.0', 0x04 , ctypes.int64_t , 8 ],
'sunos': [ 'libc.so', 0x80 , ctypes.unsigned_long, 5 ]
}

View file

@ -1,8 +1,11 @@
$NetBSD: distinfo,v 1.80 2012/04/02 14:35:00 ryoon Exp $
$NetBSD: distinfo,v 1.81 2012/04/04 20:05:09 ryoon Exp $
SHA1 (comm-release-f60c071e187b.tar.bz2) = 7b3770d918a7662688d6641bc367c1c375bc7200
RMD160 (comm-release-f60c071e187b.tar.bz2) = e1efa6624eaf565b95f7e9d68ca04a3cbbe47f05
Size (comm-release-f60c071e187b.tar.bz2) = 2261054 bytes
SHA1 (enigmail-1.4.tar.gz) = 1ee4bcd8d38685af44c1aeeea4fbba7bf30513e4
RMD160 (enigmail-1.4.tar.gz) = b3c717e150c826faae1daa09806e07dd16619c51
Size (enigmail-1.4.tar.gz) = 1323467 bytes
SHA1 (seamonkey-2.8.source.tar.bz2) = 8f5ef8cb2a3ac495add99fb3394d8c007a5d91af
RMD160 (seamonkey-2.8.source.tar.bz2) = 7aa190c00585cf9cb2f7bccbdf58e6c980be344c
Size (seamonkey-2.8.source.tar.bz2) = 101616662 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: enigmail.mk,v 1.1 2012/03/19 20:28:11 ryoon Exp $
# $NetBSD: enigmail.mk,v 1.2 2012/04/04 20:05:09 ryoon Exp $
#
# This Makefile fragment hooks the Enigmail OpenPGP extension
# (see http://www.mozilla-enigmail.org/ ) into the build.
@ -21,6 +21,8 @@ post-extract: enigmail-post-extract
.PHONY: enigmail-post-extract
enigmail-post-extract:
${RUN} mv ${WRKDIR}/enigmail ${WRKSRC}/mailnews/extensions/
${RUN} cd ${WRKSRC} && \
${PATCH} < ${FILESDIR}/mailnews_extensions_enigmail_ipc_modules_subprocess.jsm
post-configure: enigmail-post-configure
.PHONY: enigmail-post-configure

View file

@ -0,0 +1,14 @@
$NetBSD: mailnews_extensions_enigmail_ipc_modules_subprocess.jsm,v 1.1 2012/04/04 20:05:09 ryoon Exp $
--- mailnews/extensions/enigmail/ipc/modules/subprocess.jsm.orig 2012-02-09 16:50:47.000000000 +0000
+++ mailnews/extensions/enigmail/ipc/modules/subprocess.jsm
@@ -312,7 +312,9 @@ function getPlatformValue(valueType) {
// library name O_NONBLOCK RLIM_T RLIMIT_NOFILE
'darwin': [ 'libc.dylib', 0x04 , ctypes.uint64_t , 8 ],
'linux': [ 'libc.so.6', 2024 , ctypes.unsigned_long, 7 ],
+ 'dragonfly': [ 'libc.so', 0x04 , ctypes.int64_t , 8 ],
'freebsd': [ 'libc.so.7', 0x04 , ctypes.int64_t , 8 ],
+ 'netbsd': [ 'libc.so', 0x04 , ctypes.int64_t , 8 ],
'openbsd': [ 'libc.so.61.0', 0x04 , ctypes.int64_t , 8 ],
'sunos': [ 'libc.so', 0x80 , ctypes.unsigned_long, 5 ]
}