Use "cpuset_t" on FreeBSD, this lets the package build.
This commit is contained in:
parent
4525a69859
commit
9cc08a125a
3 changed files with 59 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.39 2013/11/30 12:34:52 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.40 2013/12/16 19:00:03 asau Exp $
|
||||
|
||||
SHA1 (pulseaudio-2.1.tar.xz) = 56b4ad9207ea3aec0ad1b8be4b55793b426a4f01
|
||||
RMD160 (pulseaudio-2.1.tar.xz) = 87f6051bbbe59c26e505a9765f388d3ee4d3a485
|
||||
|
@ -10,3 +10,5 @@ SHA1 (patch-src_Makefile.in) = 21daf6069ae067dd235de6d43a013e4e70bbca78
|
|||
SHA1 (patch-src_pulsecore_semaphore-osx.c) = f9b1962a700932434e05471b2d4df4a5ff5c1b00
|
||||
SHA1 (patch-src_pulsecore_svolume__mmx.c) = a3af18563fd11e3813d7a474ff8807ee9bf62390
|
||||
SHA1 (patch-src_pulsecore_svolume__sse.c) = 6d2406ad0889219bae96f52f9b525da9b19b9af9
|
||||
SHA1 (patch-src_tests_once-test.c) = ba0ca03e9f1cbc47e7985497397d03e7406420c6
|
||||
SHA1 (patch-src_tests_rtstutter.c) = e6d1627cb8a150cc5a106bb98ed31147ce8689d2
|
||||
|
|
28
audio/pulseaudio/patches/patch-src_tests_once-test.c
Normal file
28
audio/pulseaudio/patches/patch-src_tests_once-test.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-src_tests_once-test.c,v 1.1 2013/12/16 19:00:03 asau Exp $
|
||||
|
||||
--- src/tests/once-test.c.orig 2012-07-03 12:47:50.000000000 +0000
|
||||
+++ src/tests/once-test.c 2013-09-26 00:26:09.760505519 +0000
|
||||
@@ -25,6 +25,11 @@
|
||||
#include <pthread.h>
|
||||
#endif
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#include <sys/cpuset.h>
|
||||
+#endif
|
||||
+
|
||||
#include <pulsecore/thread.h>
|
||||
#include <pulsecore/once.h>
|
||||
#include <pulsecore/log.h>
|
||||
@@ -54,7 +59,11 @@
|
||||
|
||||
#ifdef HAVE_PTHREAD_SETAFFINITY_NP
|
||||
static pa_atomic_t i_cpu = PA_ATOMIC_INIT(0);
|
||||
+#if defined(__FreeBSD__)
|
||||
+ cpuset_t mask;
|
||||
+#else
|
||||
cpu_set_t mask;
|
||||
+#endif
|
||||
|
||||
CPU_ZERO(&mask);
|
||||
CPU_SET((size_t) (pa_atomic_inc(&i_cpu) % n_cpu), &mask);
|
28
audio/pulseaudio/patches/patch-src_tests_rtstutter.c
Normal file
28
audio/pulseaudio/patches/patch-src_tests_rtstutter.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-src_tests_rtstutter.c,v 1.1 2013/12/16 19:00:03 asau Exp $
|
||||
|
||||
--- src/tests/rtstutter.c.orig 2011-09-26 15:51:42.000000000 +0000
|
||||
+++ src/tests/rtstutter.c 2013-09-26 00:28:11.949504937 +0000
|
||||
@@ -32,6 +32,11 @@
|
||||
#include <pthread.h>
|
||||
#endif
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#include <sys/cpuset.h>
|
||||
+#endif
|
||||
+
|
||||
#include <pulse/util.h>
|
||||
#include <pulse/timeval.h>
|
||||
#include <pulse/gccmacro.h>
|
||||
@@ -54,7 +59,11 @@
|
||||
|
||||
#ifdef HAVE_PTHREAD_SETAFFINITY_NP
|
||||
{
|
||||
+#if defined(__FreeBSD__)
|
||||
+ cpuset_t mask;
|
||||
+#else
|
||||
cpu_set_t mask;
|
||||
+#endif
|
||||
|
||||
CPU_ZERO(&mask);
|
||||
CPU_SET((size_t) PA_PTR_TO_UINT(p), &mask);
|
Loading…
Reference in a new issue