Return a value in non-void functions.
This commit is contained in:
parent
5b31c503ca
commit
9cd075a474
2 changed files with 27 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/01/06 02:07:50 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/03/02 18:11:32 joerg Exp $
|
||||
|
||||
SHA1 (gamazons-0.83.tar.gz) = 62ef6bfaeaaf36a31f00377599feb286d489bb27
|
||||
RMD160 (gamazons-0.83.tar.gz) = 2fd9433846173a7bc53eb7abd9dfbf367460df5e
|
||||
Size (gamazons-0.83.tar.gz) = 258614 bytes
|
||||
SHA1 (patch-aa) = 9f2db32d979eace078aa0b871142d1c6c13e1d5b
|
||||
SHA1 (patch-src_callbacks.c) = cb3b8c77d9c49c1517020e25e740d632d88c7305
|
||||
|
|
25
games/gamazons/patches/patch-src_callbacks.c
Normal file
25
games/gamazons/patches/patch-src_callbacks.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-src_callbacks.c,v 1.1 2013/03/02 18:11:33 joerg Exp $
|
||||
|
||||
--- src/callbacks.c.orig 2013-03-01 12:27:35.000000000 +0000
|
||||
+++ src/callbacks.c
|
||||
@@ -359,17 +359,17 @@ int board_press_cb (GnomeCanvasItem *ite
|
||||
if (bstate_get_moving_piece())
|
||||
{
|
||||
//printf("Can't do that while a piece is moving\n");
|
||||
- return;
|
||||
+ return 0;
|
||||
}
|
||||
if (bstate_get_open_dialog())
|
||||
{
|
||||
//printf("Can't do that while another window is open\n");
|
||||
- return;
|
||||
+ return 0;
|
||||
}
|
||||
if (bstate_get_what_next() == NEW_GAME)
|
||||
{
|
||||
//printf("Can't do that while I'm expecting a new game to start\n");
|
||||
- return;
|
||||
+ return 0;
|
||||
}
|
||||
if (bstate_get_replay_mode())
|
||||
return 0;
|
Loading…
Reference in a new issue