Restructure the following packages:
editors/xemacs editors/xemacs-nox11 The latter is now just editors/xemacs built with a specific set of options. Changes include: + Add support for the following new options in options.mk: x11 Support X11 displays lucid Use Lucid widget set Also add commented out support for the following options for alternative widget sets: gtk GTK widgets motif Motif widgets xaw Athena widgets Note that USE_ATHENA, USE_GTK, and USE_MOTIF are legacy variables for the corresponding options. + Remove Makefile.common and move all logic into xemacs/Makefile and xemacs/options.mk. + Rename the "mule" PLIST variable to "canna", which more accurately reflects what is conditionally installed. + Include termcap.buildlink3.mk to properly deal with termcap/curses issues (xemacs needs termcap). Drop the --with-ncurses=no setting as the issue is handled by termcap.buildlink3.mk. + In xemacs/Makefile, we don't need separate EXTRACT_ONLY and EXTRA_FILES if we're actually going to extract all of those files all of the time. Just list them all in DISTFILES. + Be slightly more aware of ${X11_TYPE} == "modular" by not referring to ${X11BASE} in that case. + In patch-ak, directly substitute the local value of etcdir (``../etc/'') into src/Makefile.in.in. This allows for overriding etcdir via INSTALL_MAKE_FLAGS at install-time so that destdir-style installation will work. + Support DESTDIR installation by adding INSTALL_MAKE_FLAGS to override where files are installed during the install phase. + Honor PKGMANDIR. + Bump the PKGREVISION for xemacs and xemacs-nox11 to 4. Both packages now track and use the same PKGREVISION number.
This commit is contained in:
parent
adee5dd001
commit
9cde120028
8 changed files with 263 additions and 188 deletions
|
@ -1,21 +0,0 @@
|
|||
XEmacs is a self-documenting, customizable, extensible real-time
|
||||
display editor.
|
||||
|
||||
Users new to XEmacs will be able to use basic features fairly rapidly
|
||||
by studying the tutorial and using the self-documentation features.
|
||||
XEmacs also has an extensive interactive manual browser. It is easily
|
||||
extensible since its editing commands are written in Lisp.
|
||||
|
||||
XEmacs's many special packages handle mail reading (RMail) and sending
|
||||
(Mail), outline editing (Outline), compiling (Compile), running
|
||||
subshells within Emacs windows (Shell), running a Lisp read-eval-print
|
||||
loop (Lisp-Interaction-Mode), automated psychotherapy (Doctor :-) and
|
||||
many more. There is a WWW browsing mode written fully in elisp
|
||||
that looks and behaves much like the netscape WWW browser.
|
||||
|
||||
XEmacs has similar functionality to GNU Emacs. It uses a different
|
||||
display model, including support for Motif menu and scroll bars and the
|
||||
ability to run as a widget inside other applications. Many people say
|
||||
it looks nicer than GNU Emacs.
|
||||
|
||||
Web site: http://www.xemacs.org
|
|
@ -1,26 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.19 2008/04/12 22:43:00 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2008/04/24 15:32:16 jlam Exp $
|
||||
|
||||
.include "../../editors/xemacs/Makefile.common"
|
||||
PKGNAME= ${DISTNAME:S/-/-nox11-/}
|
||||
|
||||
PKGNAME= ${DISTNAME:S/xemacs/xemacs-nox11/}
|
||||
PKGREVISION= 2
|
||||
FILESDIR= ${.CURDIR}/../../editors/xemacs/files
|
||||
PATCHDIR= ${.CURDIR}/../../editors/xemacs/patches
|
||||
PKGDIR= ${.CURDIR}/../../editors/xemacs
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
# Mirror PKG_DESTDIR_SUPPORT setting from xemacs/Makefile.
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
CONFLICTS= xemacs-[0-9]*
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PLIST_SRC= ${.CURDIR}/../xemacs/PLIST
|
||||
DISTINFO_FILE= ${.CURDIR}/../xemacs/distinfo
|
||||
FILESDIR= ${.CURDIR}/../xemacs/files
|
||||
PATCHDIR= ${.CURDIR}/../xemacs/patches
|
||||
PKG_OPTIONS.xemacs+= -x11 -lucid
|
||||
#PKG_OPTIONS.xemacs+= -gtk -motif -xaw
|
||||
|
||||
CONFIGURE_ARGS+= --without-x11 # XXX -nox
|
||||
CONFIGURE_ARGS+= --without-jpeg # XXX -nox
|
||||
CONFIGURE_ARGS+= --without-png # XXX -nox
|
||||
CONFIGURE_ARGS+= --without-tiff # XXX -nox
|
||||
CONFIGURE_ARGS+= --without-xpm # XXX -nox
|
||||
CONFIGURE_ARGS+= --site-includes=${BUILDLINK_DIR}/include
|
||||
CONFIGURE_ARGS+= --site-libraries=${BUILDLINK_DIR}/lib
|
||||
CONFIGURE_ARGS+= --site-runtime-libraries=${LOCALBASE}/lib
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
.include "../../editors/xemacs/Makefile"
|
||||
|
|
|
@ -1,19 +1,105 @@
|
|||
# $NetBSD: Makefile,v 1.84 2008/04/12 22:43:00 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.85 2008/04/24 15:32:15 jlam Exp $
|
||||
|
||||
.include "../../editors/xemacs/Makefile.common"
|
||||
PKGNAME?= ${DISTNAME}
|
||||
COMMENT?= XEmacs text editor version 21
|
||||
|
||||
DISTNAME= xemacs-21.4.17
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_XEMACS:=xemacs-21.4/}
|
||||
DISTFILES= ${DISTNAME}.tar.gz ${DISTNAME}-elc.tar.gz \
|
||||
${DISTNAME}-info.tar.gz
|
||||
|
||||
MAINTAINER= uebayasi@NetBSD.org
|
||||
PKGREVISION= 3
|
||||
HOMEPAGE= http://www.xemacs.org/
|
||||
|
||||
CONFIGURE_ARGS+= --site-includes=${BUILDLINK_DIR}/include:${BUILDLINK_X11_DIR}/include
|
||||
CONFIGURE_ARGS+= --site-libraries=${BUILDLINK_DIR}/lib:${BUILDLINK_X11_DIR}
|
||||
CONFIGURE_ARGS+= --site-runtime-libraries=${LOCALBASE}/lib:${X11BASE}/lib
|
||||
CONFLICTS+= gnuserv-[0-9]*
|
||||
CONFLICTS+= xemacs-[0-9]*
|
||||
CONFLICTS+= xemacs-nox11-[0-9]*
|
||||
|
||||
PLIST.x11= yes
|
||||
NOT_FOR_PLATFORM= *-*-mips* # fails purespace dumping
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
DIST_SUBDIR= xemacs
|
||||
PLIST_SUBST+= DISTNAME=${DISTNAME:Q}
|
||||
FILES_SUBST+= DISTNAME=${DISTNAME:Q}
|
||||
MESSAGE_SUBST+= DISTNAME=${DISTNAME:Q}
|
||||
INFO_FILES= # PLIST
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
CONFIGURE_ARGS+= ${MACHINE_GNU_PLATFORM}
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
CONFIGURE_ARGS+= --mandir=${PREFIX:Q}/${PKGMANDIR:Q}/man1
|
||||
CONFIGURE_ARGS+= --with-clash-detection
|
||||
CONFIGURE_ARGS+= --with-mule=yes
|
||||
CONFIGURE_ARGS+= --with-msw=no
|
||||
CFLAGS+= -Dunix
|
||||
|
||||
.if ${X11_TYPE} != "modular"
|
||||
INFOPATH= ${PREFIX}/${PKGINFODIR}:${X11BASE}/${PKGINFODIR}:${LOCALBASE}/${PKGINFODIR}
|
||||
.else
|
||||
INFOPATH= ${PREFIX}/${PKGINFODIR}:${LOCALBASE}/${PKGINFODIR}
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --infopath=${INFOPATH:Q}
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
. if !exists(/usr/demo/SOUND/libaudio.a) && \
|
||||
!exists(/usr/demo/SOUND/lib/libaudio.a)
|
||||
CONFIGURE_ARGS+= --with_sound=none
|
||||
. endif
|
||||
.endif
|
||||
|
||||
.if (${OPSYS} == "DragonFly") && exists(/usr/lib/crtbegin.o)
|
||||
CPPFLAGS+= -DDFLY_PRE_17_CRT
|
||||
.endif
|
||||
|
||||
CHECK_WRKREF_SKIP= bin/xemacs*
|
||||
REPLACE_SH= etc/check_cygwin_setup.sh
|
||||
|
||||
LIBDIR= ${PREFIX}/lib/${DISTNAME}
|
||||
ARCHLIBDIR= ${LIBDIR}/${MACHINE_GNU_PLATFORM}
|
||||
|
||||
# This list overrides variables used in the source Makefiles at install
|
||||
# time to allow for ${DESTDIR}-style installation. This variables list
|
||||
# is pulled from the ``mkdir'' target of Makefile.in.in.
|
||||
#
|
||||
INSTALL_MAKE_FLAGS+= archlibdir=${DESTDIR}${ARCHLIBDIR}
|
||||
INSTALL_MAKE_FLAGS+= bindir=${DESTDIR}${PREFIX}/bin
|
||||
INSTALL_MAKE_FLAGS+= datadir=${DESTDIR}${PREFIX}/lib
|
||||
INSTALL_MAKE_FLAGS+= docdir=${DESTDIR}${ARCHLIBDIR}
|
||||
INSTALL_MAKE_FLAGS+= etcdir=${DESTDIR}${LIBDIR}/etc
|
||||
INSTALL_MAKE_FLAGS+= exec_prefix=${DESTDIR}${PREFIX}
|
||||
INSTALL_MAKE_FLAGS+= infodir=${DESTDIR}${LIBDIR}/info
|
||||
INSTALL_MAKE_FLAGS+= libdir=${DESTDIR}/lib
|
||||
INSTALL_MAKE_FLAGS+= lispdir=${DESTDIR}${LIBDIR}/lisp
|
||||
INSTALL_MAKE_FLAGS+= mandir=${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
INSTALL_MAKE_FLAGS+= moduledir=${DESTDIR}${ARCHLIBDIR}/modules
|
||||
INSTALL_MAKE_FLAGS+= pkgdir=${DESTDIR}${LIBDIR}/lisp
|
||||
INSTALL_MAKE_FLAGS+= prefix=${DESTDIR}${PREFIX}
|
||||
INSTALL_MAKE_FLAGS+= sitelispdir=${DESTDIR}${PREFIX}/lib/xemacs/site-lisp
|
||||
INSTALL_MAKE_FLAGS+= sitemoduledir=${DESTDIR}${PREFIX}/lib/xemacs/site-modules
|
||||
|
||||
post-extract:
|
||||
cp ${FILESDIR}/dragonfly.h ${WRKSRC}/src/s/
|
||||
|
||||
pre-build:
|
||||
rm -f ${WRKSRC}/etc/ctags.1.orig
|
||||
|
||||
.if defined(MANZ)
|
||||
PLIST_SUBST+= ELSUFX='.gz'
|
||||
.else
|
||||
PLIST_SUBST+= ELSUFX=''
|
||||
|
||||
post-install:
|
||||
find ${DESTDIR}${LIBDIR} -name "*.el" -type f -print | xargs ${GZIP_CMD}
|
||||
.endif
|
||||
|
||||
.include "../../databases/gdbm/buildlink3.mk"
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
|
||||
.include "../../graphics/jpeg/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../graphics/tiff/buildlink3.mk"
|
||||
.include "../../x11/libXpm/buildlink3.mk"
|
||||
.include "../../x11/xbitmaps/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,122 +0,0 @@
|
|||
# $NetBSD: Makefile.common,v 1.20 2008/04/12 22:43:00 jlam Exp $
|
||||
|
||||
DISTNAME= xemacs-21.4.17
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_XEMACS:=xemacs-21.4/}
|
||||
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_FILES}
|
||||
|
||||
HOMEPAGE= http://www.xemacs.org/
|
||||
COMMENT= XEmacs text editor version 21
|
||||
|
||||
CONFLICTS+= gnuserv-[0-9]*
|
||||
|
||||
NOT_FOR_PLATFORM= *-*-mips* # fails purespace dumping
|
||||
|
||||
USE_TOOLS+= gtar
|
||||
|
||||
DIST_SUBDIR= xemacs
|
||||
EXTRA_FILES= ${DISTNAME}-elc.tar.gz ${DISTNAME}-info.tar.gz
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
PLIST_VARS+= x11
|
||||
PLIST_SUBST+= DISTNAME=${DISTNAME:Q}
|
||||
FILES_SUBST+= DISTNAME=${DISTNAME:Q}
|
||||
MESSAGE_SUBST+= DISTNAME="${DISTNAME}"
|
||||
INFO_FILES= # PLIST
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
# XXX GUI configuration is a mess...
|
||||
#
|
||||
#.if defined(USE_ATHENA)
|
||||
#WITH_DIALOGS= \
|
||||
# --with-menubars=athena \
|
||||
# --with-scrollbars=athena \
|
||||
# --with-dialogs=athena \
|
||||
# --with-widgets=athena \
|
||||
# --with-athena=xaw \
|
||||
# --with-xim=xlib
|
||||
#.include "../../mk/xaw.buildlink3.mk"
|
||||
#.elif defined(USE_MOTIF)
|
||||
#WITH_DIALOGS= \
|
||||
# --with-menubars=motif \
|
||||
# --with-scrollbars=motif \
|
||||
# --with-dialogs=motif \
|
||||
# --with-widgets=motif \
|
||||
# --with-xim=motif
|
||||
#.include "../../mk/motif.buildlink3.mk"
|
||||
#.elif defined(USE_GTK)
|
||||
#WITH_DIALOGS= \
|
||||
# --with-gtk \
|
||||
# --with-menubars=yes \
|
||||
# --with-scrollbars=yes \
|
||||
# --with-dialogs=yes \
|
||||
# --with-widgets=yes \
|
||||
# --with-xim=yes
|
||||
#.include "../../x11/gtk/buildlink3.mk"
|
||||
#.else
|
||||
# XXX Default is "lucid". Due to the output of `configure --help', Lucid
|
||||
# widgets wrap Athena, so xaw.buildlink3.mk.
|
||||
WITH_DIALOGS= \
|
||||
--with-toolbars=yes \
|
||||
--with-menubars=lucid \
|
||||
--with-scrollbars=lucid \
|
||||
--with-dialogs=lucid \
|
||||
--with-widgets=lucid \
|
||||
--with-athena=xaw \
|
||||
--with-xim=xlib
|
||||
.include "../../mk/xaw.buildlink3.mk"
|
||||
#.endif
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
. if !exists(/usr/demo/SOUND/libaudio.a) && !exists(/usr/demo/SOUND/lib/libaudio.a)
|
||||
CONFIGURE_ARGS+= --with_sound=none
|
||||
. endif
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "DragonFly" && exists(/usr/lib/crtbegin.o)
|
||||
CPPFLAGS+= -DDFLY_PRE_17_CRT
|
||||
.endif
|
||||
|
||||
.if defined(MANZ)
|
||||
PLIST_SUBST+= ELSUFX='.gz'
|
||||
.else
|
||||
PLIST_SUBST+= ELSUFX=''
|
||||
.endif
|
||||
|
||||
.include "../../databases/gdbm/buildlink3.mk"
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
|
||||
INFOPATH= ${PREFIX}/${PKGINFODIR}:${X11BASE}/${PKGINFODIR}:${LOCALBASE}/${PKGINFODIR}
|
||||
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= ${MACHINE_GNU_PLATFORM}
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
CONFIGURE_ARGS+= --with-clash-detection
|
||||
CONFIGURE_ARGS+= --with-mule=yes
|
||||
.if ${OPSYS} != "Linux"
|
||||
CONFIGURE_ARGS+= --with-ncurses=no
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --with-msw=no
|
||||
CONFIGURE_ARGS+= ${WITH_DIALOGS}
|
||||
CONFIGURE_ARGS+= --infopath=${INFOPATH:Q}
|
||||
|
||||
CFLAGS+= -Dunix
|
||||
|
||||
CHECK_WRKREF_SKIP= bin/xemacs*
|
||||
|
||||
post-extract:
|
||||
@for f in ${EXTRA_FILES}; do \
|
||||
${GTAR} xzCf ${WRKDIR} ${DISTDIR}/${DIST_SUBDIR}/$$f; \
|
||||
done
|
||||
${CP} ${FILESDIR}/dragonfly.h ${WRKSRC}/src/s/
|
||||
|
||||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/etc/ctags.1.orig
|
||||
|
||||
post-install:
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/${DISTNAME}
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/lib/xemacs
|
||||
.if defined(MANZ)
|
||||
${FIND} ${PREFIX}/lib/${DISTNAME} -name "*.el" -type f -print | \
|
||||
${XARGS} ${GZIP_CMD}
|
||||
.endif
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.15 2008/04/12 22:43:00 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.16 2008/04/24 15:32:15 jlam Exp $
|
||||
bin/${DISTNAME}
|
||||
bin/ellcc
|
||||
bin/gnuattach
|
||||
|
@ -1040,7 +1040,7 @@ lib/${DISTNAME}/lisp/mule/arabic.elc
|
|||
lib/${DISTNAME}/lisp/mule/auto-autoloads.el${ELSUFX}
|
||||
lib/${DISTNAME}/lisp/mule/auto-autoloads.elc
|
||||
lib/${DISTNAME}/lisp/mule/canna-leim.el${ELSUFX}
|
||||
${PLIST.mule}lib/${DISTNAME}/lisp/mule/canna-leim.elc
|
||||
${PLIST.canna}lib/${DISTNAME}/lisp/mule/canna-leim.elc
|
||||
lib/${DISTNAME}/lisp/mule/chinese.el${ELSUFX}
|
||||
lib/${DISTNAME}/lisp/mule/chinese.elc
|
||||
lib/${DISTNAME}/lisp/mule/custom-load.el${ELSUFX}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2007/02/15 14:27:48 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.12 2008/04/24 15:32:15 jlam Exp $
|
||||
|
||||
SHA1 (xemacs/xemacs-21.4.17.tar.gz) = 274812bee5f8010ca3d56b517026270d94415f33
|
||||
RMD160 (xemacs/xemacs-21.4.17.tar.gz) = d42ca370ba916f0147b368bd7db2cc6c523646ae
|
||||
|
@ -17,6 +17,6 @@ SHA1 (patch-ae) = c3ad7249bb7eb51c509546fc88fe3efc5b70a6d7
|
|||
SHA1 (patch-af) = 97cd3d340f349a645a7be9a683879528d9f4c5f2
|
||||
SHA1 (patch-ah) = 9a02b989a6d45cdfead22ea703acceca722cf313
|
||||
SHA1 (patch-ai) = ea752473a56d20907201763966ecdeaaeffac84a
|
||||
SHA1 (patch-ak) = 240daa4996d51fe754e6fe46f2577f9112febe3c
|
||||
SHA1 (patch-ak) = bfbd285a1cc7d4e93a2fc884e03492dec9302e55
|
||||
SHA1 (patch-al) = 247826009110453a868525e711e084b7dee49664
|
||||
SHA1 (patch-am) = b7dc4c12b7d40ba12c6b82f9fc211a70877f85e7
|
||||
|
|
|
@ -1,11 +1,39 @@
|
|||
# $NetBSD: options.mk,v 1.7 2008/04/12 22:43:00 jlam Exp $
|
||||
# $NetBSD: options.mk,v 1.8 2008/04/24 15:32:15 jlam Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.xemacs
|
||||
PKG_SUPPORTED_OPTIONS= ldap xface canna
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.xemacs
|
||||
PKG_SUPPORTED_OPTIONS= ldap xface canna x11
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS= toolkit
|
||||
PKG_OPTIONS_GROUP.toolkit= lucid
|
||||
|
||||
# GUI configuration is a mess... only support "lucid" for now.
|
||||
#PKG_OPTIONS_GROUP.toolkit+= gtk motif xaw
|
||||
#PKG_OPTIONS_LEGACY_VARS+= USE_ATHENA:xaw
|
||||
#PKG_OPTIONS_LEGACY_VARS+= USE_GTK:gtk
|
||||
#PKG_OPTIONS_LEGACY_VARS+= USE_MOTIF:motif
|
||||
|
||||
PKG_SUGGESTED_OPTIONS= x11
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= mule
|
||||
###
|
||||
### Any of the "toolkit" options implies "x11".
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mgtk) || !empty(PKG_OPTIONS:Mlucid) || \
|
||||
!empty(PKG_OPTIONS:Mmotif) || !empty(PKG_OPTIONS:Mxaw)
|
||||
. if empty(PKG_OPTIONS:Mx11)
|
||||
PKG_OPTIONS+= x11
|
||||
. endif
|
||||
.endif
|
||||
|
||||
###
|
||||
### Default to using the Lucid X11 toolkit if none is specified.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
. if empty(PKG_OPTIONS:Mgtk) && empty(PKG_OPTIONS:Mlucid) && \
|
||||
empty(PKG_OPTIONS:Mmotif) && empty(PKG_OPTIONS:Mxaw)
|
||||
PKG_OPTIONS+= lucid
|
||||
. endif
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mldap)
|
||||
CONFIGURE_ARGS+= --with-ldap
|
||||
|
@ -21,10 +49,105 @@ CONFIGURE_ARGS+= --with-xface
|
|||
CONFIGURE_ARGS+= --without-xface
|
||||
.endif
|
||||
|
||||
PLIST_VARS+= canna
|
||||
.if !empty(PKG_OPTIONS:Mcanna)
|
||||
. include "../../inputmethod/canna-lib/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-canna
|
||||
PLIST.mule= yes
|
||||
PLIST.canna= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-canna
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support drawing pretty X11 widgets.
|
||||
###
|
||||
PLIST_VARS+= x11
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
. include "../../graphics/jpeg/buildlink3.mk"
|
||||
. include "../../graphics/png/buildlink3.mk"
|
||||
. include "../../graphics/tiff/buildlink3.mk"
|
||||
. include "../../x11/libXpm/buildlink3.mk"
|
||||
. include "../../x11/xbitmaps/buildlink3.mk"
|
||||
PLIST.x11= yes
|
||||
CONFIGURE_ARGS+= --with-x
|
||||
CONFIGURE_ARGS+= --with-jpeg
|
||||
CONFIGURE_ARGS+= --with-png
|
||||
CONFIGURE_ARGS+= --with-tiff
|
||||
CONFIGURE_ARGS+= --with-xpm
|
||||
CONFIGURE_ARGS+= --site-includes=${SITE_INCLUDES:Q}
|
||||
CONFIGURE_ARGS+= --site-libraries=${SITE_LIBRARIES:Q}
|
||||
CONFIGURE_ARGS+= --site-runtime-libraries=${SITE_RUNTIME_LIBRARIES:Q}
|
||||
. if ${X11_TYPE} != "modular"
|
||||
SITE_INCLUDES= ${BUILDLINK_DIR}/include:${BUILDLINK_X11_DIR}/include
|
||||
SITE_LIBRARIES= ${BUILDLINK_DIR}/lib:${BUILDLINK_X11_DIR}/lib
|
||||
SITE_RUNTIME_LIBRARIES= ${PREFIX}/lib:${X11BASE}/lib
|
||||
. else
|
||||
SITE_INCLUDES= ${BUILDLINK_DIR}/include
|
||||
SITE_LIBRARIES= ${BUILDLINK_DIR}/lib
|
||||
SITE_RUNTIME_LIBRARIES= ${PREFIX}/lib
|
||||
. endif
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
CONFIGURE_ARGS+= --without-jpeg
|
||||
CONFIGURE_ARGS+= --without-png
|
||||
CONFIGURE_ARGS+= --without-tiff
|
||||
CONFIGURE_ARGS+= --without-xpm
|
||||
CONFIGURE_ARGS+= --site-includes=${SITE_INCLUDES:Q}
|
||||
CONFIGURE_ARGS+= --site-libraries=${SITE_LIBRARIES:Q}
|
||||
CONFIGURE_ARGS+= --site-runtime-libraries=${SITE_RUNTIME_LIBRARIES:Q}
|
||||
SITE_INCLUDES= ${BUILDLINK_DIR}/include
|
||||
SITE_LIBRARIES= ${BUILDLINK_DIR}/lib
|
||||
SITE_RUNTIME_LIBRARIES= ${PREFIX}/lib
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support using GTK X11 widgets.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mgtk)
|
||||
. include "../../x11/gtk/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-gtk
|
||||
CONFIGURE_ARGS+= --with-menubars=yes
|
||||
CONFIGURE_ARGS+= --with-scrollbars=yes
|
||||
CONFIGURE_ARGS+= --with-dialogs=yes
|
||||
CONFIGURE_ARGS+= --with-widgets=yes
|
||||
CONFIGURE_ARGS+= --with-xim=yes
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support using Lucid X11 widgets.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mlucid)
|
||||
. include "../../mk/xaw.buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-toolbars=yes
|
||||
CONFIGURE_ARGS+= --with-menubars=yes
|
||||
CONFIGURE_ARGS+= --with-scrollbars=lucid
|
||||
CONFIGURE_ARGS+= --with-dialogs=lucid
|
||||
CONFIGURE_ARGS+= --with-widgets=lucid
|
||||
CONFIGURE_ARGS+= --with-athena=xaw
|
||||
CONFIGURE_ARGS+= --with-xim=xlib
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support using Motif X11 widgets.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mmotif)
|
||||
. include "../../mk/motif.buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-menubars=motif
|
||||
CONFIGURE_ARGS+= --with-scrollbars=motif
|
||||
CONFIGURE_ARGS+= --with-dialogs=motif
|
||||
CONFIGURE_ARGS+= --with-widgets=motif
|
||||
CONFIGURE_ARGS+= --with-xim=motif
|
||||
.endif
|
||||
|
||||
###
|
||||
### Support using Athena X11 widgets.
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mxaw)
|
||||
. include "../../mk/xaw.buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --with-menubars=athena
|
||||
CONFIGURE_ARGS+= --with-scrollbars=athena
|
||||
CONFIGURE_ARGS+= --with-dialogs=athena
|
||||
CONFIGURE_ARGS+= --with-widgets=athena
|
||||
CONFIGURE_ARGS+= --with-athena=xaw
|
||||
CONFIGURE_ARGS+= --with-xim=xlib
|
||||
.endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ak,v 1.4 2003/02/25 02:14:59 uebayasi Exp $
|
||||
$NetBSD: patch-ak,v 1.5 2008/04/24 15:32:15 jlam Exp $
|
||||
|
||||
--- src/Makefile.in.in.orig Wed Jan 15 21:18:00 2003
|
||||
--- src/Makefile.in.in.orig 2005-01-30 21:55:02.000000000 -0500
|
||||
+++ src/Makefile.in.in
|
||||
@@ -72,8 +72,8 @@
|
||||
@@ -72,8 +72,8 @@ CPPFLAGS=@CPPFLAGS@
|
||||
LDFLAGS=@LDFLAGS@
|
||||
|
||||
c_switch_all=@c_switch_all@
|
||||
|
@ -13,7 +13,7 @@ $NetBSD: patch-ak,v 1.4 2003/02/25 02:14:59 uebayasi Exp $
|
|||
ld_dynamic_link_flags=@ld_dynamic_link_flags@
|
||||
|
||||
extra_objs=@extra_objs@
|
||||
@@ -162,9 +162,9 @@
|
||||
@@ -163,9 +163,9 @@ ldflags += -Wl,--script=s/cygwin.sc
|
||||
|
||||
#ifdef SOLARIS2
|
||||
%.o : %.c
|
||||
|
@ -25,3 +25,21 @@ $NetBSD: patch-ak,v 1.4 2003/02/25 02:14:59 uebayasi Exp $
|
|||
$(CC) -c $(cflags) $<
|
||||
|
||||
## Create preprocessor output (debugging purposes only)
|
||||
@@ -329,7 +329,7 @@ othersrcs = $(otherobjs:.o=.c)
|
||||
LIBES = $(lwlib_libs) $(malloclib) $(ld_libs_all) $(lib_gcc)
|
||||
|
||||
#ifdef I18N3
|
||||
-mo_dir = ${etcdir}
|
||||
+mo_dir = ../etc/
|
||||
mo_file = ${mo_dir}emacs.mo
|
||||
#endif
|
||||
|
||||
@@ -658,7 +658,7 @@ libextcli_Xlib.so.1: ${external_client_x
|
||||
#endif /* EXTERNAL_WIDGET */
|
||||
|
||||
config.h: ${srcdir}/config.h.in
|
||||
-Emacs.ad.h: ${srcdir}/${etcdir}Emacs.ad
|
||||
+Emacs.ad.h: ${srcdir}/../etc/Emacs.ad
|
||||
|
||||
config.h sheap-adjust.h paths.h Emacs.ad.h :
|
||||
@echo "The file $@ needs to be re-generated."
|
||||
|
|
Loading…
Reference in a new issue