Fix missing includes for some inline functions in the files they are

used. Remove crude -O0 hack that makes ld explode.
This commit is contained in:
joerg 2015-07-23 11:10:49 +00:00
parent d139da03b7
commit 9ce4937842
5 changed files with 41 additions and 20 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.47 2015/07/12 21:50:12 wiz Exp $
# $NetBSD: Makefile.common,v 1.48 2015/07/23 11:10:49 joerg Exp $
# used by www/webkit-gtk/Makefile
DISTNAME= webkitgtk-2.8.4
@ -52,24 +52,6 @@ PYTHON_VERSIONS_INCOMPATIBLE= 33 34 # not yet ported as of 1.10.2
.include "../../lang/python/application.mk"
CMAKE_ARGS+= -DPYTHON_EXECUTABLE=${PYTHONBIN}
#
# XXX: Turning -O options with gcc-4.8.4 does not work on NetBSD. Disable
# optimization, according to the gcc(1) manual page:
#
# If you use multiple -O options, with or without level numbers, the
# last such option is the one that is effective.
#
# Fixes build problem on NetBSD of this type:
# Linking CXX shared library ../../lib/libjavascriptcoregtk-4.0.so
# CMakeFiles/JavaScriptCore.dir/runtime/FunctionExecutableDump.cpp.o: In function `JSC::FunctionExecutableDump::dump(WTF::PrintStream&) const':
# FunctionExecutableDump.cpp:(.text+0x61): undefined reference to `JSC::JSCell::inherits(JSC::ClassInfo const*) const'
# CMakeFiles/JavaScriptCore.dir/llint/LLIntEntrypoint.cpp.o: In function `JSC::LLInt::setEntrypoint(JSC::VM&, JSC::CodeBlock*)':
# LLIntEntrypoint.cpp:(.text+0x9d): undefined reference to `JSC::JSCell::inherits(JSC::ClassInfo const*) const'
# Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/build.make:13652: recipe for target 'lib/libjavascriptcoregtk-4.0.so.18.1.11' failed
#
# last checked for 2.8.4.
CFLAGS+= -O0
CXXFLAGS.SunOS+= -fpermissive
.include "../../mk/compiler.mk"

View file

@ -1,15 +1,18 @@
$NetBSD: distinfo,v 1.78 2015/07/14 00:02:34 khorben Exp $
$NetBSD: distinfo,v 1.79 2015/07/23 11:10:49 joerg Exp $
SHA1 (webkitgtk-2.8.4.tar.xz) = 127ee45bab6bbd9da1a9f63ec070d8cc06b40652
RMD160 (webkitgtk-2.8.4.tar.xz) = 4ad3b443a44275cac65d812ef3e53a355847f890
Size (webkitgtk-2.8.4.tar.xz) = 10446180 bytes
SHA1 (patch-Source_JavaScriptCore_assembler_MacroAssemblerARM.cpp) = 1f4a4be3593f9aa9ae6b41a2be8ae9d8bb27dcbb
SHA1 (patch-Source_JavaScriptCore_dfg_DFGNode.h) = 2b7e69b8e6aff9bd5f65190f8eb1afdbb993857f
SHA1 (patch-Source_JavaScriptCore_llint_LLIntEntrypoint.cpp) = 7daa228f96db55227a664dba3abc692b71e7ad18
SHA1 (patch-Source_JavaScriptCore_runtime_FunctionExecutableDump.cpp) = c86f461f67a6a31b7eb59c9b6a8d0c87ea7e98e5
SHA1 (patch-Source_ThirdParty_gtest_include_gtest_internal_gtest-port.h) = f1eee7f9d3012edee1915234c837cff820f97092
SHA1 (patch-Source_WTF_wtf_MathExtras.h) = 925d653feaa204b5128d389959328cdf559f26d3
SHA1 (patch-Source_WTF_wtf_Platform.h) = 2d2bd30ded91c8572e0c220c432ac4094289371b
SHA1 (patch-Source_WTF_wtf_Stopwatch.h) = 25bc1552a10a5724cbf261d05c0202c153fd69f7
SHA1 (patch-Source_WebCore_bindings_js_JSInspectorFrontendHostCustom.cpp) = 3707a87994d941d5f147f797d7d0be1b45bea591
SHA1 (patch-Source_WebCore_editing_InsertNodeBeforeCommand.cpp) = 14dc3ca4a4831d8f26a878be42310648713feead
SHA1 (patch-Source_cmake_OptionsGTK.cmake) = 599ed6188b632e78774fd833e3ea9e1a1acf8a2d
SHA1 (patch-ai) = 4b02898c650564fbf7b586652a13a1775a4d4748
SHA1 (patch-aj) = 84b0928c17460848fb51f255f6f68057ef768574

View file

@ -0,0 +1,12 @@
$NetBSD: patch-Source_JavaScriptCore_llint_LLIntEntrypoint.cpp,v 1.1 2015/07/23 11:10:49 joerg Exp $
--- Source/JavaScriptCore/llint/LLIntEntrypoint.cpp.orig 2015-07-22 11:57:53.000000000 +0000
+++ Source/JavaScriptCore/llint/LLIntEntrypoint.cpp
@@ -28,6 +28,7 @@
#include "CodeBlock.h"
#include "HeapInlines.h"
#include "JITCode.h"
+#include "JSCellInlines.h"
#include "JSObject.h"
#include "LLIntThunks.h"
#include "LowLevelInterpreter.h"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-Source_JavaScriptCore_runtime_FunctionExecutableDump.cpp,v 1.1 2015/07/23 11:10:49 joerg Exp $
--- Source/JavaScriptCore/runtime/FunctionExecutableDump.cpp.orig 2015-07-22 11:57:35.000000000 +0000
+++ Source/JavaScriptCore/runtime/FunctionExecutableDump.cpp
@@ -25,6 +25,7 @@
#include "config.h"
#include "FunctionExecutableDump.h"
+#include "JSCellInlines.h"
#include "CodeBlock.h"

View file

@ -0,0 +1,12 @@
$NetBSD: patch-Source_WebCore_editing_InsertNodeBeforeCommand.cpp,v 1.1 2015/07/23 11:10:49 joerg Exp $
--- Source/WebCore/editing/InsertNodeBeforeCommand.cpp.orig 2015-07-22 12:33:49.000000000 +0000
+++ Source/WebCore/editing/InsertNodeBeforeCommand.cpp
@@ -29,6 +29,7 @@
#include "AXObjectCache.h"
#include "Document.h"
#include "ExceptionCodePlaceholder.h"
+#include "RenderElement.h"
#include "htmlediting.h"
namespace WebCore {