update to 0.8.10
changes: -portability/build system improvements (Windows/QNX) -API extensions -minor bugfixes -improved builtin sanity checks
This commit is contained in:
parent
37836fbbc2
commit
9ce7cd7c74
5 changed files with 65 additions and 11 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.6 2006/11/16 22:04:21 reed Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2007/10/11 18:53:12 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libelf-0.8.5
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libelf-0.8.10
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.mr511.de/software/ \
|
||||
${MASTER_SITE_SUNSITE:=libs/}
|
||||
|
@ -12,6 +11,7 @@ COMMENT= ELF object file access library
|
|||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --disable-shared
|
||||
CONFIGURE_ARGS+= --disable-compat
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2004/08/13 07:09:01 cube Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2007/10/11 18:53:12 drochner Exp $
|
||||
include/libelf/elf_repl.h
|
||||
include/libelf/gelf.h
|
||||
include/libelf/libelf.h
|
||||
include/libelf/nlist.h
|
||||
include/libelf/sys_elf.h
|
||||
lib/libelf.a
|
||||
lib/libelf.la
|
||||
lib/pkgconfig/libelf.pc
|
||||
@dirrm include/libelf
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.5 2006/07/08 23:10:44 jlam Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.6 2007/10/11 18:53:12 drochner Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
LIBELF_BUILDLINK3_MK:= ${LIBELF_BUILDLINK3_MK}+
|
||||
|
@ -14,7 +14,6 @@ BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}libelf
|
|||
.if !empty(LIBELF_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_API_DEPENDS.libelf+= libelf>=0.8.5
|
||||
BUILDLINK_PKGSRCDIR.libelf?= ../../devel/libelf
|
||||
BUILDLINK_DEPMETHOD.libelf?= build
|
||||
.endif # LIBELF_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/23 22:24:17 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2007/10/11 18:53:12 drochner Exp $
|
||||
|
||||
SHA1 (libelf-0.8.5.tar.gz) = 57bb3aa7d89c5ae902a27893e16d1222fdb1140f
|
||||
RMD160 (libelf-0.8.5.tar.gz) = 82539ffc8e75ee558aa9afaecacbd2747be1e672
|
||||
Size (libelf-0.8.5.tar.gz) = 132111 bytes
|
||||
SHA1 (libelf-0.8.10.tar.gz) = 5f6fb666b0cf604243110383ba55ef37df1c8ece
|
||||
RMD160 (libelf-0.8.10.tar.gz) = 097b3c18f34233bd9484f2ec53c65a84b2222f31
|
||||
Size (libelf-0.8.10.tar.gz) = 147824 bytes
|
||||
SHA1 (patch-aa) = bb70182806c0541e46af884e324d6ae2b8831665
|
||||
SHA1 (patch-ab) = d04cb8da2a84478b15d4ff71cc45e30fc35d1a23
|
||||
|
|
53
devel/libelf/patches/patch-ab
Normal file
53
devel/libelf/patches/patch-ab
Normal file
|
@ -0,0 +1,53 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/10/11 18:53:12 drochner Exp $
|
||||
|
||||
--- lib/Makefile.in.orig 2007-06-29 23:39:10.000000000 +0200
|
||||
+++ lib/Makefile.in
|
||||
@@ -77,13 +77,9 @@ topdir = ..
|
||||
subdir = lib
|
||||
|
||||
.SUFFIXES:
|
||||
-.SUFFIXES: .c .o
|
||||
-.c.o:
|
||||
- @$(RM) $@ $(@:.o=.os)
|
||||
- if test -n "$(PICFLAGS)"; then \
|
||||
- $(COMPILE) $(PICFLAGS) $< && $(MV) $@ $(@:.o=.os); \
|
||||
- else true; fi
|
||||
- $(COMPILE) $<
|
||||
+.SUFFIXES: .c .lo
|
||||
+.c.lo:
|
||||
+ ${LIBTOOL} --mode=compile $(COMPILE) ${.IMPSRC} -o ${.TARGET}
|
||||
|
||||
INCLUDES = -I$(topdir) -I. -I$(srcdir)
|
||||
|
||||
@@ -144,17 +140,16 @@ PRIVHDRS = byteswap.h errors.h ext_types
|
||||
DISTFILES = $(SRCS) $(LIBSRCS) $(HDRS) $(PRIVHDRS) Makefile.in sys_elf.h.in \
|
||||
Makefile.w32 build.bat config.h.w32 libelf.def sys_elf.h.w32
|
||||
|
||||
-all: libelf.a shared-$(DO_SHLIB)
|
||||
+all: libelf.la shared-$(DO_SHLIB)
|
||||
|
||||
check:
|
||||
|
||||
shared-yes: $(SHLIB)
|
||||
shared-no:
|
||||
|
||||
-libelf.a: $(OBJS) $(LIBOBJS)
|
||||
- @$(RM) $@
|
||||
- $(AR) rcv $@ $(OBJS) $(LIBOBJS)
|
||||
- $(RANLIB) $@
|
||||
+libelf.la: $(OBJS:.o=.lo) $(LIBOBJS:.o=.lo)
|
||||
+ ${LIBTOOL} --mode=link ${CC} $(OBJS:.o=.lo) $(LIBOBJS:.o=.lo) -o libelf.la \
|
||||
+ ${LDFLAGS} -rpath ${PREFIX}/lib
|
||||
|
||||
$(SHLIB): libelf.a
|
||||
@$(RM) $(SHLIB)
|
||||
@@ -175,8 +170,7 @@ installdirs: $(top_srcdir)/mkinstalldirs
|
||||
done
|
||||
|
||||
install-data: all installdirs
|
||||
- $(INSTALL_DATA) libelf.a $(instroot)$(libdir)
|
||||
- -cd $(instroot)$(libdir) && $(RANLIB) libelf.a
|
||||
+ ${LIBTOOL} --mode=install $(INSTALL_DATA) libelf.la $(instroot)$(libdir)
|
||||
files="$(HDRS) $(AUXHDRS) elf_repl.h"; for file in $$files; do \
|
||||
if test -r $$file; then \
|
||||
$(INSTALL_DATA) $$file $(instroot)$(includedir)/libelf; \
|
Loading…
Reference in a new issue