import grace, a graphing tool based on xmgr
This commit is contained in:
parent
a05c844ba4
commit
9d0a6895d8
8 changed files with 214 additions and 0 deletions
33
math/grace/Makefile
Normal file
33
math/grace/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/02/03 19:47:40 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= grace-5.0.5
|
||||
CATEGORIES= math graphics x11
|
||||
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/
|
||||
|
||||
MAINTAINER= drochner@netbsd.org
|
||||
HOMEPAGE= http://plasma-gate.weizmann.ac.il/Grace/
|
||||
|
||||
DEPENDS+= xpm-3.4k:../../graphics/xpm
|
||||
DEPENDS+= netcdf:../../devel/netcdf
|
||||
DEPENDS+= jpeg-*:../../graphics/jpeg
|
||||
DEPENDS+= tiff-*:../../graphics/tiff
|
||||
DEPENDS+= pdflib-*:../../print/pdflib
|
||||
DEPENDS+= t1lib-*:../../textproc/t1lib
|
||||
DEPENDS+= Xbae-*:../../x11/Xbae
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_FORTRAN= yes
|
||||
USE_MOTIF= yes
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --enable-grace-home=${PREFIX}/grace \
|
||||
--enable-extra-incpath=${LOCALBASE}/include
|
||||
|
||||
ALL_TARGET=
|
||||
MAKE_ENV+= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
|
||||
|
||||
post-install:
|
||||
${RM} -f ${PREFIX}/bin/xmgrace
|
||||
${LN} -s ${PREFIX}/grace/bin/xmgrace ${PREFIX}/bin
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
math/grace/files/md5
Normal file
3
math/grace/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/02/03 19:47:41 drochner Exp $
|
||||
|
||||
MD5 (grace-5.0.5.tar.gz) = bf94942461c6bee4d985c8cfe414346d
|
4
math/grace/files/patch-sum
Normal file
4
math/grace/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/02/03 19:47:41 drochner Exp $
|
||||
|
||||
MD5 (patch-aa) = cefe25773d50c2069ecd533b0f8c705e
|
||||
MD5 (patch-ab) = ff5230821b8d805609b9b851bcfe2fe5
|
13
math/grace/patches/patch-aa
Normal file
13
math/grace/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/02/03 19:47:41 drochner Exp $
|
||||
|
||||
--- examples/Makefile.orig Sat Oct 23 00:36:31 1999
|
||||
+++ examples/Makefile Thu Feb 3 11:52:37 2000
|
||||
@@ -32,7 +32,7 @@
|
||||
install : $(EXAMPLES) $(DOTEST)
|
||||
$(MKINSTALLDIRS) $(GRACE_HOME)/examples
|
||||
for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
|
||||
- $(INSTALL_PROGRAM) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
|
||||
+ $(INSTALL_SCRIPT) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
|
||||
|
||||
links : dummy
|
||||
|
22
math/grace/patches/patch-ab
Normal file
22
math/grace/patches/patch-ab
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2000/02/03 19:47:41 drochner Exp $
|
||||
|
||||
--- auxiliary/Makefile.orig Fri Sep 24 23:23:51 1999
|
||||
+++ auxiliary/Makefile Thu Feb 3 12:00:25 2000
|
||||
@@ -9,7 +9,8 @@
|
||||
include $(TOP)/Make.conf
|
||||
|
||||
AUXILIARIES = README convcal.c magic.grace
|
||||
-PROGRAMS = fdf2fit convcal$(EXE)
|
||||
+PROGRAMS = convcal$(EXE)
|
||||
+SCRIPTS = fdf2fit
|
||||
|
||||
all : convcal$(EXE)
|
||||
|
||||
@@ -26,6 +27,7 @@
|
||||
$(MKINSTALLDIRS) $(GRACE_HOME)/auxiliary
|
||||
for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/auxiliary; done
|
||||
for i in $(PROGRAMS); do $(INSTALL_PROGRAM) $$i $(GRACE_HOME)/bin; done
|
||||
+ for i in $(SCRIPTS); do $(INSTALL_SCRIPT) $$i $(GRACE_HOME)/bin; done
|
||||
|
||||
tests : dummy
|
||||
|
1
math/grace/pkg/COMMENT
Normal file
1
math/grace/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
GRaphing, Advanced Computation and Exploration of data
|
11
math/grace/pkg/DESCR
Normal file
11
math/grace/pkg/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
Grace is a tool to make two-dimensional plots of scientific
|
||||
data. It runs under various (if not all) flavours of UNIX
|
||||
with X11 and Motif. Its capabilities are roughly similar to
|
||||
GUI-based programs like Sigmaplot or Microcal Origin plus
|
||||
script-based tools like gnuplot or Genplot. Its strength
|
||||
lies in the fact that it combines the convenience of a
|
||||
graphical user interface with the power of a scripting
|
||||
language which enables it to do sophisticated calculations
|
||||
or perform automated tasks.
|
||||
Grace is derived from Xmgr (a.k.a. ACE/gr), originally
|
||||
written by Paul Turner.
|
127
math/grace/pkg/PLIST
Normal file
127
math/grace/pkg/PLIST
Normal file
|
@ -0,0 +1,127 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/02/03 19:47:41 drochner Exp $
|
||||
bin/xmgrace
|
||||
grace/bin/gracebat
|
||||
grace/bin/xmgrace
|
||||
grace/bin/grconvert
|
||||
grace/bin/convcal
|
||||
grace/bin/fdf2fit
|
||||
grace/lib/libgrace_np.a
|
||||
grace/include/grace_np.h
|
||||
grace/fonts/FontDataBase
|
||||
grace/fonts/type1/n021003l.pfb
|
||||
grace/fonts/type1/n021023l.pfb
|
||||
grace/fonts/type1/n021004l.pfb
|
||||
grace/fonts/type1/n021024l.pfb
|
||||
grace/fonts/type1/n019003l.pfb
|
||||
grace/fonts/type1/n019023l.pfb
|
||||
grace/fonts/type1/n019004l.pfb
|
||||
grace/fonts/type1/n019024l.pfb
|
||||
grace/fonts/type1/n022003l.pfb
|
||||
grace/fonts/type1/n022023l.pfb
|
||||
grace/fonts/type1/n022004l.pfb
|
||||
grace/fonts/type1/n022024l.pfb
|
||||
grace/fonts/type1/d050000l.pfb
|
||||
grace/fonts/type1/s050000l.pfb
|
||||
grace/fonts/type1/d050000l.afm
|
||||
grace/fonts/type1/n019003l.afm
|
||||
grace/fonts/type1/n019004l.afm
|
||||
grace/fonts/type1/n019023l.afm
|
||||
grace/fonts/type1/n019024l.afm
|
||||
grace/fonts/type1/n021003l.afm
|
||||
grace/fonts/type1/n021004l.afm
|
||||
grace/fonts/type1/n021023l.afm
|
||||
grace/fonts/type1/n022003l.afm
|
||||
grace/fonts/type1/n022023l.afm
|
||||
grace/fonts/type1/n022004l.afm
|
||||
grace/fonts/type1/n022024l.afm
|
||||
grace/fonts/type1/n021024l.afm
|
||||
grace/fonts/type1/s050000l.afm
|
||||
grace/fonts/enc/IsoLatin1.enc
|
||||
grace/fonts/enc/IsoLatin2.enc
|
||||
grace/templates/Default.agr
|
||||
grace/doc/CHANGES.html
|
||||
grace/doc/GPL.html
|
||||
grace/doc/philosophical-gnu-sm.jpg
|
||||
grace/doc/nohelp.html
|
||||
grace/doc/FAQ.html
|
||||
grace/doc/Tutorial.html
|
||||
grace/doc/UsersGuide.html
|
||||
grace/doc/FAQ.dvi
|
||||
grace/doc/Tutorial.dvi
|
||||
grace/doc/UsersGuide.dvi
|
||||
grace/doc/2.1.dat
|
||||
grace/doc/3.dat
|
||||
grace/doc/7.1.2.agr
|
||||
grace/doc/7.1.3.agr
|
||||
grace/doc/8.2.dat
|
||||
grace/doc/10.1.dat
|
||||
grace/doc/10a.dat
|
||||
grace/doc/10c.dat
|
||||
grace/doc/10b.dat
|
||||
grace/doc/shiftdata.sh
|
||||
grace/doc/mygraph.png
|
||||
grace/doc/grace.1
|
||||
grace/doc/gracebat.1
|
||||
grace/doc/xmgrace.1
|
||||
grace/doc/grconvert.1
|
||||
grace/examples/altaxis.par
|
||||
grace/examples/logtest.par
|
||||
grace/examples/times.agr
|
||||
grace/examples/au.agr
|
||||
grace/examples/manygraphs.agr
|
||||
grace/examples/terr.agr
|
||||
grace/examples/tinset.agr
|
||||
grace/examples/axes.agr
|
||||
grace/examples/mlo.dat
|
||||
grace/examples/tlog.agr
|
||||
grace/examples/log2.agr
|
||||
grace/examples/bar.agr
|
||||
grace/examples/explain.agr
|
||||
grace/examples/moresyms.agr
|
||||
grace/examples/test.com
|
||||
grace/examples/tmc.c
|
||||
grace/examples/fills.agr
|
||||
grace/examples/props.agr
|
||||
grace/examples/test.dat
|
||||
grace/examples/chartebar.agr
|
||||
grace/examples/charts.agr
|
||||
grace/examples/graphs.par
|
||||
grace/examples/regions.par
|
||||
grace/examples/test1.par
|
||||
grace/examples/tstack.agr
|
||||
grace/examples/brw.dat
|
||||
grace/examples/hilo.agr
|
||||
grace/examples/test2.agr
|
||||
grace/examples/arrows.agr
|
||||
grace/examples/txyr.agr
|
||||
grace/examples/co2.agr
|
||||
grace/examples/log.dat
|
||||
grace/examples/stackedb.agr
|
||||
grace/examples/tfonts.agr
|
||||
grace/examples/typeset.agr
|
||||
grace/examples/xyz.agr
|
||||
grace/examples/co2.par
|
||||
grace/examples/logistic.agr
|
||||
grace/examples/logistic.fit
|
||||
grace/examples/symslines.agr
|
||||
grace/examples/tforms.par
|
||||
grace/examples/polar.agr
|
||||
grace/examples/motif.agr
|
||||
grace/examples/spectrum.agr
|
||||
grace/examples/dotest
|
||||
grace/auxiliary/README
|
||||
grace/auxiliary/convcal.c
|
||||
grace/auxiliary/magic.grace
|
||||
grace/gracerc
|
||||
grace/gracerc.user
|
||||
@dirrm grace/bin
|
||||
@dirrm grace/lib
|
||||
@dirrm grace/include
|
||||
@dirrm grace/fonts/type1
|
||||
@dirrm grace/fonts/enc
|
||||
@dirrm grace/fonts
|
||||
@dirrm grace/templates
|
||||
@dirrm grace/doc
|
||||
@dirrm grace/examples
|
||||
@dirrm grace/auxiliary
|
||||
@dirrm grace
|
Loading…
Reference in a new issue