Fix build with new libtool (as seen in bulk builds).
autoconf code from xmms, since I think the rest of the infrastructure comes from there too.
This commit is contained in:
parent
d2c7fc821c
commit
9d0ed269c2
3 changed files with 269 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.7 2006/01/05 14:46:46 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2006/02/16 18:05:58 wiz Exp $
|
||||
|
||||
SHA1 (xmms-sid-0.7.4.tar.gz) = 9ccf412e7c9759ae69ca78dee0895bdb724df9e8
|
||||
RMD160 (xmms-sid-0.7.4.tar.gz) = e359daf6fd3a7f3d9a40ae9ca8daa2c27ddb6f63
|
||||
|
@ -6,3 +6,5 @@ Size (xmms-sid-0.7.4.tar.gz) = 226916 bytes
|
|||
SHA1 (patch-aa) = fb0558110b61f54eab42cd805f9ffb2cdfa2617a
|
||||
SHA1 (patch-ab) = 772dc1e50401516de9b5a6844dc7c93c2f1fbc2b
|
||||
SHA1 (patch-ac) = b8cea4e8bf7742dec63143f30141cb48ee946260
|
||||
SHA1 (patch-ad) = e67c0a99ece07ae5e28ac1b6d169eff61bcb2bf6
|
||||
SHA1 (patch-ae) = fae2c22765c1cdc8e6bf3b78b4016e9d6cbd0bb9
|
||||
|
|
41
audio/xmms-sid/patches/patch-ad
Normal file
41
audio/xmms-sid/patches/patch-ad
Normal file
|
@ -0,0 +1,41 @@
|
|||
$NetBSD: patch-ad,v 1.1 2006/02/16 18:05:58 wiz Exp $
|
||||
|
||||
--- configure.in.orig 2002-09-02 21:12:52.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -43,6 +43,36 @@ AM_PATH_GLIB(1.2.2,,AC_MSG_ERROR([*** GL
|
||||
AM_PATH_GTK(1.2.2,,AC_MSG_ERROR([*** Gtk+ >= 1.2.2 not found. You either don't have Gtk+ at all or your Gtk+ is too old. Latest Gtk+ can be found from Gtk+ homepages (http://www.gtk.org/)]), gthread)
|
||||
|
||||
|
||||
+PTHREAD_LIBS=error
|
||||
+AC_MSG_CHECKING(for old style FreeBSD -pthread flag)
|
||||
+AC_EGREP_CPP(yes,
|
||||
+[#if (defined(__FreeBSD_cc_version) && __FreeBSD_cc_version <= 500001) || defined(__OpenBSD__)
|
||||
+ yes
|
||||
+ #endif
|
||||
+ ], AC_MSG_RESULT(yes)
|
||||
+ CFLAGS="$CFLAGS -D_THREAD_SAFE" PTHREAD_LIBS="-pthread",
|
||||
+ AC_MSG_RESULT(no))
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ AC_CHECK_LIB(pthread, pthread_attr_init,
|
||||
+ PTHREAD_LIBS="-lpthread")
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ AC_CHECK_LIB(pthreads, pthread_attr_init,
|
||||
+ PTHREAD_LIBS="-lpthreads")
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ AC_CHECK_LIB(c_r, pthread_attr_init,
|
||||
+ PTHREAD_LIBS="-lc_r")
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ AC_CHECK_FUNC(pthread_attr_init, PTHREAD_LIBS="")
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ AC_MSG_ERROR(*** Unable to locate working posix thread library ***)
|
||||
+fi
|
||||
+AC_SUBST(PTHREAD_LIBS)
|
||||
+
|
||||
+
|
||||
dnl ***
|
||||
dnl *** Song position patch check
|
||||
dnl ***
|
225
audio/xmms-sid/patches/patch-ae
Normal file
225
audio/xmms-sid/patches/patch-ae
Normal file
|
@ -0,0 +1,225 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/02/16 18:05:58 wiz Exp $
|
||||
|
||||
--- configure.orig 2006-02-16 10:04:26.000000000 +0000
|
||||
+++ configure
|
||||
@@ -6892,8 +6841,212 @@ rm -f conftest*
|
||||
|
||||
|
||||
|
||||
+PTHREAD_LIBS=error
|
||||
+echo $ac_n "checking for old style FreeBSD -pthread flag""... $ac_c" 1>&6
|
||||
+echo "configure:6847: checking for old style FreeBSD -pthread flag" >&5
|
||||
+cat > conftest.$ac_ext <<EOF
|
||||
+#line 6849 "configure"
|
||||
+#include "confdefs.h"
|
||||
+#if (defined(__FreeBSD_cc_version) && __FreeBSD_cc_version <= 500001) || defined(__OpenBSD__)
|
||||
+ yes
|
||||
+ #endif
|
||||
+
|
||||
+EOF
|
||||
+if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
|
||||
+ egrep "yes" >/dev/null 2>&1; then
|
||||
+ rm -rf conftest*
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ CFLAGS="$CFLAGS -D_THREAD_SAFE" PTHREAD_LIBS="-pthread"
|
||||
+else
|
||||
+ rm -rf conftest*
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ echo $ac_n "checking for pthread_attr_init in -lpthread""... $ac_c" 1>&6
|
||||
+echo "configure:6869: checking for pthread_attr_init in -lpthread" >&5
|
||||
+ac_lib_var=`echo pthread'_'pthread_attr_init | sed 'y%./+-%__p_%'`
|
||||
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ ac_save_LIBS="$LIBS"
|
||||
+LIBS="-lpthread $LIBS"
|
||||
+cat > conftest.$ac_ext <<EOF
|
||||
+#line 6877 "configure"
|
||||
+#include "confdefs.h"
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char pthread_attr_init();
|
||||
+
|
||||
+int main() {
|
||||
+pthread_attr_init()
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:6888: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=no"
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+LIBS="$ac_save_LIBS"
|
||||
+
|
||||
+fi
|
||||
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ PTHREAD_LIBS="-lpthread"
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ echo $ac_n "checking for pthread_attr_init in -lpthreads""... $ac_c" 1>&6
|
||||
+echo "configure:6911: checking for pthread_attr_init in -lpthreads" >&5
|
||||
+ac_lib_var=`echo pthreads'_'pthread_attr_init | sed 'y%./+-%__p_%'`
|
||||
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ ac_save_LIBS="$LIBS"
|
||||
+LIBS="-lpthreads $LIBS"
|
||||
+cat > conftest.$ac_ext <<EOF
|
||||
+#line 6919 "configure"
|
||||
+#include "confdefs.h"
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char pthread_attr_init();
|
||||
+
|
||||
+int main() {
|
||||
+pthread_attr_init()
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:6930: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=no"
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+LIBS="$ac_save_LIBS"
|
||||
+
|
||||
+fi
|
||||
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ PTHREAD_LIBS="-lpthreads"
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ echo $ac_n "checking for pthread_attr_init in -lc_r""... $ac_c" 1>&6
|
||||
+echo "configure:6953: checking for pthread_attr_init in -lc_r" >&5
|
||||
+ac_lib_var=`echo c_r'_'pthread_attr_init | sed 'y%./+-%__p_%'`
|
||||
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ ac_save_LIBS="$LIBS"
|
||||
+LIBS="-lc_r $LIBS"
|
||||
+cat > conftest.$ac_ext <<EOF
|
||||
+#line 6961 "configure"
|
||||
+#include "confdefs.h"
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char pthread_attr_init();
|
||||
+
|
||||
+int main() {
|
||||
+pthread_attr_init()
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:6972: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_lib_$ac_lib_var=no"
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+LIBS="$ac_save_LIBS"
|
||||
+
|
||||
+fi
|
||||
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ PTHREAD_LIBS="-lc_r"
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ echo $ac_n "checking for pthread_attr_init""... $ac_c" 1>&6
|
||||
+echo "configure:6995: checking for pthread_attr_init" >&5
|
||||
+if eval "test \"`echo '$''{'ac_cv_func_pthread_attr_init'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ cat > conftest.$ac_ext <<EOF
|
||||
+#line 7000 "configure"
|
||||
+#include "confdefs.h"
|
||||
+/* System header to define __stub macros and hopefully few prototypes,
|
||||
+ which can conflict with char pthread_attr_init(); below. */
|
||||
+#include <assert.h>
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char pthread_attr_init();
|
||||
+
|
||||
+int main() {
|
||||
+
|
||||
+/* The GNU C library defines this for functions which it implements
|
||||
+ to always fail with ENOSYS. Some functions are actually named
|
||||
+ something starting with __ and the normal name is an alias. */
|
||||
+#if defined (__stub_pthread_attr_init) || defined (__stub___pthread_attr_init)
|
||||
+choke me
|
||||
+#else
|
||||
+pthread_attr_init();
|
||||
+#endif
|
||||
+
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:7023: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_func_pthread_attr_init=yes"
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_func_pthread_attr_init=no"
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+fi
|
||||
+
|
||||
+if eval "test \"`echo '$ac_cv_func_'pthread_attr_init`\" = yes"; then
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ PTHREAD_LIBS=""
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+
|
||||
+fi
|
||||
+if test "x$PTHREAD_LIBS" = xerror; then
|
||||
+ { echo "configure: error: *** Unable to locate working posix thread library ***" 1>&2; exit 1; }
|
||||
+fi
|
||||
+
|
||||
+
|
||||
+
|
||||
echo $ac_n "checking for song position patch""... $ac_c" 1>&6
|
||||
echo "configure:6897: checking for song position patch" >&5
|
||||
tmp_CPPFLAGS=$CPPFLAGS
|
||||
if test -d "$prefix" ;then
|
||||
CPPFLAGS="$CPPFLAGS -I${prefix}/include"
|
||||
@@ -7126,6 +7277,7 @@ s%@GLIB_LIBS@%$GLIB_LIBS%g
|
||||
s%@GTK_CONFIG@%$GTK_CONFIG%g
|
||||
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
|
||||
s%@GTK_LIBS@%$GTK_LIBS%g
|
||||
+s%@PTHREAD_LIBS@%$PTHREAD_LIBS%g
|
||||
|
||||
CEOF
|
||||
EOF
|
Loading…
Reference in a new issue